+ Responder ao Tópico



  1. #1
    andreytalamonte
    Visitante

    Padrão para habilitar 3D no X

    Ae pessoal,
    Eu tenho uma placa NV GF5700 instalada com o drive da propria nvidia, mas a placa esta funcionando sem o suporte a 3D. com a opção direct rendering= no.
    Só que eu não sei em qual arquivo eu mexo pra habilitar esse troço.
    Algúem pode ajudar???

  2. #2
    luccosta
    Visitante

    Padrão para habilitar 3D no X


    Caro amigo,

    Por se tratar de uma placa NVidia, o recomendado é que vc execute as modificações no xorg.conf que por padrao esta em:
    /etc/X11/xorg.conf

    Este arquivo deve ser manipulado como root, desta forma recomendo, antes de mais nada, fazer um back-up do mesmo.

    Para a instalação do drive e correta configuração dos arquivos necessários acesse o link abaixo:

    NVidia Install Driver

    Acho que isto te ajudará muito, se for possível informa a distro e a versão .

    Abrax. :good:



  3. #3
    andreytalamonte
    Visitante

    Padrão ,,,

    ,,,,

  4. #4
    andreytalamonte
    Visitante

    Padrão ,,,

    ,,,



  5. #5
    andreytalamonte
    Visitante

    Padrão Eu ja fiz isso, nao influenciou em nada

    Amigo,

    Eu to usando o Debian Sarge 3.1, o meu arquivo de conf é o /etc/X11/XF86config-4
    a configuração dele é a seguinte:

    Section "Files"
    FontPath "unix/:7100" # local font server
    # if the local font server has problems, we can fall back on these
    FontPath "/usr/lib/X11/fonts/misc"
    FontPath "/usr/lib/X11/fonts/cyrillic"
    FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/lib/X11/fonts/Type1"
    FontPath "/usr/lib/X11/fonts/CID"
    FontPath "/usr/lib/X11/fonts/Speedo"
    FontPath "/usr/lib/X11/fonts/100dpi"
    FontPath "/usr/lib/X11/fonts/75dpi"
    EndSection

    Section "Module"
    # Load "GLcore" comentei
    Load "bitmap"
    Load "dbe"
    Load "ddc"
    # Load "dri" comentei
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "record"
    Load "speedo"
    Load "type1"
    Load "vbe"
    Load "nvidia" acrescentei
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "keyboard"
    Option "CoreKeyboard"
    Option "XkbRules" "xfree86"
    Option "XkbModel" "abnt2"
    Option "XkbLayout" "br"
    Option "XkbVariant" "abnt2"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "Emulate3Buttons" "true"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Device"
    Identifier "Placa de Vídeo NVidia GF5700 256MB"
    Driver "nvidia"
    EndSection

    Section "Monitor"
    Identifier "DWE:2714"
    HorizSync 28-38
    VertRefresh 43-72
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "Placa de Vídeo NVidia GF5700 256MB"
    Monitor "DWE:2714"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    **não repara no monitor não hehehe eh um 14"" que ta xubxituindo o outro de 17"" que foi arrumar =)

    Mais alguma idéia? Eu acho que tem um outro arquivo que eu mexo pra habilitar o "direct rendenring" que é a aceleração por harware.( não eh isso??)
    Vlwz!!