+ Responder ao Tópico



  1. Salve, Salve galera!

    Bom.. Cenario..

    eth1(pcmcia com cartão orinoco) - 192.168.100.x
    eth0(rede interna) - 192.168.0.x

    Código :
    echo "1" >/proc/sys/net/ipv4/ip_forward 
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE


    Problema:

    Os terminais(windows) devidamente configurados para navegar através do NAT(e navegam normalmente), porém, nao enviam email com anexo, emails pequenos(sem anexo) vai normal, mas emails com uma certa quantidade de caracteres ou anexos nem pensar...

    Bom..pensei que poderia ser problema de sinal,que ocasionaria problema de upload, pegamos um notebook e colocamos o cartao nele, compartilhamos a net e pimba.. funciona..

    Bom... alguem tem alguma idéia?

    Com Linux, fazendo Nat, navega, mas nao vai email com anexo
    Com Windows, na mesma antena/cartao, funciona tudo...


    Algum palpite?

    Fedora Core 3
    Linux blabla 2.6.12-1.1376_FC3 #1 Fri Aug 26 23:27:19 EDT 2005 i586 i586 i386 GNU/Linux



    Valeu qualquer dica...
    _________________

  2. Vc usa controle de banda aí (upload)? Qual? Se tiver, já testou com ele desabilitado?



  3. Sem controle de velocidade nenhum..

    Exceto no provedor é claro!

  4. #4
    antoniobrandao
    Estou tendo problemas parecidos com fedora 3 e htb. Emails grandes nã funcionam. Desliguem o htb e mesmo assim nao funciona.

    Não fiz o teste colocando o windows pra compartilhar (como vc disse).

    Por outro lado, nos clientes onde o email não funciona observei que há perda de pacotes durante o ping.

    Um dos clientes usa notebook e na casa delle ocorre o problema. Trouxe o note dele na empresa e conectado na rede local funcionou. Portanto é algo relacionado ao wireless mesmo.

    Acredito que o wireless perde alguns pacotes e o kernel do linux reseta a conexao ao aparecerem pacotes foram a ordem TCP (estado INVALID do iptables). Será que pode ser isso?



  5. #5
    Quando a perda de pacotes é acentuada, e pode ter certeza que você terá esse tipo de problemas. Se você testar com o ping, verifique que cada vez que você aumenta o tamanho do pacote, a percentagem de perda sobe ainda mais...

    Nos meus clientes quando estão com problema com emails normalmente é isso e a solução só achando o equipamento defeituosos que pode estar ocasionando ruído na rede interna, no caso da parte física da rede, com cabeamento, ou melhorando a conexão WiFi, quando o problema é em relação a rede.






Tópicos Similares

  1. Email com anexo por PHP
    Por ajsmit no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 24-04-2006, 16:12
  2. NAT + Nao envia email com anexo
    Por cebolark no fórum Servidores de Rede
    Respostas: 0
    Último Post: 06-10-2005, 16:09
  3. Email com anexo no console para GMAIL ? :P
    Por DropALL no fórum Servidores de Rede
    Respostas: 0
    Último Post: 06-04-2005, 08:17
  4. email com anexo
    Por ajsmit no fórum Servidores de Rede
    Respostas: 1
    Último Post: 19-08-2003, 20:11
  5. problema em enviar email com anexo
    Por offs no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-05-2003, 07:27

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L