+ Responder ao Tópico



  1. #1
    Ale_tlk
    Pessoal,

    Quem puder nos de uma dica por favor pois estamos c/ um problemão aqui. Obrigado. Ai vai...

    Seguinte, precisamos saber como atribuir ip válido dentro de nossa rede. Somos provedor de internet a radio e em nossa infraestrutura usamos uma rede 10.1.0.0 e nosso servidor possui uma interface wlan com tudo concentrado nele. Estamos utilizando o Conectiva 10 e para controle de banda usamos o htb, nosso link é da Telefonica c/ acesso a rede ip e dispomos de 64 ips validos /192, meu roteador tem mascara 248, e estamos sem saber se é preciso atribuir algo no roteador, cujo modelo é um IBM2210.

  2. Pra vc nao ter que se bater muito com esse negocio de mascara e sub-mascara usa uma dica do jim que ta aqui no site mesmo, utilizando proxy_arp que vai resolver o seu problema sem muito esforço !!!


    Valeu



  3. Pra vc nao ter que se bater muito com esse negocio de mascara e sub-mascara usa uma dica do jim que ta aqui no site mesmo, utilizando proxy_arp que vai resolver o seu problema sem muito esforço !!!


    Valeu

  4. Citação Postado originalmente por gatoseco
    Pra vc nao ter que se bater muito com esse negocio de mascara e sub-mascara usa uma dica do jim que ta aqui no site mesmo, utilizando proxy_arp que vai resolver o seu problema sem muito esforço !!!


    Valeu
    Caro Jean, diga uma coisa, tentei utilizar a solução de nosso amigo Jim aqui, e minha rede começou a dar conflito em toda ela. O que pode ser? Vc já se defrontou com isso?

    Valeu

    Paulo Henrique Menoni
    phmenoni@hotmail.com :good:



  5. Estranho isso meu amigo, mas esse ip que vc ta colocando no seu cliente na ta em uso nao teria como dar conflito !!!


    Posta mais detalhes desse problema !!!



    Valeu !!!

  6. Citação Postado originalmente por gatoseco
    Estranho isso meu amigo, mas esse ip que vc ta colocando no seu cliente na ta em uso nao teria como dar conflito !!!


    Posta mais detalhes desse problema !!!



    Valeu !!!
    Vamos lá:

    Tenho uma rede formada por ips inválidos, tenho um link dedicado com 64 ips válidos. Atualmente não repasso ips válidos para os clientes, mas está existindo procura então resolvi utilizar o tuto do Jim pra fazer uns testes.

    Bom, subo as configurações belezinha, ponho o ip válido no micro, até aí blz tb, mas as máquinas dos meus clientes que estão com ip inválido começam a dar conflito de ip depois dessas configurações. Então removo essas configurações e reinicio o server, e vouta tudo ao normal.

    É estranho, pois já vi algumas pessoas aqui reclamarem do mesmo problema, dizendo que o proxy_arp deixa a rede maluca.

    Utilizo o Conectiva 10, com kernel 2.6...

    Exemplo da minha configuração:

    echo "1" > /proc/sys/net/ipv4/conf/eth0/proxy_arp - Rede ligada ao roteador
    echo "1" > /proc/sys/net/ipv4/conf/eth1/proxy_arp - Rede local
    route add -host 201.111.111.2 dev eth1 - Ip a ser atribuido ao cliente

    No cliente configuro:

    IP: 201.111.111.2 - ip da rota criada no linux
    Gateway: 201.111.111.1 - ip do roteador

    Pronto. Inicializo isso e começa a dar pau na rede toda, conflito de ip em tudo.

    Fiz isso sem regra alguma no firewall, mesmo assim acontece a mesma coisa.

    O que será que pode ser isso? Essa é a melhor solução pra ip válido no meu caso.

    Valew até aqui...

    Paulo :good:



  7. Olá,
    não recomendo o uso do proxy_arp, faça como na internet de verdade: use rotas.

    Se voce tem na sua rede valida por exemplo:

    roteador: 200.0.0.1
    gateway dos clientes:
    eth0: 200.0.0.2
    eth1: 192.168.0.1

    vc criar uma rota estática no roteador dizendo que parte da rede está atras do gateway:

    roteador:
    200.0.0.128 255.255.255.128 200.0.0.2

    na eth1 vc adiciona um ip desse range que roteaou:
    # ip addr add 200.0.0.129/25 brd + dev eth0

    e no cliente vc pode usar de .130 a .254

    Muito melhor e mais seguro que fazer na camada de enlace.

    Seu gateway vai ficar assim:

    eth0: 200.0.0.2
    eth1:
    192.168.0.1
    200.0.0.129

  8. Citação Postado originalmente por phmenoni
    Citação Postado originalmente por gatoseco
    Estranho isso meu amigo, mas esse ip que vc ta colocando no seu cliente na ta em uso nao teria como dar conflito !!!


    Posta mais detalhes desse problema !!!



    Valeu !!!
    Vamos lá:

    Tenho uma rede formada por ips inválidos, tenho um link dedicado com 64 ips válidos. Atualmente não repasso ips válidos para os clientes, mas está existindo procura então resolvi utilizar o tuto do Jim pra fazer uns testes.

    Bom, subo as configurações belezinha, ponho o ip válido no micro, até aí blz tb, mas as máquinas dos meus clientes que estão com ip inválido começam a dar conflito de ip depois dessas configurações. Então removo essas configurações e reinicio o server, e vouta tudo ao normal.

    É estranho, pois já vi algumas pessoas aqui reclamarem do mesmo problema, dizendo que o proxy_arp deixa a rede maluca.

    Utilizo o Conectiva 10, com kernel 2.6...

    Exemplo da minha configuração:

    echo "1" > /proc/sys/net/ipv4/conf/eth0/proxy_arp - Rede ligada ao roteador
    echo "1" > /proc/sys/net/ipv4/conf/eth1/proxy_arp - Rede local
    route add -host 201.111.111.2 dev eth1 - Ip a ser atribuido ao cliente

    No cliente configuro:

    IP: 201.111.111.2 - ip da rota criada no linux
    Gateway: 201.111.111.1 - ip do roteador

    Pronto. Inicializo isso e começa a dar pau na rede toda, conflito de ip em tudo.

    Fiz isso sem regra alguma no firewall, mesmo assim acontece a mesma coisa.

    O que será que pode ser isso? Essa é a melhor solução pra ip válido no meu caso.

    Valew até aqui...

    Paulo :good:
    Tenho a mesma estrutura aqui, até a distribuição e igual e com 5 ips validos passando pelo server que faz vpn entre matriz e filial, alem da rede invalida e ta passando blz. sem problema algum. Será que esses ips invalido ta vindo da eth que tem o link?!?!? faz um teste ai da um drop em tudo que vem da eth do link e libere somente o range de ips validos que vc tem. e veja o que acontece.

    Falou!!



  9. Citação Postado originalmente por oyama
    Citação Postado originalmente por phmenoni
    Citação Postado originalmente por gatoseco
    Estranho isso meu amigo, mas esse ip que vc ta colocando no seu cliente na ta em uso nao teria como dar conflito !!!


    Posta mais detalhes desse problema !!!



    Valeu !!!
    Vamos lá:

    Tenho uma rede formada por ips inválidos, tenho um link dedicado com 64 ips válidos. Atualmente não repasso ips válidos para os clientes, mas está existindo procura então resolvi utilizar o tuto do Jim pra fazer uns testes.

    Bom, subo as configurações belezinha, ponho o ip válido no micro, até aí blz tb, mas as máquinas dos meus clientes que estão com ip inválido começam a dar conflito de ip depois dessas configurações. Então removo essas configurações e reinicio o server, e vouta tudo ao normal.

    É estranho, pois já vi algumas pessoas aqui reclamarem do mesmo problema, dizendo que o proxy_arp deixa a rede maluca.

    Utilizo o Conectiva 10, com kernel 2.6...

    Exemplo da minha configuração:

    echo "1" > /proc/sys/net/ipv4/conf/eth0/proxy_arp - Rede ligada ao roteador
    echo "1" > /proc/sys/net/ipv4/conf/eth1/proxy_arp - Rede local
    route add -host 201.111.111.2 dev eth1 - Ip a ser atribuido ao cliente

    No cliente configuro:

    IP: 201.111.111.2 - ip da rota criada no linux
    Gateway: 201.111.111.1 - ip do roteador

    Pronto. Inicializo isso e começa a dar pau na rede toda, conflito de ip em tudo.

    Fiz isso sem regra alguma no firewall, mesmo assim acontece a mesma coisa.

    O que será que pode ser isso? Essa é a melhor solução pra ip válido no meu caso.

    Valew até aqui...

    Paulo :good:
    Tenho a mesma estrutura aqui, até a distribuição e igual e com 5 ips validos passando pelo server que faz vpn entre matriz e filial, alem da rede invalida e ta passando blz. sem problema algum. Será que esses ips invalido ta vindo da eth que tem o link?!?!? faz um teste ai da um drop em tudo que vem da eth do link e libere somente o range de ips validos que vc tem. e veja o que acontece.

    Falou!!
    Hoje tenho uma classe de ip 200.xxx.xxx.192/26 e divide esta casse em três ( 200.xxx.xxx.128/26, 200.xxx.xxx.192/26 e 200.xxx.xxx.144/28 ) agora tenho um grande problema a minha classe de ip 200.xxx.xxx.144/28 não consegue acessar nenhum serviços da minha outra classe. Alguém poderia ajuda?

  10. Citação Postado originalmente por phmenoni
    Citação Postado originalmente por gatoseco
    Pra vc nao ter que se bater muito com esse negocio de mascara e sub-mascara usa uma dica do jim que ta aqui no site mesmo, utilizando proxy_arp que vai resolver o seu problema sem muito esforço !!!


    Valeu
    Caro Jean, diga uma coisa, tentei utilizar a solução de nosso amigo Jim aqui, e minha rede começou a dar conflito em toda ela. O que pode ser? Vc já se defrontou com isso?

    Valeu

    Paulo Henrique Menoni

    phmenoni@hotmail.com :good:
    Tb utilizo o proxy_arp aki sem problema, inclusivew aceita controle de banda pelo cbq. Sua máscara de sub-rede está configurada corretamente?



  11. Citação Postado originalmente por ryiades
    Citação Postado originalmente por phmenoni
    Citação Postado originalmente por gatoseco
    Pra vc nao ter que se bater muito com esse negocio de mascara e sub-mascara usa uma dica do jim que ta aqui no site mesmo, utilizando proxy_arp que vai resolver o seu problema sem muito esforço !!!


    Valeu
    Caro Jean, diga uma coisa, tentei utilizar a solução de nosso amigo Jim aqui, e minha rede começou a dar conflito em toda ela. O que pode ser? Vc já se defrontou com isso?

    Valeu

    Paulo Henrique Menoni

    phmenoni@hotmail.com :good:
    Tb utilizo o proxy_arp aki sem problema, inclusivew aceita controle de banda pelo cbq. Sua máscara de sub-rede está configurada corretamente?
    aqui não utilizo o proxy_arp, pois não e muito confiável, aqui fiz como o Patrick falou, criei uma nova classe no meu roteador e configurei uma nova interface no meu server. O problema e que não ping e nem acesso neguem utilizando esta classe!!!

  12. Não sei se te ajuda. Veja o meu exemplo, fiz isso a semana passada.

    Na minha rede tenho um range de 128 ips reais direto no meu servidor de rádios. Então a partir dele eu jogo as redes pros servidores de rádio onde os clientes precisam.
    A minha rede de rádio é baseada em ips inválidos, na faixa 10.0.0.0/24

    IP do servidor do cliente que precisa de ip real
    10.0.0.25

    Joguei uma rede /30 no servidor 10.0.0.25
    route add -net 201.10.XX.160 netmask 255.255.255.252 gw 10.0.0.25

    Pronto, a rede já está 'batendo' no 10.0.0.25

    Agora, no 10.0.0.25, na eth interna, você cria um alias na placa com o ip 201.10.XX.161
    Esse ip .161 será o gateway do micro que você vai dar o ip real.

    IP do micro
    201.10.XX.162
    MASK
    255.255.255.252
    Gateway
    201.10.XX.161

    Pronto.
    Lembre que você precisa habilitar o forward na rede interna pro ip funcionar no micro do cliente.

    Espero ter ajuda.

    []



  13. Excelente dica !!!

    Valeu !!!






Tópicos Similares

  1. Como atribuir um ip publico a um servidor, sem usar NAT?
    Por Valter J Sabater no fórum Redes
    Respostas: 5
    Último Post: 31-01-2013, 15:39
  2. Como colocar um ip valido em uma repetidora?
    Por adelsonbbg no fórum Redes
    Respostas: 5
    Último Post: 03-08-2007, 07:47
  3. Respostas: 0
    Último Post: 19-03-2006, 22:29
  4. Como Acessar um Ip Via Internet para entrar numa maquina
    Por To-Doido no fórum Servidores de Rede
    Respostas: 17
    Último Post: 02-03-2004, 11:24
  5. Como Acessar um Ip Via Internet para entrar numa maquina
    Por To-Doido no fórum Servidores de Rede
    Respostas: 13
    Último Post: 15-02-2004, 14:37

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L