+ Responder ao Tópico



  1. #1
    evelincfa
    Visitante

    Padrão Compilação do kernel 2.6

    Estou tentando atualizar o meu kernel, mas obtenho o seguinte erro ao fazer make menuconfig:

    # make menuconfig
    HOSTCC scripts/kconfig/mconf.o
    scripts/kconfig/mconf.c:91: error: static declaration of 'current_menu' follows non-static declaration
    scripts/kconfig/lkc.h:63: error: previous declaration of 'current_menu' was here
    make[1]: ** [scripts/kconfig/mconf.o] Erro 1
    make: ** [menuconfig] Erro 2

    Será que falta alguma pacote?versão do gcc (meu gcc é versão 4)?

  2. #2
    bau
    Visitante

    Padrão Compilação do kernel 2.6

    Cara de fato é preciso as bibliotecas gcc....

    Qual a sua distro....!!!!

    Tenta instalar as bibliotecas gcc e tenta novamente!!!!!

    [ ]´s

    Bau



  3. #3
    evelincfa
    Visitante

    Padrão É o gcc

    Minha distro é o debian, mas...
    Pesquisei um pouco mais no google e olha só:

    On Tue, Jul 19, 2005 at 08:13:41PM -0400, Andres Salomon wrote:

    On Tue, 19 Jul 2005 23:49:12 +0200, Daniel Leidert wrote:


    Package: kernel-source-2.6.8
    Version: 2.6.8-16
    Severity: grave
    Justification: renders package unusable

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    The kernel does not compile with gcc 4.0:

    [..]
    HOSTCC scripts/kconfig/mconf.o
    scripts/kconfig/mconf.c:91: error: static declaration of 'current_menu'
    follows non-static declaration
    scripts/kconfig/lkc.h:63: error: previous declaration of 'current_menu'
    was here
    make[1]: *** [scripts/kconfig/mconf.o] Error 1
    make: *** [xconfig] Error 2



    Uh, right.. Horms, would you prefer to keep 2.6.8 in unstable for working
    on security stuff, or can we remove it?

    I'd like to keep it there. I'll take a look into how bad
    the gcc-4.0 issues are here. If its too painful, I guess
    we should pull 2.6.8 from unstable.

    Ou seja, o problema é o gcc4, até agora está indo bacan com o kernel 2.6.12