+ Responder ao Tópico



  1. #1
    mrsoliveira
    Visitante

    Padrão Instalação Courier-Imap (compilação não vai!)

    essoal,

    Eu estou com problemas para instalação do Courier-Imap, eu estou usando o CL10. Alguém sabe onde encontro os pacotes RPM para esta distro??

    Tentei compilar várias vezes seguindo exatamente como explicado, mas acontece o seguinte erro:
    checking build system type... mkdir: cannot create directory `/root/tmp/cg5819-17854': Permission denied
    mkdir: cannot create directory `/root/tmp/cg-5819': Permission denied
    config.guess: cannot create a temporary directory in /root/tmp
    configure: error: cannot guess build type; you must specify one
    configure: error: /bin/sh './configure' failed for maildir

    Eu estou compilando com usuário comum.

    Alguém tem alguma idéia de como resolver este problema ou um RPM pronto??

    Desde já agradeço a atenção de todos!
    _________________
    Vlw,
    Marcelo Oliveira

  2. #2
    mrsoliveira
    Visitante

    Padrão Instalação Courier-Imap (compilação não vai!)

    Amigos,

    Estou novamente precisando de um auxilio para colocar a funcionar o Courier-imap.

    Eu compilei como falava no tutorial, vários erros aconteceram, alguns fui remendando, mas provavelmente não ficou 100% pois na hora de colocar pra rodar ele mostra o seguinte:

    [[email protected] rc.d]# /etc/rc.d/imapd.rc start
    bash: /etc/rc.d/imapd.rc: Arquivo ou diretório não encontrado
    Obs.: Já criei o link para o local do arquivo,

    Também já tentei executar o arquivo diretamente da sua localização original, que também é um pouquinho estranha, visto que foi nesta pasta que coloquei os arquivos, mas eles deveriam de estar em outra pasta.

    [[email protected] courier-imap-3.0.3]# imapd.rc
    bash: imapd.rc: command not found
    [[email protected] courier-imap-3.0.3]# imap
    bash: imap: command not found
    [[email protected] courier-imap-3.0.3]# imapd
    * OK [CAPABILITY IMAP4REV1 LOGIN-REFERRALS STARTTLS AUTH=LOGIN] athenas.unidigital IMAP4rev1 2002.336cl at Tue, 18 Oct 2005 15:06:35 +0000 (UTC)
    Alguém pode me ajudar a descobrir como configurar corretamente este serviço???


    Desde logo grato a todos,

    Marcelo Oliveira



  3. #3

    Padrão Instalação Courier-Imap (compilação não vai!)

    tenta compilar como root

  4. #4
    mrsoliveira
    Visitante

    Padrão Instalação Courier-Imap (compilação não vai!)

    não funfa:

    configure: WARNING: === Do not compile Courier-IMAP as root. Compile
    configure: WARNING: === Courier-IMAP as a non-root user then su to
    configure: WARNING: === root before running make install. You must now
    configure: WARNING: === remove this entire directory and then extract the
    configure: WARNING: === source code from the tarball as a non-root user
    configure: WARNING: === and rerun the configure script. If you have read
    configure: WARNING: === the INSTALL file you should have known this. So
    configure: WARNING: === you better read INSTALL again.
    configure: error: aborted.



  5. #5

    Padrão Instalação Courier-Imap (compilação não vai!)

    Veja se a variável de ambiente que aponta para o diretório temporário está "setada" para /root/tmp, se estivar "sete" para /tmp e de um chmod 777 nesse diretório, pelo menos assim vc evita o erro da primeira mensagem postada

  6. #6
    hunt3r
    Visitante

    Padrão Instalação Courier-Imap (compilação não vai!)

    olha, talvez seja uma observação redundante ou ate besta, mas...
    o cl10 tem os pacotes do courier em .rpm ....

    apt-get update
    apt-get install courier-imap
    apt-get install courier-ssl
    apt-get install courier-authdaemon

    caso isso nao se aplique ao caso, tenta rodar o rc com o comando
    sh imapd.rc

    e da uma olhadinha na 1a. linha do arquivo (a que assigna o interpretador do script)..

    #!/bin/bash por ex...
    e veja se ela está apontado para um interpretador válido



  7. #7
    mrsoliveira
    Visitante

    Padrão Instalação Courier-Imap (compilação não vai!)

    cara to usando o Conectiva linux 10 e não é possivel encontrar nenhum pacote Courier* através do apt-get install..

    Você já consiguiu instalar estes pacotes no CL10???

    Qual distro você ta usando??

    Att

    Marcelo

  8. #8
    mrsoliveira
    Visitante

    Padrão Instalação Courier-Imap (compilação não vai!)

    Pessoal,

    Como faço para que não de os erros abaixo:


    Comando:
    [[email protected] courier-imap-3.0.3]# ./configure --with-authvchkpw --enable-unicode --with-authdaemon --disable-root-check --prefix=/usr --sysconfdir=/etc/courier-imap


    Erro ao final da execução:

    configure: error: /etc/lib_deps does not exist - upgrade vpopmail to the current version or fix the permissions on this file
    configure: error: /bin/sh './configure' failed for authlib
    You have new mail in /var/spool/mail/root

    Visto que tá dando um erro de Vpopmail, eu não gostaria de ter que instalar este pois to utilizando um tutorial da net que só precisa do courier!

    Desde já agradeço a atenção de todos,
    Obrigado


    --
    Marcelo Oliveira
    [email protected]



  9. #9

    Padrão Instalação Courier-Imap (compilação não vai!)

    compile com um usuário diferente de root e isso não deverá aparecer.

  10. #10
    mrsoliveira
    Visitante

    Padrão Instalação Courier-Imap (compilação não vai!)

    Agora o erro que acontece:::


    config.status: executing depfiles commands
    configure: configuring in maildir
    configure: running /bin/sh './configure' --prefix=/usr '--with-authvchkpw' '--enable-unicode''--without-authdaemon' '--disable-root-check' '--prefix=/usr' '--sysconfdir=/etc/courier-imap'--with-authchangepwdir=/usr/libexec/authlib --with-db=gdbm --with-userdb=/etc/userdb --with-makedatprog='/usr/libexec/makedatprog' --with-mailuser=root --without-socks --with-authchangepwdir=/var/tmp/dev/null --with-package=courier-imap --with-version=3.0.3 --cache-file=/dev/null --srcdir=.
    checking build system type... mkdir: cannot create directory `/root/tmp/cg11312-10085': Permission denied
    mkdir: cannot create directory `/root/tmp/cg-11312': Permission denied
    config.guess: cannot create a temporary directory in /root/tmp
    configure: error: cannot guess build type; you must specify one
    configure: error: /bin/sh './configure' failed for maildir
    [[email protected] courier-imap-3.0.3]$



  11. #11

    Padrão Instalação Courier-Imap (compilação não vai!)

    Cara eu já respondi isso acima, vou tentar explicar melhor. O diretório temporário está sendo apontado para /root/tmp nas suas configurações, vc tem que mudar isso e apontar o diretório para qualquer outro lugar diferente de barra /root/tmp onde o usuário com o qual vc está compilando tenha permissão de escrita. Se vc já estiver de saco cheio e quiser compilar logo isso, loga como root da chmod -R 777 /root, mas não fale para ninguém que vc fez isso.

  12. #12

    Padrão Re: Instalação Courier-Imap (compilação não vai!)

    Para compilar o courier você precisa estar como usuário comum, se você descompactou-o como root, mude as permissões do diretório para seu usuario !!!

    adduser gatoseco

    chown gatoseco:users /caminho/ondefoi/descomapctado/courier-imap-2.2.0/ -R

    # su gatoseco
    $ cd /caminho/ondefoi/descomapctado/courier-imap-2.2.0/
    $./configure--prefix=/usr --sysconfdir=/etc/courier/ --libexecdir=/usr/lib/courier
    $ make
    $ exit
    # checkinstall -S
    # make install-configure


    # cd /etc/courier
    # mkdir dist
    # mv *.dist dist/


    configura o authmysqlrc e pronto !!!


    Da um start nele como segue abaixo nem precisa crair link nem nada, e so pra dar problema !!!

    # /usr/lib/courier/imapd.rc start
    # /usr/lib/courier/pop3d.rc start


    Valeu !!!



  13. #13
    mrsoliveira
    Visitante

    Padrão Instalação Courier-Imap (compilação não vai!)

    Ok,

    Tudo feito, mas não starta:
    [[email protected] courier]# imapd.rc start
    bash: imapd.rc: command not found
    [[email protected] courier]# pop3d.rc start
    bash: pop3d.rc: command not found
    [[email protected] courier]# pop3d start
    bash: pop3d: command not found
    You have new mail in /var/spool/mail/root
    [[email protected] courier]#

    Onde devem ficar os arquivos de instalação do Courier???

    /etc/courier??
    /usr/lib/courier???


    Desde já agradeço a atenção de todos!

    Marcelo Oliveira