+ Responder ao Tópico



  1. #1

    Padrão NIS+NFS+autofs nao funciona

    Inicialmente, gostaria de sugerir a criacao de um forum especifico para NIS/NFS, caso tenham outras pessoas interessadas, pois é a 2a. vez que acabo usando o forum do Samba pra isso, e nao sei se é correto...

    Tentei, usando os diversos tutoriais na Net, fazer com que, apos o usuario logar via NIS em uma estacao, montar automaticamente seu homedir do servidor NFS, conforme passo-a-passo abaixo, mas nao deu certo. Ao rodar o autofs no servidor, trava tudo... o que pode estar errado abaixo?

    Servidor:
    1) Incluir no alvo all: do arquivo /var/yp/Makefile:
    all: auto.home auto.master ... outros ...
    2) Executar: make -C /var/yp;
    3) No arquivo /etc/auto.master incluir a linha abaixo:
    /home /etc/auto.home --timeout 60
    4) Criar o arquivo /etc/auto.home:
    * -rw,soft,intr 192.168.0.XX:/home/&
    5) Incluir no /etc/exports: /home 192.168.0.0(rw,sync,no_root_squash)
    6) Executar: service nfs restart; service ypserv restart; service autofs restart;
    ...NO AUTOFS TRAVA TUDO...

    Cliente:
    1) Dúvida: /home deve ser uma partição separada na estação? Pois é necessário desmontá-la nos tutoriais. Mas se for apenas um subdir da /?
    2) Dúvida em executar: service autofs restart;

  2. #2
    Avatar de thiagoacsp
    Ingresso
    Oct 2005
    Localização
    São Bernardo do Campo, Brazil, Brazil
    Posts
    231

    Padrão NIS+NFS+autofs nao funciona

    Creio que vc queira que usuarios do linux autentiquem no servidor mas para isso acho bem melhor utilizar o samba como PDC para a rede.



  3. #3

    Padrão NIS+NFS+autofs nao funciona

    É um laboratorio puramente Linux. Eu ate poderia usar o Samba, com um autologin local + script de mount de homedir de rede, mas estou querendo usar NIS+NFS exatamente por querer usar uma solucao pura Linux, pois é um experimento de uma disciplina de Redes, ainda nao é um ambiente real.

  4. #4

    Padrão NIS+NFS+autofs nao funciona

    O NIS esta aceitando o login remoto numa boa, e em seguida se eu rodo um "mount -t nfs" do homedir do cidadao tambem funciona. Mas gostaria de tirar este passo do script manual, fazer tudo automatico, mas o tal do autofs esta complicando...