+ Responder ao Tópico



  1. #1

    Padrão conexão ao postgres

    Pessoal, não estou conseguindo me conectar ao postgres.

    Tenho a versão 8.0.4 instalada num freebsd que aparentemente está levantada:

    webserver# ps ax |grep post
    779 ?? Ss 0:00.01 /usr/local/bin/postmaster -D /usr/local/pgsql/data (postgres)
    781 ?? S 0:00.01 postmaster: writer process (postgres)
    782 ?? S 0:00.00 postmaster: stats buffer process (postgres)
    783 ?? I 0:00.00 postmaster: stats collector process (postgres)
    847 ?? Is 0:00.02 /usr/local/libexec/postfix/master

    Não estou conseguindo me conectar via pgadmin. Diz que não conseguiu encontrar o servidor.

    o meu pg_hba.conf está assim:
    # TYPE DATABASE USER CIDR-ADDRESS METHOD

    # "local" is for Unix domain socket connections only
    local all all trust
    # IPv4 local connections:
    host all all 192.168.0.0/24 ident sameuser
    # IPv6 local connections:
    host all all ::1/128 trust

    O q estou fazendo errado?


    Obrigado!

    Valois

  2. #2

    Padrão conexão ao postgres

    O banco está na porta default ???
    Você consegue conectar via psql ??? Diretamente no servidor...
    O servidor está pingando corretamente ???

    A nossa configuração está assim :
    Código :
    host    all     all 127.0.0.1           255.255.255.0   password
    local   all     postgres                                                trust
    local   all     all                                                trust
    host    all     all 10.21.0.0       255.255.0.0     password



  3. #3

    Padrão conexão ao postgres

    Sim, estou conseguindo pingar o servidor (me conecto via ssh) e está configurado na porta default.
    Se eu der um su pgsql, e me sonsigo me conectar via psql (psql template1).

    segue o retorno do meu sockstat
    #sockstar |grep pg
    pgsql postgres 783 3 dgram -> /var/run/log
    pgsql postgres 782 3 dgram -> /var/run/log
    pgsql postgres 782 6 udp4 127.0.0.1:51384 127.0.0.1:51384
    pgsql postgres 781 3 dgram -> /var/run/log
    pgsql postgres 781 6 udp4 127.0.0.1:51384 127.0.0.1:51384
    pgsql postgres 779 3 dgram -> /var/run/log
    pgsql postgres 779 4 tcp4 127.0.0.1:5432 *:*
    pgsql postgres 779 5 stream /tmp/.s.PGSQL.5432
    pgsql postgres 779 6 udp4 127.0.0.1:51384 127.0.0.1:51384

    Obrigado!

  4. #4

    Padrão conexão ao postgres

    Ai pessoa, consegui configurar o postgres para aceitar conexões pela rede vi pGAdmin. É bem fácil, mas para quem nunca fez, ...

    segue o q fiz:

    Configurar o Postgres para aceitar conexões vindas da rede. Por default, não aceita:
    edita o /usr/local/pgsql/postgresql.conf
    listen_addresses = '*' # defaults to localhost, '*' = any

    configurar os Host da rede que podem acessar o Postgres. Para facilitar aimplantação, liberei todas as classes de IP. Depois, configuro apenas o IP que irá administrar o banco.Editar:

    /usr/local/pgsql/pg_hba.conf e adicionar no final:
    host all all 0.0.0.0/0 trust

    Também é interessante configurar o log. As opções estão em /usr/local/pgadmin/postgresql.conf

    Valew!


    Valois



  5. #5

    Padrão Re: conexão ao postgres

    hehehe...parabens por resolver, soh vou dar mais uma palavrinha....

    Citação Postado originalmente por Valois
    webserver# ps ax |grep post
    779 ?? Ss 0:00.01 /usr/local/bin/postmaster -D /usr/local/pgsql/data (postgres)
    pra o postgresql aceitar conexoes via tcp/ip vc precisa da flag "-i", ou seja, seu banco de dados estava startado pra ouvir em arquivos unix, eu costumo levantar meu servico assim:

    Código :
    pg_ctl -D datadir -l arquivo.log -o "-i" start

  6. #6

    Padrão conexão ao postgres

    OK,

    Não conheço as versões anteriores do Postgres, mas me parece q a 8.0.4 vem um pouco diferente. A própria documentação do site www.postgres.org, não bate com a configuração do postgresql.conf.
    É até interessante alguma opinião de pessoas q tenham mais esperiencia do q eu.

    De qualquer forma, continuo levantando o banco com os mesmos parametros. Até tentei verificar a opção -i, mas dava erro de sintaxe.


    Obrigado!



  7. #7

    Padrão conexão ao postgres

    Citação Postado originalmente por Valois
    Até tentei verificar a opção -i, mas dava erro de sintaxe.
    talvez vc tenha tentado algo como:

    pg_ctl ... -o -i start

    de fato vai dar erro....vc *tem* q usar o -i entre aspas pra que ele nao interprete o -i como uma flag, e sim como o valor do paramtro -o

    pg_ctl ... -o "-i" start

  8. #8
    jamba
    Visitante

    Padrão conexão ao postgres

    Acho que para as versoes atuais nao precisa do paramentro "-i".....seta no postgresql.conf pra aceitar conexao tcp/ip e inicia normalmente sem o "-i".

    tcpip_socket = true

    pg_ctl -D pathdatabase/ -l pathdatabase/pgsql.log start &



  9. #9

    Padrão conexão ao postgres

    Pois é pessoal,

    A opção "-i", configurei dentro do postgresql.conf :

    listen_addresses = '*' # defaults to localhost, '*' = any

    Por default, a opção é '' e o '*' indica conexão por qualquer placa via TCP/IP


    configurar os Host da rede que podem acessar o Postgres. Para facilitar aimplantação, liberei todas as classes de IP. Depois, configuro apenas o IP que irá administrar o banco.Editar:

    /usr/local/pgsql/pg_hba.conf e adicionar no final:
    host all all 0.0.0.0/0 trust