+ Responder ao Tópico



  1. #1

    Padrão Variaveis do post nao vão

    Estou com o seguinte problema.

    No form feito em php tem somente as variaveis

    $codigo
    $nome

    Que sao enviados atraves de submit para o arquivo INCLUIR.PHP.
    No mysql e gravado somente o indice de autoincrement. Os valores das variavieis $codigo e $descricao nao sao enviados para serem gravados.

    O que pode estar errado ? Os valores das variaveis sao passadas para o
    arquivo de inclusão atraves form action e submit.

  2. #2
    Avatar de thiagoacsp
    Ingresso
    Oct 2005
    Localização
    São Bernardo do Campo, Brazil, Brazil
    Posts
    231

    Padrão Variaveis do post nao vão

    utilize assim no script para incluir:
    $codigo = $_POST['codigo'];
    $descricao = $_POST['descricao'];

    Cometi o mesmo erro quando tava começando com PHP.
    Espero ter ajudado.



  3. #3

    Padrão Variaveis do post nao vão

    Citação Postado originalmente por thiagoacsp
    utilize assim no script para incluir:
    $codigo = $_POST['codigo'];
    $descricao = $_POST['descricao'];

    Cometi o mesmo erro quando tava começando com PHP.
    Espero ter ajudado.
    ou

    $codigo = $_REQUEST'codigo'];
    $descricao = $_REQUEST['descricao'];

    o esquema de enviar direto só funciona se vc ativar a vairaveis globais do site mas isso não é nada bom em questão de segurança

  4. #4
    Gabriel_Kritikos
    Visitante

    Padrão Variaveis do post nao vão

    É eu tb tive esse mesmo problema sem contar que perdi uma tarde pra descobrir a solução e tem um detalhe no servidor windows funcionava detectei só no linux......
    Acontece!!!!!!!!!!!!!!!