+ Responder ao Tópico



  1. #1
    butkam
    Visitante

    Padrão [urgente] problemas no roteamento dentro do squid

    olá a todos, eu fiz o roteamento dentro do squid através dos comandos:

    #######squid.conf#######
    acl adsl2 src 10.21.1.123/255.255.255.255
    tcp_outgoing_address 192.168.0.2 adsl2
    ######################

    onde, somente eu sairia pela adsl2.
    o problema é q na navegação, aparece

    #########navegador###
    ERRO
    A URL solicitada não pode ser recuperada
    Na tentativa de recuperar a URL: www.google.com:443
    O seguinte erro foi encontrado:
    * Falha no Socket
    O sistema retornou:
    (99) Cannot assign requested address
    Squid foi incapaz de criar um socket TCP, talvez por excesso de carga no sistema. Por favor tente novamente.
    #####################

    o que vcs acham q pode ser???
    estou tentando tb balanceamento por iproute2... mas acho q o balanceamento no squid é mais fácil... pois basta colocar... htm, html, jpg e gif em 1 modem e restante em outro modem. ficando a internet rápida e naum me importando com os downloads...

    alguem tem isso implementado??? estou precisando com urgencia...

    obrigado,

    butkam

    estou seguindo as dicas do site: http://www.gulbf.com.br/index.php?op...d=77&Itemid=43

  2. #2

    Padrão Re: [urgente] problemas no roteamento dentro do squid

    Citação Postado originalmente por butkam
    olá a todos, eu fiz o roteamento dentro do squid através dos comandos:

    #######squid.conf#######
    acl adsl2 src 10.21.1.123/255.255.255.255
    tcp_outgoing_address 192.168.0.2 adsl2
    ######################

    onde, somente eu sairia pela adsl2.
    o problema é q na navegação, aparece

    #########navegador###
    ERRO
    A URL solicitada não pode ser recuperada
    Na tentativa de recuperar a URL: www.google.com:443
    O seguinte erro foi encontrado:
    * Falha no Socket
    O sistema retornou:
    (99) Cannot assign requested address
    Squid foi incapaz de criar um socket TCP, talvez por excesso de carga no sistema. Por favor tente novamente.
    #####################

    o que vcs acham q pode ser???
    estou tentando tb balanceamento por iproute2... mas acho q o balanceamento no squid é mais fácil... pois basta colocar... htm, html, jpg e gif em 1 modem e restante em outro modem. ficando a internet rápida e naum me importando com os downloads...

    alguem tem isso implementado??? estou precisando com urgencia...

    obrigado,

    butkam

    estou seguindo as dicas do site: http://www.gulbf.com.br/index.php?op...d=77&Itemid=43
    Ei fera tbm to com o mesmo problema, to seguindo este mesmo site, mais seguinte, aqui eu possuo um link dedicado ke vai na eth0, e a eth1 vai para os users, a eth2 xega o adsl, demorou pra mim sacar pq quando no tutorial diz para colocar o gw, mais com o gw naum funciona vc tem que colocar o ip da placa de rede, bom quando coloco o ip da eth0 funfa blz, mais quando coloco o ip do adsl naum funfa, descobri pq não estava funcionando, tenho que colocar o gw do modem nesta placa de rede, mais ae vem a questão até montei um tópico aqui na under pra ver c alguém me ajuda mais até agora nda.. se vc souber como fazer isto.. o topico ta ae abaixo...

    https://under-linux.org/modules.php?...wtopic&t=37083


    _______________________________
    Rafael Fernando Machado
    www.franet.com.br



  3. #3
    butkam
    Visitante

    Padrão só uma dúvida

    questão o seguinte...
    eu estou testando o ping nas placas de rede...
    eth0=adsl = ip:192.168.0.3... gw:192.168.0.2
    eth1=adsl = ip:192.168.1.4... gw:192.168.1.1
    eth2=rede interna

    ping -I eth0 www.uol.com.br
    PING www.uol.com.br (200.221.2.45) from 192.168.0.3 eth0: 56(84) bytes of data.
    64 bytes from home.uol.com.br (200.221.2.45): icmp_seq=1 ttl=58 time=66.4 ms

    ping -I eth1 www.uol.com.br
    PING www.uol.com.br (200.221.2.45) from 192.168.1.4 eth1: 56(84) bytes of data.
    From srvpgeproxy.atpge (192.168.1.4) icmp_seq=2 Destination Host Unreachable

    achu q é isso q tá dando problema no balanceamento e dando erro no navegador.. socket failure....

    abraços,
    butkam

    obs.. alguem se arrisca de resolver esse problema???

  4. #4

    Padrão Re: só uma dúvida

    Citação Postado originalmente por butkam
    questão o seguinte...
    eu estou testando o ping nas placas de rede...
    eth0=adsl = ip:192.168.0.3... gw:192.168.0.2
    eth1=adsl = ip:192.168.1.4... gw:192.168.1.1
    eth2=rede interna

    ping -I eth0 www.uol.com.br
    PING www.uol.com.br (200.221.2.45) from 192.168.0.3 eth0: 56(84) bytes of data.
    64 bytes from home.uol.com.br (200.221.2.45): icmp_seq=1 ttl=58 time=66.4 ms

    ping -I eth1 www.uol.com.br
    PING www.uol.com.br (200.221.2.45) from 192.168.1.4 eth1: 56(84) bytes of data.
    From srvpgeproxy.atpge (192.168.1.4) icmp_seq=2 Destination Host Unreachable

    achu q é isso q tá dando problema no balanceamento e dando erro no navegador.. socket failure....

    abraços,
    butkam

    obs.. alguem se arrisca de resolver esse problema???
    Sim kra, antes de fazer este parada no squid tem que tar feito o balanceamento, que té agora eu naum consegui faze, ja vi um monte de tutorial mais naum consigo fazer kra, nenhum da certo, se tu conseguir me da um toke ae.. pq eu to precisando faze isso aki..

    Att.
    Rafael Fernando
    www.franet.com.br



  5. #5
    butkam
    Visitante

    Padrão [urgente] problemas no roteamento dentro do squid

    já tentou fazer isso???
    https://under-linux.org/wiki/Artigos/Loadbalance

    abraços,

    butkam