+ Responder ao Tópico



  1. #1
    cag
    Visitante

    Padrão samba muito lento (Tópico com meu smb.conf)

    Pessoal, desculpe por repetir o tópico.
    Vou colar minha configuracao, realmente estou quase doido e nada funciona...

    Só pode ser pau do samba.


    O Sistema fica muito lento, mas quando reinicio o samba ele fica normal..
    O Unico erro que aparece é este...

    [2005/10/26 09:49:51, 0] printing/print_cups.c:cups_cache_reload(85)
    Unable to connect to CUPS server localhost - Connection refused

    Minha configuração é estáa..
    [global]
    workgroup = rede
    server string = Cobol
    invalid users = root
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 0
    encrypt passwords = true
    passdb backend = tdbsam guest
    socket options = TCP_NODELAY
    dns proxy = yes
    obey pam restrictions = yes
    keep alive = 20
    security = SHARE
    load printers = no

    [COBOL]
    comment = COBOL
    path = /COBOL
    printable = no
    read only = No
    guest ok = yes

    não tenho impressora na maquina, e volta este erro.

    Mas acredito q fica lento por outro motivo.

  2. #2
    Avatar de thiagoacsp
    Ingresso
    Oct 2005
    Localização
    São Bernardo do Campo, Brazil, Brazil
    Posts
    231

    Padrão samba muito lento (Tópico com meu smb.conf)

    Qual sua distro?
    Outra coisa verifica se o cups ta rodando se tiver para ele.
    Outra coisa pode tirar o parametro load printers do [global] e printable do compartilhamento acho que nao eh necessario ja que nao tem impressora.



  3. #3
    cag
    Visitante

    Padrão samba muito lento (Tópico com meu smb.conf)

    Utilizo o redhat...

    eu n tenho cups na máquina, tiro todas as configuracoes de impressora...
    e volta esse erro

  4. #4
    cag
    Visitante

    Padrão samba muito lento (Tópico com meu smb.conf)

    Estou doido, em todos os logs mostra o erro do cups.
    Em cada usuário da rede, só pode ser isso que está travando.



  5. #5
    cag
    Visitante

    Padrão samba muito lento (Tópico com meu smb.conf)

    estou usando o grupo de trabalho em minusculo, mas no windows está maiusculo....

    Pode ser esse o problema ??

  6. #6
    Avatar de thiagoacsp
    Ingresso
    Oct 2005
    Localização
    São Bernardo do Campo, Brazil, Brazil
    Posts
    231

    Padrão samba muito lento (Tópico com meu smb.conf)

    Uma pergunta vc utiliza o samba como PDC ou somente para compartilhamento?



  7. #7
    cag
    Visitante

    Padrão samba muito lento (Tópico com meu smb.conf)

    somente compartilhamento, é share.

    Esquece o erro da inicialização, eu tinha alterado para testar.
    o Único erro é do cups.

  8. #8
    Avatar de thiagoacsp
    Ingresso
    Oct 2005
    Localização
    São Bernardo do Campo, Brazil, Brazil
    Posts
    231

    Padrão samba muito lento (Tópico com meu smb.conf)

    Kra tenta isso:
    [global]
    workgroup = samba
    server string = Servidor Samba
    security = share
    #encrypt passwords = yes
    log file = /var/log/samba/samba.log

    [COBOL]
    comment = COBOL
    path = /COBOL
    read only = No
    guest ok = yes

    E uma coisa a pasta eh maiuscula? e ja rodou o comando "testparm" para ver se a configuração do smb.conf ta certa?



  9. #9
    cag
    Visitante

    Padrão samba muito lento (Tópico com meu smb.conf)

    já rodei...

    é maiuscula a pasta:

    Load smb config files from /etc/samba/smb.conf
    Processing section "[COBOL]"

    Loaded services file OK.
    Server role: ROLE_STANDALONE

    Já tentei assim, tirei todas configurações de impressao...

    ta assim agora:

    Código :
    [global]
       workgroup = rede
       server string = Intranet 
       invalid users = root
       log file = /var/log/samba/log.%m
       max log size = 10
       syslog = 0
       encrypt passwords = true
       passdb backend = tdbsam guest
       socket options = TCP_NODELAY
       ;panic action = /usr/share/samba/panic-action %d
       keep alive = 20
       security = SHARE
    o único erro que aparece nos logs, é do cups[/code]

  10. #10
    cag
    Visitante

    Padrão samba muito lento (Tópico com meu smb.conf)

    sei la, já não sei mais o que fazer...

    estou achando que pode ser o hub.
    Quando 1 conecta vai legal, mas quando 8 conectam complica.

    reinicia vai etc...

    ta complicado



  11. #11
    Avatar de thiagoacsp
    Ingresso
    Oct 2005
    Localização
    São Bernardo do Campo, Brazil, Brazil
    Posts
    231

    Padrão samba muito lento (Tópico com meu smb.conf)

    Kra realmente eh muito complicado mas da o log do cups com uma maquina soh ou nem? ou so da esse log se tah mais de 1 maquina ou as 8? faça um teste vai entrando maquina por maquina pra ver eh um trampo meio de noia mas da pra ver quantas maquina ele fica ok e ou na conf que vc passo comenta a linha panic com "#" pq ";" acho que nao funciona blz, olha esse eh o samba que utilizo tanto para user como para share:

    [global]
    workgroup = samba
    log file = /var/log/samba/%m.log
    max log size = 50
    security = share
    unix password sync = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
    encrypt passwords = yes
    smb passwd file = /etc/samba/smbpasswd
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    local master = yes
    os level = 100
    preferred master = yes
    wins support = yes
    #printcap name = /etc/printcap
    #printing = cups
    #load printers = yes

    [homes]
    comment = Home Directories
    browseable = no
    writable = yes

    pelo que teste sempre funciono mas tenta ai nao custa nada.

  12. #12
    cag
    Visitante

    Padrão samba muito lento (Tópico com meu smb.conf)

    o log da em log.smbd em alguns usuários tb (user.log)

    já estou meio doido.
    Vou colocar um swith para ver se melhora...
    O Servidor smb, que você roda essa configuração tem muito acesso simultaneamente ?
    A Performace é realmente boa ?

    Quanto o samba está pegando de memória ?

    Obrigado



  13. #13
    Avatar de thiagoacsp
    Ingresso
    Oct 2005
    Localização
    São Bernardo do Campo, Brazil, Brazil
    Posts
    231

    Padrão samba muito lento (Tópico com meu smb.conf)

    Olha tenho dois servidores rodando o samba em cada um tem um pouco mais de 40 acessos a cada um por hora sao ao todos 30 pessoas que acessam e mais algumas maquinas que rodam para fazer atualização de alguns sistemas que temos aqui e eh gravado em um compartilhamento no samba. Mas a quantidade de memoria nao sei te dizer pois ainda nao verificamos isso.
    Bom faça isso eliminar duvidas eh bem mais pratico, se nao funcionar o switch, reinstale o samba e configure ele para pedir usuario e senha, se funcionar com usuario entao tem que encontrar outra forma de fazer sem senha.

  14. #14
    cag
    Visitante

    Padrão samba muito lento (Tópico com meu smb.conf)

    é verdade,

    obrigado mesmo.

    Ah, o erro do cups não apareceu mais.

    coloquei assim no smb.conf

    printing = bsd
    printcap name = /dev/null

    apanhei pra descobrir isso


    valeu



  15. #15
    Avatar de thiagoacsp
    Ingresso
    Oct 2005
    Localização
    São Bernardo do Campo, Brazil, Brazil
    Posts
    231

    Padrão samba muito lento (Tópico com meu smb.conf)

    Bom legal que vc conseguiu mas como que vc descobriu que era so colocar esses parametros?
    Ou vc testou e acabou funcionando?

  16. #16
    cag
    Visitante

    Padrão samba muito lento (Tópico com meu smb.conf)

    Olha eu poderia ficar tentando 1 semana e não colocaria esses 2 parametros.

    Achei por uma sorte na lista do samba, já foi difícil de encontrar.

    Tem muita pergunta parecida no google, mas todas são referentes há configuração do cups, e no meu caso não tenho cups e aparecia esse erro.

    Agora é só aguardar, talvez a lentidão do samba é isso.

    valeu



  17. #17
    lewroy
    Visitante

    Padrão ola Amigos

    Ola Amigos deixa eu participar deste forum tb, gostaria de vc me ajudassem pois estou instalando o meu 1° samba, ele já aprece nos grupos do Ruindows XP mais n/ consigo logar, já cadastrei todos os usuarios cadastrados, mais mesmo assim n/ logo o que eu faço???? Obrigado :cry:

  18. #18
    Avatar de thiagoacsp
    Ingresso
    Oct 2005
    Localização
    São Bernardo do Campo, Brazil, Brazil
    Posts
    231

    Padrão samba muito lento (Tópico com meu smb.conf)

    Bom kra posta ai seu smb.conf pra gente dar uma olhada e diz ai a msg que aparece no ruindows creio que seja algo como nao acessivel, mais posta ai que a gente tenta ajudar.