Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Squid demorando p/ autenticar

    Pessoal, to com um problema.
    Configurei um servidor proxy squid num slackware 9.1.

    O que acontece é que configurei para ser um proxy c/ autenticação, porém os usuários estão encontrando dificuldade para logar, pois quando são fornecidos os dados de acesso (user e senha) o servidor está demorando muito para liberar a navegação p/ os usuários.

    Isso quando consegue logar, as vezes acontece até de demorar e retornar pedindo novamente a senha, como se os dados estivessem incorretos.

    Alguém tem idéia de como posso resolver esse problema??

    Agradeço a quem puder ajudar.

    Obrigado!

  2. #2
    isnard
    Visitante

    Padrão Squid demorando p/ autenticar

    Gustavo,

    tu vais precisar fornecer mais informações para o pessoal poder te ajudar.

    Que tipo de autenticação tu estas usando seria um bom começo?



  3. #3

    Padrão Squid demorando p/ autenticar

    To usando ncsa_auth... Ele pede a senha normalmente, mas quando é informado demora demais pra liberar a navegação, mas geralmente não libera, volta depois de muito tempo pedir senha novamente.

  4. #4
    isnard
    Visitante

    Padrão Squid demorando p/ autenticar

    Gustavo,

    vai aí uma bateria de perguntas que são importantes...
    Quantos usuários estão usando simultaneamente o proxy? Será que o número de autenticadores não está baixo? Testa a autenticação na linha de comando? Também é demorado? O que diz o cache.log?



  5. #5

    Padrão Squid demorando p/ autenticar

    Como assim a autenticação na linha de comando??

    Serão pouco menos de 10 usuários.

  6. #6

    Padrão Squid demorando p/ autenticar

    Olá,

    posta aí as linhas do squid.conf referentes à autenticação.



  7. #7

    Padrão Squid demorando p/ autenticar

    Então cara, acontece que este servidor que estou montando está em outra cidade. Não vou ter acesso a isso por pelo menos uns 20 dias.

    Será que poderia me dar uma dica?

  8. #8

    Padrão Squid demorando p/ autenticar

    Citação Postado originalmente por isnard
    Testa a autenticação na linha de comando? Também é demorado?

    Como faço esse teste de autenticação direto na linha de comando?



  9. #9
    isnard
    Visitante

    Padrão Squid demorando p/ autenticar

    ncsa_auth <arquivo_de_usuarios>

  10. #10

    Padrão Squid demorando p/ autenticar

    Pessoal, alguém tem alguma suspeita do que pode ser para me dar uma dica?

    É que estou a mais de 300km desta máquina, ela está em outra cidade, e quando eu for pra lá quero ter pelo menos alguma coisa em mente pois nem sei mais por onde começar.


    Vlw galera!



  11. #11
    Charles_123
    Visitante

    Padrão suid

    Em quanto tu nao postar o teu squid aqui no Forum nao vai adiantar muito,pois temos que ver o que esta confurado.

  12. #12

    Padrão Squid demorando p/ autenticar

    OK, Mas então alguém poderia postar seu próprio squid.conf para que eu possa ter em que me basear quando for pra lá??

    É que vou estar lá por pouco tempo e tenho que dar solução nisso dessa vez.


    Valeu galera.



  13. #13
    cag
    Visitante

    Padrão Squid demorando p/ autenticar

    Tente os seguintes parametros na autentificação.

    Código :
    auth_param basic program /usr/lib/squid/pam_auth
    auth_param basic children 5
    auth_param basic realm Intranet
    auth_param basic credentialsttl 2 hours

    No caso eu utilizo pam, é só mudar para a sua autentificação.

  14. #14

    Padrão Squid demorando p/ autenticar

    Citação Postado originalmente por isnard
    Testa a autenticação na linha de comando? Também é demorado?
    Fiz o teste na linha de comando, mas é demorado mesmo assim.

    Isso significa que o erro não tá no squid.conf.
    Alguém tem alguma coisa do que pode ser?

    Fiz o teste com o comando ncsa_auth senhas (é o arquivo de senhas que uso) e o sistema ficou como se estivesse travado. ñ retornou nada.



  15. #15

    Padrão Squid demorando p/ autenticar

    Alguma idéia? Por favor pessoal, realmente preciso solucionar isso!

  16. #16
    mushroom-br
    Visitante

    Padrão Squid demorando p/ autenticar

    Sugestão, remove e instala tudo novamente!



  17. #17

    Padrão Squid demorando p/ autenticar

    Citação Postado originalmente por mushroom-br
    Sugestão, remove e instala tudo novamente!
    O problema é tempo!
    Alguém tem alguma sugestão?
    Agora que sei que nem a autenticação na linha de comando funciona, descarto a hipótese do problema ser com o squid.

    Tá ai também o porque de não resolver meu problema desinstalar e instalar tudo novamente.

    Por favor pessoal!

  18. #18

    Padrão Squid demorando p/ autenticar

    Essa maquina está rodando apenas SQUID ??? Qual a configuração de hardware e o uso do mesmo ?



  19. #19

    Padrão Squid demorando p/ autenticar

    Citação Postado originalmente por Drozzini
    Essa maquina está rodando apenas SQUID ??? Qual a configuração de hardware e o uso do mesmo ?
    Sim, está só rodando squid.
    É um AMD K6-2 500Mhz c/ 128 MB RAM.

    Creio que pra colocar esse proxy pra funcionar essa máquina já estaria bom, ainda mais rodando slackware 9.1.

    Não tenho os dados de uso neste momento, mas assim que tiver te envio.

    São 5 máquinas na rede que irão usar o proxy. +/- 10 usuários devem dividir essas máquinas. É uma rede pequena, porém é muito importante ter esse proxy funcionando.

  20. #20

    Padrão Squid demorando p/ autenticar

    realmente pela conf da maquina só com proxy tem q funcionar legal !

    Perguntei conf e uso mais mesmo caso não fosse dedicada pro proxy a maquina.

    Ai está meu squid.conf caso ajude:

    http://www.zenisys.com.br/Docs/squid.conf