+ Responder ao Tópico



  1. #1
    duker
    gente é o seguinte compilei o kernel 2.6.12-3 mas agora estou sem acesso a gravadora de dvd e cd no casos as unidades são IDE e seriam respectivamente os dispositivos hdc e hdd mas não existe os arquivos /dev/hdc e /dev/hdd
    O comando dmesg dá a seguinte saída:
    Linux version 2.6.12.3-dUKer (root@dUKer) (gcc version 3.3.4) #4 Sun Nov 6 23:10:48 BRST 2005
    BIOS-provided physical RAM map:
    BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
    BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
    BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
    BIOS-e820: 0000000000100000 - 0000000017ff0000 (usable)
    BIOS-e820: 0000000017ff0000 - 0000000017ff8000 (ACPI data)
    BIOS-e820: 0000000017ff8000 - 0000000018000000 (ACPI NVS)
    BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
    BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
    BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
    383MB LOWMEM available.
    found SMP MP-table at 000fb820
    On node 0 totalpages: 98288
    DMA zone: 4096 pages, LIFO batch:1
    Normal zone: 94192 pages, LIFO batch:31
    HighMem zone: 0 pages, LIFO batch:1
    DMI 2.3 present.
    ACPI: RSDP (v000 AMI ) @ 0x000fa5a0
    ACPI: RSDT (v001 AMIINT VIA_K7 0x00000010 MSFT 0x00000097) @ 0x17ff0000
    ACPI: FADT (v001 AMIINT VIA_K7 0x00000011 MSFT 0x00000097) @ 0x17ff0030
    ACPI: MADT (v001 AMIINT VIA_K7 0x00000009 MSFT 0x00000097) @ 0x17ff00c0
    ACPI: DSDT (v001 VIA VIA_K7 0x00001000 MSFT 0x0100000d) @ 0x00000000
    ACPI: Local APIC address 0xfee00000
    ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
    Processor #0 6:8 APIC version 16
    ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
    IOAPIC[0]: apic_id 2, version 3, address 0xfec00000, GSI 0-23
    ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
    ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 low level)
    ACPI: IRQ0 used by override.
    ACPI: IRQ2 used by override.
    ACPI: IRQ9 used by override.
    Enabling APIC mode: Flat. Using 1 I/O APICs
    Using ACPI (MADT) for SMP configuration information
    Allocating PCI resources starting at 18000000 (gap: 18000000:e6c00000)
    Built 1 zonelists
    Kernel command line: root=/dev/hdb1
    mapped APIC to ffffd000 (fee00000)
    mapped IOAPIC to ffffc000 (fec00000)
    Initializing CPU#0
    PID hash table entries: 2048 (order: 11, 32768 bytes)
    Detected 1780.896 MHz processor.
    Using tsc for high-res timesource
    Console: colour VGA+ 80x25
    Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
    Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
    Memory: 385160k/393152k available (2347k kernel code, 7436k reserved, 1027k data, 328k init, 0k highmem)
    Checking if this processor honours the WP bit even in supervisor mode... Ok.
    Calibrating delay loop... 3497.98 BogoMIPS (lpj=1748992)
    Security Framework v1.0.0 initialized
    Mount-cache hash table entries: 512
    CPU: After generic identify, caps: 0383fbff c1cbfbff 00000000 00000000 0000000000000000 00000000
    CPU: After vendor identify, caps: 0383fbff c1cbfbff 00000000 00000000 00000000 00000000 00000000
    CPU: CLK_CTL MSR was 6003d22f. Reprogramming to 2003d22f
    CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
    CPU: L2 Cache: 256K (64 bytes/line)
    CPU: After all inits, caps: 0383fbff c1cbfbff 00000000 00000020 00000000 00000000 00000000
    Intel machine check architecture supported.
    Intel machine check reporting enabled on CPU#0.
    CPU: AMD Sempron(tm) 2500+ stepping 01
    Enabling fast FPU save and restore... done.
    Enabling unmasked SIMD FPU exception support... done.
    Checking 'hlt' instruction... OK.
    ENABLING IO-APIC IRQs
    ..TIMER: vector=0x31 pin1=2 pin2=-1
    NET: Registered protocol family 16
    EISA bus registered
    PCI: PCI BIOS revision 2.10 entry at 0xfdaf1, last bus=1
    PCI: Using configuration type 1
    mtrr: v2.0 (20020519)
    ACPI: Subsystem revision 20050309
    ACPI: Interpreter enabled
    ACPI: Using IOAPIC for interrupt routing
    ACPI: PCI Root Bridge [PCI0] (0000:00)
    PCI: Probing PCI hardware (bus 00)
    Boot video device is 0000:01:00.0
    ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
    ACPI: Power Resource [URP1] (off)
    ACPI: Power Resource [URP2] (off)
    ACPI: Power Resource [FDDP] (off)
    ACPI: Power Resource [LPTP] (off)
    ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 10 *11 12 14 15)
    ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 *5 6 7 10 11 12 14 15)
    ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 *5 6 7 10 11 12 14 15)
    ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 *10 11 12 14 15)
    Linux Plug and Play Support v0.97 (c) Adam Belay
    pnp: PnP ACPI init
    pnp: PnP ACPI: found 10 devices
    usbcore: registered new driver usbfs
    usbcore: registered new driver hub
    PCI: Using ACPI for IRQ routing
    PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
    Machine check exception polling timer started.
    Total HugeTLB memory allocated, 0
    VFS: Disk quotas dquot_6.5.1
    Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
    NTFS driver 2.1.22 [Flags: R/W DEBUG].
    Initializing Cryptographic API
    vga16fb: initializing
    vga16fb: mapped to 0xc00a0000
    Console: switching to colour frame buffer device 80x30
    fb0: VGA16 VGA frame buffer device
    isapnp: Scanning for PnP cards...
    isapnp: No Plug & Play device found
    PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
    serio: i8042 AUX port at 0x60,0x64 irq 12
    serio: i8042 KBD port at 0x60,0x64 irq 1
    Serial: 8250/16550 driver $Revision: 1.90 $ 54 ports, IRQ sharing enabled
    ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    io scheduler noop registered
    io scheduler anticipatory registered
    io scheduler deadline registered
    io scheduler cfq registered
    Floppy drive(s): fd0 is 1.44M
    FDC 0 is a post-1991 82077
    RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
    via-rhine.c:v1.10-LK1.2.0-2.6 June-10-2004 Written by Donald Becker
    ACPI: PCI Interrupt 0000:00:12.0[A] -> GSI 23 (level, low) -> IRQ 23
    PCI: Via IRQ fixup for 0000:00:12.0, from 11 to 7
    eth0: VIA Rhine II at 0x1dc00, 00:11:5b:39:5b:c2, IRQ 23.
    eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 41e1.
    Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    VP_IDE: IDE controller at PCI slot 0000:00:11.1
    ACPI: PCI Interrupt 0000:00:11.1[A]: no GSI
    PCI: Via IRQ fixup for 0000:00:11.1, from 255 to 15
    VP_IDE: chipset revision 6
    VP_IDE: not 100% native mode: will probe irqs later
    VP_IDE: VIA vt8235 (rev 00) IDE UDMA133 controller on pci0000:00:11.1
    ide0: BM-DMA at 0xfc00-0xfc07, BIOS settings: hdaMA, hdbMA
    ide1: BM-DMA at 0xfc08-0xfc0f, BIOS settings: hdcMA, hddMA
    Probing IDE interface ide0...
    hda: ST310212A, ATA DISK drive
    hdb: SAMSUNG SP0411N, ATA DISK drive
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    Probing IDE interface ide1...
    hdc: HL-DT-STDVDRRW GWA-4161B, ATAPI CD/DVD-ROM drive
    hdd: SAMSUNG CD-R/RW DRIVE SW-224B, ATAPI CD/DVD-ROM drive

    ide1 at 0x170-0x177,0x376 on irq 15
    Probing IDE interface ide2...
    Probing IDE interface ide3...
    Probing IDE interface ide4...
    Probing IDE interface ide5...
    hda: max request size: 128KiB
    hda: 20005650 sectors (10242 MB) w/512KiB Cache, CHS=19846/16/63, UDMA(33)
    hda: cache flushes not supported
    hda: hda1 hda2 hda3
    hdb: max request size: 1024KiB
    hdb: 78242976 sectors (40060 MB) w/2048KiB Cache, CHS=16383/255/63, UDMA(33)
    hdb: cache flushes supported
    hdb: hdb1 hdb2
    usbmon: debugs is not available
    ohci_hcd: 2004 Nov 08 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
    USB Universal Host Controller Interface driver v2.2
    ACPI: PCI Interrupt 0000:00:10.0[A] -> GSI 21 (level, low) -> IRQ 21
    PCI: Via IRQ fixup for 0000:00:10.0, from 11 to 5
    uhci_hcd 0000:00:10.0: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
    uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 1
    uhci_hcd 0000:00:10.0: irq 21, io base 0x0000e400
    hub 1-0:1.0: USB hub found
    hub 1-0:1.0: 2 ports detected
    ACPI: PCI Interrupt 0000:00:10.1[B] -> GSI 21 (level, low) -> IRQ 21
    uhci_hcd 0000:00:10.1: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller(#2)
    uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 2
    uhci_hcd 0000:00:10.1: irq 21, io base 0x0000e800
    hub 2-0:1.0: USB hub found
    hub 2-0:1.0: 2 ports detected
    ACPI: PCI Interrupt 0000:00:10.2[C] -> GSI 21 (level, low) -> IRQ 21
    uhci_hcd 0000:00:10.2: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller(#3)
    uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 3
    uhci_hcd 0000:00:10.2: irq 21, io base 0x0000ec00
    hub 3-0:1.0: USB hub found
    hub 3-0:1.0: 2 ports detected
    usb 1-2: new full speed USB device using uhci_hcd and address 2
    usbcore: registered new driver aiptek
    drivers/usb/input/aiptek.c: v1.5 (May-15-2004): Bryan W. Headley/Chris Atenasio
    drivers/usb/input/aiptek.c: Aiptek HyperPen USB Tablet Driver (Linux 2.6.x)
    usbcore: registered new driver hiddev
    usbcore: registered new driver usbhid
    drivers/usb/input/hid-core.c: v2.01:USB HID core driver
    mice: PS/2 mouse device common for all mice
    EISA: Probing bus 0 at eisa.0
    EISA: Detected 0 cards.
    NET: Registered protocol family 2
    IP: routing cache hash table of 4096 buckets, 32Kbytes
    TCP established hash table entries: 16384 (order: 5, 131072 bytes)
    TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
    TCP: Hash tables configured (established 16384 bind 16384)
    NET: Registered protocol family 1
    NET: Registered protocol family 17
    NET: Registered protocol family 8
    NET: Registered protocol family 20
    ACPI wakeup devices:
    PCI0 UAR1 USB1 USB2 USB3 EHCI AC9 MC9 ILAN SLPB
    ACPI: (supports S0 S1 S4 S5)
    EXT3-fs: INFO: recovery required on readonly filesystem.
    EXT3-fs: write access will be enabled during recovery.
    input: AT Translated Set 2 keyboard on isa0060/serio0
    kjournald starting. Commit interval 5 seconds
    EXT3-fs: recovery complete.
    EXT3-fs: mounted filesystem with ordered data mode.
    VFS: Mounted root (ext3 filesystem) readonly.
    Freeing unused kernel memory: 328k freed
    Adding 377516k swap on /dev/hda3. Priority:-1 extents:1
    EXT3 FS on hdb1, internal journal
    Linux agpgart interface v0.101 (c) Dave Jones
    SCSI subsystem initialized
    ide-scsi is deprecated for cd burning! Use ide-cd and give dev=/dev/hdX as device
    scsi0 : SCSI host adapter emulation for IDE ATAPI devices
    Vendor: HL-DT-ST Model: DVDRRW GWA-4161B Rev: 1.00
    Type: CD-ROM ANSI SCSI revision: 02
    scsi1 : SCSI host adapter emulation for IDE ATAPI devices
    Vendor: SAMSUNG Model: CD-R/RW SW-224B Rev: R205
    Type: CD-ROM ANSI SCSI revision: 02
    NTFS volume version 3.1.
    NTFS-fs error (device hda1): ntfs_check_logfile(): The two restart pages in $LogFile do not match.
    NTFS-fs warning (device hda1): load_system_files(): Failed to load $LogFile. Will not be able to remount read-write. Mount in Windows.
    kjournald starting. Commit interval 5 seconds
    EXT3 FS on hda2, internal journal
    EXT3-fs: mounted filesystem with ordered data mode.
    sr0: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray
    Uniform CD-ROM driver Revision: 3.20
    Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
    sr1: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray
    Attached scsi CD-ROM sr1 at scsi1, channel 0, id 0, lun 0
    eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
    nvidia: module license 'NVIDIA' taints kernel.
    ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 16
    NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-7676 Fri Jul 29 12:58:54 PDT 2005
    via82xx: Assuming DXS channels with 48k fixed sample rate.
    Please try dxs_support=1 or dxs_support=4 option
    and report if it works on your machine.
    ACPI: PCI Interrupt 0000:00:11.5[C] -> GSI 22 (level, low) -> IRQ 22
    PCI: Via IRQ fixup for 0000:00:11.5, from 5 to 6
    PCI: Setting latency timer of device 0000:00:11.5 to 64
    ACPI: PCI Interrupt 0000:00:10.3[D] -> GSI 21 (level, low) -> IRQ 21
    PCI: Via IRQ fixup for 0000:00:10.3, from 10 to 5
    ehci_hcd 0000:00:10.3: VIA Technologies, Inc. USB 2.0
    ehci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 4
    ehci_hcd 0000:00:10.3: irq 21, io mem 0xdfffff00
    ehci_hcd 0000:00:10.3: USB 2.0 initialized, EHCI 1.00, driver 10 Dec 2004
    hub 4-0:1.0: USB hub found
    hub 4-0:1.0: 6 ports detected
    usb 1-2: USB disconnect, address 2
    pci_hotplug: PCI Hot Plug PCI Core version: 0.5
    usb 1-2: new full speed USB device using uhci_hcd and address 3
    shpchp: shpc_init : shpc_cap_offset == 0
    shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
    agpgart: Detected VIA KM400/KM400A chipset
    agpgart: AGP aperture is 64M @ 0xe0000000
    Linux video capture interface: v1.00
    /root/app/webcam/spca5xx-20051105/drivers/usb/spca5xx.c: USB SPCA5XX camera found. Type Creative Instant P0620
    /root/app/webcam/spca5xx-20051105/drivers/usb/spca5xx.c: [spca5xx_probe:8213] Camera type JPEG
    /root/app/webcam/spca5xx-20051105/drivers/usb/zc3xx.h: [zcxx_probeSensor:108] sensor answer1 170
    /root/app/webcam/spca5xx-20051105/drivers/usb/zc3xx.h: [zc3xx_config:404] Find Sensor PAS106
    /root/app/webcam/spca5xx-20051105/drivers/usb/spca5xx.c: [spca5xx_getcapability:2198] maxw 352 maxh 288 minw 176 minh 144
    usbcore: registered new driver spca5xx
    /root/app/webcam/spca5xx-20051105/drivers/usb/spca5xx.c: spca5xx driver 00.57.05 registered
    parport: PnPBIOS parport detected.
    parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
    Real Time Clock Driver v1.12
    input: PC Speaker
    input: ImPS/2 Generic Wheel Mouse on isa0060/serio1
    ts: Compaq touchscreen protocol output
    agpgart: Found an AGP 3.5 compliant device at 0000:00:00.0.
    agpgart: Device is in legacy mode, falling back to 2.x
    agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
    agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
    agpgart: Found an AGP 3.5 compliant device at 0000:00:00.0.
    agpgart: Device is in legacy mode, falling back to 2.x
    agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
    agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode

    Como arrumar isso nem sei por onde começar direito plz ajudem....
    aí o link com o arkivo de opções da conf. do kernel (/usr/srv/linux/.config)
    http://geocities.yahoo.com.br/dukercs/c/config.txt


    __________________________________
    dUKer - Rodolpho
    Linux User Número:
    http://geocities.yahoo.com.br/dukercs/385557.png
    Quer se tornar um linux user http://counter.li.org

  2. #2
    duker
    gente eu já ouvi falar do comando makedev mas no slack 10.1 q uso parece q não tem alguém sabe como posso criar esses dispositivos ?



  3. #3
    duker
    Consegui ufa !!! vou postar pro caso de alguém ter o mesmo problema q eu. É o seguinte para criar o dispositivo é necessário ter o comando mknod (a maioria tem )
    aí se faz o seguinte:
    como root lógico:

    [root@localhost ]# mknod /dev/$1 b 11 0

    [root@localhost ]# mknod /dev/$2 b 11 1

    Onde o $1 é o nome do disposivo de bloco (indicado pela letra b ) bom utilizar o geralzão q é hdc para o IDE secundário primário e hdd para o IDE secundário slave,
    a letra b é um argumento q indica q o dispositivo a ser criado é de bloco, o pq do 11 eu ainda não descobri (kkk grande explicação neh se alguém souber plz ajude a enriquecer meus conecimentos e estarei muito grato)
    e 1 e zero são os números do dispositivo....
    sei lá acho q naum expliquei nada direito mas esse post foi só pra postar como consegui passar por esse pequeno probleminha... rsrs


    ___________________________________
    dUKer - Rodolpho
    Linux User Número:
    http://geocities.yahoo.com.br/dukercs/385557.png
    Quer se tornar um linux user http://counter.li.org

  4. na verdade o que aconteceu é que vc ativou a interface ide-scsi para as duas unidades, de forma que estas estao acessíveis somente via /dev/sr0 e /dev/sr1, é só usar estes dispositivos em vez do /dev/hdd e /dev/hdd que vai funcionar






Tópicos Similares

  1. Mikrotik - Sem acesso aos sites do Google
    Por felipefonseca no fórum Redes
    Respostas: 3
    Último Post: 05-09-2014, 18:02
  2. Respostas: 1
    Último Post: 29-07-2013, 18:33
  3. Sem Acesso ao Engenius EOC 5610
    Por gokuu no fórum Redes
    Respostas: 13
    Último Post: 17-02-2013, 00:38
  4. Sem Acesso ao Hotmail
    Por ronieatm no fórum Redes
    Respostas: 6
    Último Post: 14-12-2011, 11:15
  5. sem acesso ao Mikrotik
    Por vmh0909 no fórum Redes
    Respostas: 0
    Último Post: 11-02-2009, 18:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L