Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    jvdebian
    hello Guys!!

    Ai gente, eu estou tentando instalar o SARG no meu Servidor Debian, que por sinal ja esta rodando o SQUID, mas eu ja tentei Instalar o SARG usando apt-get e me uma mensagem de erro:

    ebserver:/tmp# apt-get -f install libc6
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Sorry, libc6 is already the newest version.
    You might want to run `apt-get -f install' to correct these:
    Sorry, but the following packages have unmet dependencies:
    libdb1-compat: Depends: libc6 (>= 2.2.5-13) but 2.2.5-11.8 is to be installed
    sarg: Depends: libc6 (>= 2.3.2.ds1-21) but 2.2.5-11.8 is to be installed
    Depends: libgd2-noxpm (>= 2.0.33) but it is not going to be installed or
    libgd2-xpm (>= 2.0.33) but it is not installable
    Depends: ttf-bitstream-vera but it is not installable
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

    eu ja tentei baixar o pacote .Deb do sarg e instalar com o dpkg:

    webserver:/tmp# dpkg -i sarg_2.0.5.dfsg-1_i386.deb
    (Reading database ... 19486 files and directories currently installed.)
    Preparing to replace sarg 2.0.5.dfsg-1 (using sarg_2.0.5.dfsg-1_i386.deb) ...
    Unpacking replacement sarg ...
    dpkg: dependency problems prevent configuration of sarg:
    sarg depends on libc6 (>= 2.3.2.ds1-21); however:
    Version of libc6 on system is 2.2.5-11.8.
    sarg depends on libgd2-noxpm (>= 2.0.33) | libgd2-xpm (>= 2.0.33); however:
    Package libgd2-noxpm is not installed.
    Package libgd2-xpm is not installed.
    sarg depends on ttf-bitstream-vera; however:
    Package ttf-bitstream-vera is not installed.
    dpkg: error processing sarg (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    sarg
    webserver:/tmp#

    ja tentei baixar os pacotes tb ai continua dando erro de dependencias!!
    o q q e possivel de se fazer? por favor pessoal, manda uma luz ai!! brigadao!!!! t+

  2. #2
    wrochal
    Caro,

    Que versão do Debian você usa? E outra coisa porque você não usar o apt-get install sarg?

    Até,



  3. Pelo que entendi vc quer instalar o sarg mas ele tah pedindo a biblioteca libc6 >= 2.3.2.ds1-21 mas a sua versão eh 2.2.5-11.8. Daih vc tentou instalar a libc6 certo.

    Tente fazer isso:

    #apt-get install glibc
    (contém a libc6 e outras libs (é sempre bom ter atualizadas)

    daih de:

    #apt-get isntall sarg

    Lembrando que o sarg tem que ter instalado o apache com módulo php

  4. #4
    jvdebian
    Ae, qto a Versao do Debian, estou usando o 3.0.

    Eu jah tentei "apt-get install sarg" foi dai q tudo comecou tudo.

    ahh tb acabei de testar "apt-get install glibc" olha a resposta:

    webserver:~# apt-get install glibc
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Package glibc has no available version, but exists in the database.
    This typically means that the package was mentioned in a dependency and
    never uploaded, has been obsoleted or is not available with the contents
    of sources.list
    E: Package glibc has no installation candidate

    tentei "apt-get update" e depois "apt-get install glibc" e a mensagem continua a mesma dizendo q o pacote nao tem candidato para instalacao!!! acho q jah esta na sua versao mais nova!!!

    resumindo... ainda nao consegui instalar o sarg!!!!

    webserver:~# apt-get install sarg
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Sorry, sarg is already the newest version.
    You might want to run `apt-get -f install' to correct these:
    Sorry, but the following packages have unmet dependencies:
    libdb1-compat: Depends: libc6 (>= 2.2.5-13) but 2.2.5-11.8 is to be installed
    sarg: Depends: libc6 (>= 2.3.2.ds1-21) but 2.2.5-11.8 is to be installed
    Depends: libgd2-noxpm (>= 2.0.33) but it is not going to be installed or
    libgd2-xpm (>= 2.0.33) but it is not installable
    Depends: ttf-bitstream-vera but it is not installable
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).



  5. Antes você tem que atualizar para Sarge, com:

    Código :
    # apt-get -f dist-upgrade

    Mas antes você tem que ter os repositórios no seu /etc/apt/sources.list

    Então você instala o SARG.


    Abraços!






Tópicos Similares

  1. Erro na instalação do Red Hat 9
    Por luiz_nando no fórum Servidores de Rede
    Respostas: 2
    Último Post: 03-03-2004, 06:17
  2. Erro na instalação do logrep para analisar Snort?
    Por Hacinn no fórum Segurança
    Respostas: 0
    Último Post: 05-12-2003, 07:12
  3. Erro na instalação do modem!
    Por no fórum Servidores de Rede
    Respostas: 10
    Último Post: 01-12-2003, 13:52
  4. erro na instalação do postfix
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 30-10-2003, 12:27
  5. msg de erro na instalacao do modulo Archive::Zip... o que eh
    Por fisicko no fórum Servidores de Rede
    Respostas: 0
    Último Post: 15-08-2003, 14:09

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L