Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    perdiga
    ola pessoal?

    estou com um problema, tenho um servidor instalado o conectiva 10, compilei o postgre 8.0.4 blz, ate então estava funcionando legal, o problema foi o seguinte tive que instalar o pacote do php4-postgresql e não me toquei que ele baixou a versão 7.4.xx do postgre clients. E agora precisei restartar o servidor e não funciona mais.

    da este erro nos logs
    FATAL: database files are incompatible with server
    DETAIL: The data directory was initialized by PostgreSQL version 8.0, which is not compatible with this version 7.4.2.

    a duvida é a seguinte como faço para ele voltar como estava sem que eu perca o que tenho no meu banco..

    compilando novamente? me ajudem ai pessoal..

    muito obrigado.

  2. Isso ai perdiga =]


    compila dinovo a mesma versão que você tinha do postgres,


    depois levanta sua antiga base. =]


    /usr/local/postgresql-8.0.3/bin/pg_ctl start /usr/local/postgresql-8.0.3/data/


    caso o directorio do seu banco esteja em /usr/local/postgresql-8.0.3/data/


    é isso ai =]

    abraços manow!



  3. #3
    perdiga
    valeu pela resposta amigo, vou tentar depois posto se funcionou...

  4. #4
    perdiga
    amigo mais uma forcinha.

    fiz o seguinte entrei no diretorio do source do postgreSql e dei um ./configure e um gmake


    apos isto tentei iniciar ele, mas continua dando o mesmo erro. tenho que dar um gmake install tambem, mas se eu der isso não vou perder minha base.


    valeu pela força....



  5. Onde está sua base Perdiga?

    não, não vai , porem efetue um backup da sua base com certeza.


    pq não

    ./configure --prefix=/tmp/teste_postgres/
    make
    make install


    entre em /tmp/teste_postgres/bin/
    e tente montar usa base
    /tmp/teste_postgres/bin/pg_ctl start -d dir_onde_está_sua_base


    se não souber de um find / -name data

    "sempre" fica dentro de data


    abraços






Tópicos Similares

  1. Problema com postgresql + debian Lenny
    Por SebaCueto no fórum Servidores de Rede
    Respostas: 11
    Último Post: 27-07-2010, 09:43
  2. Respostas: 0
    Último Post: 10-09-2008, 08:40
  3. Problema com autenticacao pop (tpop3d) com postgresql
    Por GrayFox no fórum Sistemas Operacionais
    Respostas: 13
    Último Post: 27-08-2004, 04:13
  4. Problemas com o make instalando Postgresql 7.3.2
    Por LenTu no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 13-11-2003, 13:22
  5. problemas com o IMP
    Por marlonfuchs no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-06-2002, 08:13

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L