Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    blaizer
    Bom tenho uma maquina com um servidor RADIUS rodando 100% , ele autentica em uma base de dados que está em MySQL , o pessoal que utiliza Internet discada já está autenticando normalmente nesse servidor a 1 mes !!

    Tem outra maquina que faz um gateway com uma rede wireless que sou provedor , instalei nessa maquina gateway os serviços pppoe-server e ppp .

    Ok rodo tudo normal , fui testar a autenticação , ok , a conexao chega a ser estabelecida , ele envia o nome e senha de usuario para o meu servidor gateway , mas meu servidor gateway nao repassa para o servidor em radius fazer a validação ai da esse erro no arquivos :
    tail -f /var/log/message
    LCP: timeout sending Config-Requests

    e desconecta no pc com windows dizendo que o servidor não respondeu , já refiz a configuracao do meu ppp e radiusclient e nada , de dar certo

    uso o radtest para testar do meu gateway e ele funciona normal , nao sei como que se faz para repassar o pedido do meu gateway para o meu servidor de radius que tem a base de dados ... se alguem tiver uma ideia poste aqui !!
    Após eu terminar de configurar isso tudo , irei montar um tutorial show de bola para a galera nao ficar atraz disso igual eu estou ... .heehe Abraços , desde já

    Obrigado a todos....
    Alan Mendes ....

  2. #2
    wren
    Po kara, não sei se entendi muito bem, vc disse q o servidor(gw) estava funcionando, mas a autenticação não?
    ou seja, os clientes não conseguem conectar no servidor radius atraves do pppoe server é isso?

    Bom o q vc pode fazer para resolver isso é o seguinte, o servidor pppoe, tem q enxergar o servidor radius. Dentro do etc/radiusclient vc vai precisar editar o arquivo radiusclient.conf e colocar o endereço do seu server radius lá!
    authserver x.x.x.x :x (com o ip do seu server é a porta ele esta escutando)
    acctserver x.x.x.x :x
    uma pergunta qnd vc usou o radtest qual ip q vc colocou, e em qual máquina vc executou o teste, se possível coloque os ips q vc está trabalhando!!

    Abraços Caio Herdy



  3. #3
    blaizer
    O meu usuario final ( quem vai tentar fazer a autenticação ) está na faixa de ip 10.10.3.0-255 , meu servidor pppoe tem o ip eth1 = 10.10.3.254 , eth0 = 10.10.2.1
    meu servidor radius tem o ip : 10.10.2.10.

    Quando testo o radtest da maquina que é o pppoe-server ele funciona ele testa a senha no servidor e fica tudo ok ....

    agora quando o usuario final tenta autenticar pelo pppoe ele me da essa resposta no tail -f /var/log/message

    Nov 18 07:55:21 scarry pppd[2338]: Plugin radius.so loaded.
    Nov 18 07:55:21 scarry pppd[2338]: RADIUS plugin initialized.
    Nov 18 07:55:21 scarry pppd[2338]: Plugin radattr.so loaded.
    Nov 18 07:55:21 scarry pppd[2338]: RADATTR plugin initialized.
    Nov 18 07:55:21 scarry kernel: CSLIP: code copyright 1989 Regents of the University of California
    Nov 18 07:55:21 scarry kernel: PPP generic driver version 2.4.2
    Nov 18 07:55:21 scarry pppd[2338]: pppd 2.4.3 started by root, uid 0
    Nov 18 07:55:21 scarry pppd[2338]: Using interface ppp0
    Nov 18 07:55:21 scarry pppd[2338]: Connect: ppp0 <--> /dev/pts/2
    Nov 18 07:55:35 scarry pppoe-server[2336]: Bogus PPPoE length field (8224)
    Nov 18 07:55:52 scarry pppd[2338]: LCP: timeout sending Config-Requests
    Nov 18 07:55:52 scarry pppd[2338]: Connection terminated.
    Nov 18 07:55:52 scarry pppd[2338]: Using interface ppp0
    Nov 18 07:55:52 scarry pppd[2338]: Connect: ppp0 <--> /dev/pts/3
    Nov 18 07:55:57 scarry pppd[2338]: tcflush failed: Bad file descriptor
    Nov 18 07:55:57 scarry pppd[2338]: Exit.
    Nov 18 07:55:57 scarry pppoe-server[2336]: Session 1 closed for client 00:10:60:5d:94:49 (10.10.4.0) on eth1
    Nov 18 07:55:57 scarry pppoe-server[2336]: Sent PADT


    O servidor pppoe nao está chamando o radtest ou nao sei qual dispositivo ele usa para conectar , acho que deve ser isso !!

    meu /etc/ppp/pppoe-server-options

    require-pap
    login
    lcp-echo-interval 10
    lcp-echo-failure 2
    ms-dns 200.159.78.1
    ms-dns 200.159.78.10
    plugin radius.so
    plugin radattr.so
    logfile /var/log/pppd.log

    Obrigado ... !

  4. Cara, parece que o seu pppoe-server não está encontrando o radius para autenticar.

    Nos logs do radius aparece alguma coisa?

    Você falou que a classe de ips que você utiliza é 10.10.3.0 nos clientes e 10.10.2.0 nos servidores, por que nos logs tem uma linha em que aparece a classe 10.10.4.0
    Nov 18 07:55:57 scarry pppoe-server[2336]: Session 1 closed for client 00:10:60:5d:94:49 (10.10.4.0) on eth1
    Outra coisa, você já chegou a ver esse tutorial aqui https://under-linux.org/wiki/Tutoriais/Pppoe.



  5. Desculpe minha ignoracia mas como funciona este lançe do PPOE + radius em redes ADSL ?? como funciona ? qual a finalidade ???


    Abraço a todos






Tópicos Similares

  1. problema com servidor pppoe
    Por jasonlinux no fórum Redes
    Respostas: 0
    Último Post: 25-08-2007, 22:52
  2. Problemas com Servidor (Samba/FTP/arquivos)
    Por bisturi no fórum Servidores de Rede
    Respostas: 0
    Último Post: 19-04-2005, 17:53
  3. Problemas com foreign key no MYSQL...
    Por kallunga no fórum Servidores de Rede
    Respostas: 6
    Último Post: 09-03-2005, 15:50
  4. Problemas com servidor PPP
    Por F-15_RJ no fórum Servidores de Rede
    Respostas: 0
    Último Post: 28-10-2003, 04:06
  5. problemas com servidor de mail
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-06-2003, 10:22

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L