+ Responder ao Tópico



  1. #1
    andreabreu
    Visitante

    Padrão Como faço para resolver dependências?

    Baixei pacotes que tinham as libs das dependencias abaixo, abri os rpm no mc e copiei as libs para o usr/lib. Criei os links simbólicos com os nomes que as dependêcias pedem. Rodei o ldconfig mas ainda assim, quando rodo o apt-get dá a mensagem abaixo.

    Como faço para resolver estas dependências? Já baixei os rpm's que tem estas dependências mas não instalei o rpm todo, apenas pus as libs no usr/lib com os links necessários. O que eu fiz errado?

    não quis instalar os pacotes inteiros, pois o primeiro, o readline, o apt-get mandou um aviso que iria remover alguns pacotes e isto não era recomendado.

    SEGUEM AS MENSAGENS:

    [[email protected] andre]# cd pg
    [[email protected] pg]# apt-get install *.rpm
    Lendo Listas de Pacotes... Feito
    Construindo Árvore de Dependências... Feito
    Selecionando postgresql para 'postgresql-8.0.4-2PGDG.i686.rpm'
    Selecionando postgresql-devel para 'postgresql-devel-8.0.4-2PGDG.i686.rpm'
    Selecionando postgresql-docs para 'postgresql-docs-8.0.4-2PGDG.i686.rpm'
    Selecionando postgresql-jdbc para 'postgresql-jdbc-8.0.4-2PGDG.i686.rpm'
    Selecionando postgresql-libs para 'postgresql-libs-8.0.4-2PGDG.i686.rpm'
    Selecionando postgresql-server para 'postgresql-server-8.0.4-2PGDG.i686.rpm'
    Selecionando postgresql-test para 'postgresql-test-8.0.4-2PGDG.i686.rpm'
    Alguns pacotes não puderam ser instalados. Isso pode significar que
    você solicitou uma situação impossível ou se você está usando a
    distribuição instável, que alguns pacotes requeridos não foram
    criados ainda ou foram tirados do Incoming.
    A seguinte informação pode ajudar a resolver a situação:

    Os seguintes pacotes têm dependências não resolvidas:
    postgresql: Depende: libcrypto.so.5 mas este não é instalável
    Depende: libreadline.so.5 mas este não é instalável
    Depende: libssl.so.5 mas este não é instalável
    postgresql-devel: Depende: libcrypto.so.5 mas este não é instalável
    Depende: libreadline.so.5 mas este não é instalável
    Depende: libssl.so.5 mas este não é instalável
    postgresql-libs: Depende: libcrypto.so.5 mas este não é instalável
    Depende: libkrb5.so.3(krb5_3_MIT) mas este não é instalável
    Depende: libssl.so.5 mas este não é instalável
    postgresql-server: Depende: libcrypto.so.5 mas este não é instalável
    Depende: libkrb5.so.3(krb5_3_MIT) mas este não é instalável
    Depende: libreadline.so.5 mas este não é instalável
    Depende: libssl.so.5 mas este não é instalável
    E: Pacotes quebrados

  2. #2
    RafaelMonteiro
    Visitante

    Padrão Como faço para resolver dependências?

    vá para a ultima linha do erro. e começe a instalar de tras pra frente...



  3. #3
    andreabreu
    Visitante

    Padrão Como faço para resolver dependências?

    Desculpa, mas não entendi.
    Como eu ja disse, instalei todas as libs no /usr/lib, fiz os links e rodei ldconfig.
    Tem uma ordem para fazer isto?

  4. #4

    Padrão Como faço para resolver dependências?

    faz o seguinte.



    apt-get -h verifica qual a opção que você precisa pra ver dependencias, pode resolver seu problema.



  5. #5

    Padrão Use

    Pode usar apt-get -f install. Para corrigir uma base que dependencias.


    mas o comando é : apt-get install postgresql*

    Na verdade ela vai pegar tudo referente a postgresql e vai instalar com dependencias e tudo. sempre coloque o pacote + * que ela vai pegar tudo referente.