+ Responder ao Tópico



  1. #1
    Bugs
    Pessoal estou tento problemas de spam no meu apache....
    no access.log dele esta aparecendo milhares de Requisições, que esta fazendo com que meu link fique saturado somente com esse problema.
    exemplo das requisições

    68.211.176.172 - - [18/Nov/2005:10:29:21 +0000] "GET http://209.73.169.1/config/login?.re...&passwd=123456 HTTP/1.0" 404 206 "-" "-"
    201.29.79.240 - - [18/Nov/2005:10:29:23 +0000] "GET / HTTP/1.0" 302 1 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.40607)"
    87.122.18.64 - - [18/Nov/2005:10:29:23 +0000] "GET http://62.159.82.27:80/MCUpdateCMS/updatefiles/ip.php HTTP/1.1" 404 236 "-" "Mozilla/3.0 (compatible; Indy Library)"
    59.42.57.197 - - [18/Nov/2005:10:29:24 +0000] "GET http://www.clickingagent.com/proxych...2&port=80&loc= HTTP/1.0" 404 208 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
    222.89.77.132 - - [18/Nov/2005:10:29:29 +0000] "POST HTTP://mqqact.qq.com/cgi-bin/sk_c_login.cgi HTTP/1.1" 404 228 "http://mqqact.qq.com/sms_king/sk_index.shtml" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"
    80.228.209.81 - - [18/Nov/2005:10:29:31 +0000] "GET http://62.159.82.27:80/MCUpdateCMS/updatefiles/ip.php HTTP/1.1" 404 236 "-" "Mozilla/3.0 (compatible; Indy Library)"
    64.182.245.33 - - [18/Nov/2005:10:29:34 +0000] "CONNECT login.icq.com:80 HTTP/1.0" 200 2943 "-" "-"
    59.42.57.197 - - [18/Nov/2005:10:29:34 +0000] "GET http://www.ftjcfx.com/image-1699135-10379808 HTTP/1.0" 404 216 "http://www.thestar.com" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"


    esses sites que aparecem na lista nao estao no meu servidor web....
    pelo que pude compreender algum estão utilizando meu servidor WEB como proxy externo para acessar sites externos.
    ja revirei tudo as confs do apache de pé a cabeça e nao consegui descobrir algum erro q possa ter cometido, mesmo pq tenho outros servidores rodando perfeitamente sem este problema.

    ja coloquei regras no firewall para aceitar somente requisicoes na porta 80 somente para endereços com destino no meu dominio..
    por exemplo, e nada adiantou.

    iptables -A INPUT -i eth0 -p tcp --dport 80 -d ! webmail.dominio.com.br -j DROP
    iptables -A INPUT -i eth0 -p tcp --dport 80 -d ! www.dominio.com.br -j DROP

    Se alguem ja passou por isso por favor AJUDE !!!
    ta tenso....

    Abraços...

  2. #2
    vinimaciel
    Por acaso voce esta usando o mod_proxy em seu server?
    Se sim tens que fecha-lo para nao aceitar conexoes externas.


    Vinicius Maciel Simchak



    Citação Postado originalmente por Bugs
    Pessoal estou tento problemas de spam no meu apache....
    no access.log dele esta aparecendo milhares de Requisições, que esta fazendo com que meu link fique saturado somente com esse problema.
    exemplo das requisições

    68.211.176.172 - - [18/Nov/2005:10:29:21 +0000] "GET http://209.73.169.1/config/login?.re...&passwd=123456 HTTP/1.0" 404 206 "-" "-"
    201.29.79.240 - - [18/Nov/2005:10:29:23 +0000] "GET / HTTP/1.0" 302 1 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.40607)"
    87.122.18.64 - - [18/Nov/2005:10:29:23 +0000] "GET http://62.159.82.27:80/MCUpdateCMS/updatefiles/ip.php HTTP/1.1" 404 236 "-" "Mozilla/3.0 (compatible; Indy Library)"
    59.42.57.197 - - [18/Nov/2005:10:29:24 +0000] "GET http://www.clickingagent.com/proxych...2&port=80&loc= HTTP/1.0" 404 208 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)"
    222.89.77.132 - - [18/Nov/2005:10:29:29 +0000] "POST HTTP://mqqact.qq.com/cgi-bin/sk_c_login.cgi HTTP/1.1" 404 228 "http://mqqact.qq.com/sms_king/sk_index.shtml" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"
    80.228.209.81 - - [18/Nov/2005:10:29:31 +0000] "GET http://62.159.82.27:80/MCUpdateCMS/updatefiles/ip.php HTTP/1.1" 404 236 "-" "Mozilla/3.0 (compatible; Indy Library)"
    64.182.245.33 - - [18/Nov/2005:10:29:34 +0000] "CONNECT login.icq.com:80 HTTP/1.0" 200 2943 "-" "-"
    59.42.57.197 - - [18/Nov/2005:10:29:34 +0000] "GET http://www.ftjcfx.com/image-1699135-10379808 HTTP/1.0" 404 216 "http://www.thestar.com" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"


    esses sites que aparecem na lista nao estao no meu servidor web....
    pelo que pude compreender algum estão utilizando meu servidor WEB como proxy externo para acessar sites externos.
    ja revirei tudo as confs do apache de pé a cabeça e nao consegui descobrir algum erro q possa ter cometido, mesmo pq tenho outros servidores rodando perfeitamente sem este problema.

    ja coloquei regras no firewall para aceitar somente requisicoes na porta 80 somente para endereços com destino no meu dominio..
    por exemplo, e nada adiantou.

    iptables -A INPUT -i eth0 -p tcp --dport 80 -d ! webmail.dominio.com.br -j DROP
    iptables -A INPUT -i eth0 -p tcp --dport 80 -d ! www.dominio.com.br -j DROP

    Se alguem ja passou por isso por favor AJUDE !!!
    ta tenso....

    Abraços...



  3. Ola

    Faça com que o proxy, aceite apenas conexões internas. Altere no inicio do squid.conf para:

    http_port 192.168.1.1:3128
    icp_port 0

    onde 192.138.1.1 é o Ip_falso do teu server e 3128 é a porta

    vlw






Tópicos Similares

  1. spam no QMAIL
    Por SnifferSp no fórum Servidores de Rede
    Respostas: 1
    Último Post: 07-08-2002, 11:29
  2. SPAM no campo from
    Por shido no fórum Servidores de Rede
    Respostas: 1
    Último Post: 02-08-2002, 09:19
  3. Estatísticas no apache
    Por ediguedes no fórum Servidores de Rede
    Respostas: 3
    Último Post: 29-07-2002, 10:56
  4. Spam no sendmail tem como?
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-06-2002, 09:07
  5. Mod_SSL No apache 2.0.36
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-04-2002, 01:20

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L