+ Responder ao Tópico



  1. #1

    Padrão Mensagem de Erro no Servidor

    Caro amigos tenho um servidor instalado debian, nele tem um script para fazer backup diario, entao ele sempre fica ligado na empresa, quando eu chego ele me mostra a seguinte mensagem.

    st0: Block Limits 1 - 16777215 bytes.
    mptbase: ioc0: LogInfo(0x11010600) : F/W: Bug! MID not found
    mptbase: ioc0: LogInfo(0x11010600) : F/W: Bug! MID not found
    mptbase: ioc0: LogInfo(0x11010600) : F/W: Bug! MID not found
    st0: Error with sense data: Current st09:00: sns = 70 6
    ASC=29 ASCQ=0
    Raw sense data:0x70 0x00 0x06 0x00 0x00 0x00 0x00 0x00a 0x00 0x00 0x00 0x00 0x29 0x00 0x00 0x00 0x01 0x01

    Esse e a mensagem, alguem poderia me ajudar

  2. #2

    Padrão Re: Mensagem de Erro no Servidor

    Citação Postado originalmente por carlos_itau
    Caro amigos tenho um servidor instalado debian, nele tem um script para fazer backup diario, entao ele sempre fica ligado na empresa, quando eu chego ele me mostra a seguinte mensagem.

    st0: Block Limits 1 - 16777215 bytes.
    mptbase: ioc0: LogInfo(0x11010600) : F/W: Bug! MID not found
    mptbase: ioc0: LogInfo(0x11010600) : F/W: Bug! MID not found
    mptbase: ioc0: LogInfo(0x11010600) : F/W: Bug! MID not found
    st0: Error with sense data: Current st09:00: sns = 70 6
    ASC=29 ASCQ=0
    Raw sense data:0x70 0x00 0x06 0x00 0x00 0x00 0x00 0x00a 0x00 0x00 0x00 0x00 0x29 0x00 0x00 0x00 0x01 0x01

    Esse e a mensagem, alguem poderia me ajudar
    Tem como você postar o seu script aí para a gente ver o que ele faz?

    Sempre dá este erro, desde que você colocou o script pra funcionar, ou isso começou de uns tempos prá cá?



  3. #3
    mod3vic3
    Visitante

    Padrão O script que uso atualmente

    # Reseta a fita na unidade
    mt -f /dev/st0 rewind

    # Indica inicio do backup no log
    echo "------------------------------------------------------------" >> /var/log/d3/bkptopazio.log
    echo "Backup D3/Topazio Inicio.....: `date`" >> /var/log/d3/bkptopazio.log
    /usr/bin/d3tcl backup-diario >/var/log/d3/bkp-diario.log 2>&1
    echo "Backup D3/Topazio Fim........: `date`" >> /var/log/d3/bkptopazio.log

    # gravando o backup
    echo "Backup em fita Inicio........: `date`" >> /var/log/d3/bkptopazio.log
    tar Ppcvfz /dev/st0 /topazio /home >/var/log/d3/fita.log
    echo "Backup em fita Termino.......: `date`" >> /var/log/d3/bkptopazio.log
    echo " " >> /var/log/d3/bkptopazio.log
    # ejetando a fita
    mt -f /dev/st0 offline
    echo "Fita ejetada em..............: `date`" >> /var/log/d3/bkptopazio.log
    echo "------------------------------------------------------------" >> /var/log/d3/bkptopazio.log

  4. #4

    Padrão Mensagem de Erro no Servidor

    O erro começou a dar de um tempo para ca, e as vezes da o erro, hoje deu erro mais o sistema esta funcionando normalmente mais as vezes o servidor trava.



  5. #5

    Padrão Mensagem de Erro no Servidor

    Esse erro, pelo que pesquisei no nosso amigo google é referente a falha em mídia, provavelmente o teu backup está comprometido.
    Minha sugestão é que, imediatamente, tente recuperar o backup em outra máquina para se certificar, se for, comprar novas fitas e verificar a unidade de backup.

  6. #6

    Padrão Mensagem de Erro no Servidor

    As fitas que estou usando sao todas novas, tem menos de um mês que troquei todas, a minha fita e uma DDS-4 de 20/40 GB.



  7. #7

    Padrão Mensagem de Erro no Servidor

    Cara sinceramente não sei o que pode ser, andei procurando no google o que poderia ser o erro, parece que o sistema não está conseguindo montar/gravar os dados na fita, alguma coisa assim.


    Você tem que analisar desde quando está dando erro, você fez alguma alteração no servidor, mudou os tipos de fita?

  8. #8

    Padrão Mensagem de Erro no Servidor

    Acabei de fazer a mesma rotina do backup mais no modo manual, e nao deu nenhum erro. apenas esta dando o erro se a rotina estiver no automatico


    meu crontab esta com essas linhas: (sendo executado como root)

    40 02 * * 1-6 /sbin/shutdown -y -r now >/var/log/shutdown.log 2>&1
    00 04 * * 1-6 /usr/local/bin/bkp_topazio >/var/log/d3/cron-bkp.log 2>&1



  9. #9

    Padrão Mensagem de Erro no Servidor

    Cara, muito estranho o fato de as vezes dar erro e as vezes não. Eu acredito que o problema seja com as fitas.

    Faça um teste aí com todas elas, manual e também diminua o tempo entre as execuções no cron e deixe executar automático.

    Verifique se não tem algum problema com hardware, cabos, algum mau contato. Quem sabe né, já vi quase tudo nesse mundo da informática.

  10. #10

    Padrão Outro erro no meu sistema

    Amigos um outro erro que tb está aparecendo no meu servidor e esse

    Open denied
    : Permission denied
    /usr/lib/printfilters/master-filter: $thetempfile: ambiguous redirect

    O que pode ser isso ??



  11. #11

    Padrão Mensagem de Erro no Servidor

    Você efetuou um teste de restore para ver se o teu backup não está comprometido ???
    Se você roda "na mão" ele não dá problemas ? mesmo que seja na mesma fita que deu erro ???
    Por que você reinicia o servidor ???

  12. #12

    Padrão Mensagem de Erro no Servidor

    Eu ja efetuei o restore, quando eu faço na mão o backup faz ok, quando ele trava o backup nem faz.


    Fizemos o teste na mão com a mesma fita que deu erro, e ela foi ok.


    Geralmente nos nao reiniciamos o servidor, estamos reiniciando ele agora devido a esses erros para tentar envitar. pois ele fica travado na tela de login.



  13. #13
    Visitante

    Padrão Re: Mensagem de Erro no Servidor

    Citação Postado originalmente por carlos_itau
    Caro amigos tenho um servidor instalado debian, nele tem um script para fazer backup diario, entao ele sempre fica ligado na empresa, quando eu chego ele me mostra a seguinte mensagem.

    st0: Block Limits 1 - 16777215 bytes.
    mptbase: ioc0: LogInfo(0x11010600) : F/W: Bug! MID not found
    mptbase: ioc0: LogInfo(0x11010600) : F/W:not founse 01 0x01

    Esse e a mensagem, alguem poderia me ajudar

  14. #14
    Super_Diaulas
    Visitante

    Padrão Re: Outro erro no meu sistema

    Citação Postado originalmente por carlos_itau
    Amigos um outro erro que tb está aparecendo no meu servidor e esse

    Open denied
    : Permission denied
    /usr/lib/printfilters/master-filter: $thetempfile: ambiguous redirect

    O que pode ser isso ??

    esse $thetempfile não tem no seu script, onde ele entra? Nem sei se é coisa da fita mesmo
    mas, de repente tenta declarar ele no inicio, bota qualquer valor nele.

    pode problema de ambiente tb
    os comandos tenta botar o full path tipo

    /bin/tar


    # Reseta a fita na unidade
    mt -f /dev/st0 rewind
    Isso não reseta a fita, apenas rebobina, bota isso no final para testar


    Qual cron tá agendado? na do root?

    Verifiquei no google também, existem vários casos iguais, mas sem solução aparente, muitos diziam que era bug,
    tente trocar a controladora (caso tenha), o terminador e a unidade

    Outras perguntas, qual distro e qual kernel???

    Mas ainda acredito que seja fita ruim



  15. #15
    Super_Diaulas
    Visitante

    Padrão Mensagem de Erro no Servidor

    achei mais isso


    http://seclists.org/lists/linux-kern.../Dec/0417.html

    Linux Kernel: [GIT PATCH] SCSI bug fixes for 2.6.15-rc4

  16. #16

    Padrão Mensagem de Erro no Servidor

    O script esta agendado no cron do root, uso Debian com Kernel 2.4.
    E qual é o comando que eu posso usar para pagar os dados da fita ?