+ Responder ao Tópico



  1. #1

    Padrão erro na compilação do kernel!

    estou tentando compilar um kernel-2.6.8 em um debian-sarge, porém sempre me retorna esse erro:

    SPLIT include/linux/autoconf.h -> include/config/*
    HOSTCC scripts/genksyms/genksyms.o
    SHIPPED scripts/genksyms/lex.c
    SHIPPED scripts/genksyms/parse.h
    SHIPPED scripts/genksyms/keywords.c
    HOSTCC scripts/genksyms/lex.o
    SHIPPED scripts/genksyms/parse.c
    HOSTCC scripts/genksyms/parse.o
    HOSTLD scripts/genksyms/genksyms
    CC scripts/mod/empty.o
    HOSTCC scripts/mod/mk_elfconfig
    MKELF scripts/mod/elfconfig.h
    HOSTCC scripts/mod/file2alias.o
    HOSTCC scripts/mod/modpost.o
    HOSTCC scripts/mod/sumversion.o
    HOSTLD scripts/mod/modpost
    HOSTCC scripts/conmakehash
    HOSTCC scripts/kallsyms
    HOSTCC scripts/pnmtologo
    HOSTCC scripts/bin2c
    CC arch/i386/kernel/asm-offsets.s
    In file included from include/asm/thread_info.h:16,
    from include/linux/thread_info.h:21,
    from include/linux/spinlock.h:12,
    from include/linux/capability.h:45,
    from include/linux/sched.h:7,
    from arch/i386/kernel/asm-offsets.c:7:
    include/asm/processor.h:87: error: array type has incomplete element type
    make[1]: ** [arch/i386/kernel/asm-offsets.s] Erro 1
    make: ** [arch/i386/kernel/asm-offsets.s] Erro 2
    alguém pode dar uma ajuda?

    valeu!

  2. #2

    Padrão erro na compilação do kernel!

    jah tive esse pau em alguma máquina, mas agora nao lembro ao certo oque foi que eu fiz, soh lembro que tinha que desabilitar uma opção referente ai ao asm, bom mas já que vc ta compilando na mao abaixa a versão mais nova que deve resolver (2.6.14.3)



  3. #3

    Padrão erro na compilação do kernel!

    agora quando rodo o comando, da esse erro ai!

    make menuconfig
    HOSTCC scripts/kconfig/mconf.o
    scripts/kconfig/mconf.c:91: error: static declaration of ‘current_menu’ follows non-static declaration
    scripts/kconfig/lkc.h:63: error: previous declaration of ‘current_menu’ was here
    make[1]: ** [scripts/kconfig/mconf.o] Erro 1
    make: ** [menuconfig] Erro 2
    make modules
    CHK include/linux/version.h
    HOSTCC scripts/kconfig/mconf.o
    scripts/kconfig/mconf.c:91: error: static declaration of ‘current_menu’ follows non-static declaration
    scripts/kconfig/lkc.h:63: error: previous declaration of ‘current_menu’ was here
    make[2]: ** [scripts/kconfig/mconf.o] Erro 1
    make[1]: ** [silentoldconfig] Erro 2
    make: ** [include/linux/autoconf.h] Erro 2
    valeu!

  4. #4

    Padrão erro na compilação do kernel!

    o problema era o sequinte!

    para compilar o linux 2.6 com binutils-2.16 use o seguinte patch

    http://www.kernel.org/pub/linux/deve....6-seg-5.patch

    patch -Np1 -i linux-2.6-seg-5.patch

    falo!



  5. #5

    Padrão erro na compilação do kernel!

    Citação Postado originalmente por flipeexpl
    agora quando rodo o comando, da esse erro ai!

    make menuconfig
    HOSTCC scripts/kconfig/mconf.o
    scripts/kconfig/mconf.c:91: error: static declaration of ‘current_menu’ follows non-static declaration
    scripts/kconfig/lkc.h:63: error: previous declaration of ‘current_menu’ was here
    make[1]: ** [scripts/kconfig/mconf.o] Erro 1
    make: ** [menuconfig] Erro 2
    make modules
    CHK include/linux/version.h
    HOSTCC scripts/kconfig/mconf.o
    scripts/kconfig/mconf.c:91: error: static declaration of ‘current_menu’ follows non-static declaration
    scripts/kconfig/lkc.h:63: error: previous declaration of ‘current_menu’ was here
    make[2]: ** [scripts/kconfig/mconf.o] Erro 1
    make[1]: ** [silentoldconfig] Erro 2
    make: ** [include/linux/autoconf.h] Erro 2
    valeu!
    Amigo, estava com esse problema aqui.
    Basta você remover o gcc versão 4.0 e instalar o gcc 3.3.
    Aqui eu fiz isso e resolveu o problema.

    Abraços