+ Responder ao Tópico



  1. #1
    ph4lc0n
    Visitante

    Padrão problemas com instalaçao de programas

    aee galera, estou com problemas na instaçao de softwares e quando vou instalar, que uso os comandos make, make install e ./configure da
    isso ae oh:

    [[email protected] lmule-1.3.1]# make
    make: *** Nenhum alvo indicado e nenhum arquivo make encontrado. Pare.
    [[email protected] lmule-1.3.1]# make install
    make: *** Sem regra para processar o alvo `install'. Pare.
    [[email protected] lmule-1.3.1]# ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for g++... g++
    checking for C++ compiler default output... a.out
    checking whether the C++ compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C++ compiler... yes
    checking whether g++ accepts -g... yes
    checking for style of include used by make... GNU
    checking dependency style of g++... gcc3
    checking for gcc... gcc
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ANSI C... none needed
    checking dependency style of gcc... gcc3
    checking how to run the C preprocessor... gcc -E
    checking for pthread_attr_init in -lpthread... yes
    checking for XML_ParserCreate in -lexpat... no
    configure: error: libexpat not found
    [[email protected] lmule-1.3.1]#

    vlw, espero que me ajudem a solcuionar isso!
    mtos tem essa dúvida. e desistem no meio do caminho, eu nao vou desistir!!
    mais uma vez obrigado!

  2. #2

    Padrão problemas com instalaçao de programas

    "checking for XML_ParserCreate in -lexpat... no
    configure: error: libexpat not found
    [[email protected] lmule-1.3.1]#
    "

    aparentemente uma biblioteca complementar, que não foi encontrada.

    vc deve ter aí nêsse folder criado quando vc descompactou o arquivo original (tar.gz ou tar.bz2) um README ou um INSTALL. Leia-os, normalmente contém as instruções específicas para o pacote.

    :twisted: