Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    lfelipe
    Galera, seguinte:

    estou tentando implementar a lixeira no samba, fazendo da seguinte forma, incluindo as seguintes linhas no smb.conf, abaixodo compartilhamento desejado:

    vfs object = /usr/lib/samba/vfs/recycle.so
    vfs options = /etc/samba/recycle.conf

    mas quando vou acessar o compartilhamento me da erro, dizendo que não tenho permissão e tal, e se eu comentar a linha do vfs object, consigo acessar normalmente, mas porem, sem a lixeira.

    Alguem saberia o que esta acontencendo. Help-me!

    Thank's.

    Falow

  2. ja fiz a lixeira no samba posta ai o smb.conf e diz qual versao do samba vc ta usando.



  3. #3
    lfelipe
    e então, segue o smb.conf...
    as linhas que estão comentada do vfs é que estão dando problema.

    # Samba config file created using SWAT
    # from servidor.com.br

    # Global parameters
    [global]
    workgroup = (nome da empresa)
    security = SHARE
    encrypt passwords = Yes
    log level = 1
    log file = /var/log/samba/log.%m
    socket options = IPTOS_LOWDELAY TCP_NODELAY
    domain logons = Yes
    preferred master = True
    domain master = True
    admin users = felipe

    [Works]
    path = /melc/Arquivos
    read only = No
    force create mode = 0777
    force directory mode = 0777
    guest only = Yes
    guest ok = Yes
    #vfs object = /lib/vfs/recycle.so
    vfs options = /etc/samba/recycle.conf

    [printers]
    path = /tmp
    printable = Yes
    browseable = No
    available = No


    [Imob]
    path = /imobiliar/servicos/
    read only = No
    force create mode = 0777
    force directory mode = 0777
    guest ok = Yes
    #vfs object = /usr/lib/samba/vfs/recycle.so
    vfs options = /etc/samba/recycle.conf

    [Info]
    comment = Diretorio de TI
    path = /imobiliar/servicos/Informatica/
    read only = No
    force create mode = 0777
    force directory mode = 0777
    guest ok = Yes
    #vfs object = recycle.so
    vfs options = /etc/samba/recycle.conf

  4. Cara no meu Debian eu fiz a seguinte alteração:

    De:
    vfs objects = /usr/lib/samba/vfs/recycle.so

    Para:
    vfs objects = recycle

    No testparm ele dá erro, mas funcionou.



  5. kra se o seu for samba 3.0 pra cima vc tem que fazer o seguinte colocar os seguintes parametros no compartilhamento global:
    recycle:exclude = *.tmp *.temp *.o *.obj ~$*
    recycle:keeptree = True
    recycle:touch = True
    recycle:versions = True
    recycle:noversions = *.doc|*.xls|*.ppt|*.dwg|*.dxf|*.txt
    recycle:repository = .lixeira/%U
    recycle:maxsize = 0
    aqui quando o usuarios deletar vai fazer com que apareca uma pasta dentro da lixeira com o nome do usuario.
    Depois vc precisa colocar o parametro:
    vfs objects = recycle
    no compartilhamento que vc queria que tenha a lixeira.

    Mas um conselho tente montar um script para fazer a limpeza dela para nao lotar.

    flw espero ter ajudado.






Tópicos Similares

  1. Lixeira no samba com o Debian
    Por noturnobr no fórum Servidores de Rede
    Respostas: 0
    Último Post: 05-04-2005, 18:47
  2. Lixeira no samba
    Por guiga07 no fórum Servidores de Rede
    Respostas: 3
    Último Post: 18-02-2005, 11:46
  3. Lixeira no Samba
    Por Tonare no fórum Servidores de Rede
    Respostas: 6
    Último Post: 04-03-2004, 21:16
  4. Implementar lixeira no samba
    Por Vaza no fórum Servidores de Rede
    Respostas: 1
    Último Post: 06-01-2004, 08:28
  5. Lixeira no Samba
    Por marcosmamorim no fórum Servidores de Rede
    Respostas: 0
    Último Post: 23-10-2002, 14:36

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L