+ Responder ao Tópico



  1. Bem pessoal o negócio é o seguinte: já instalei várias vezes na minha casa a versão slackware 10 num p233 que tenho, com 64 mb de ram, com intuito de de montar servidor dhcp, proxy-cache e firewall, pois trabalho só na plataforma windows e em termos de seguraça o windows é uma merda e a empresa está pra mandar uma proposta para uma das empresas que agente atende é quer terceirizar essa mão-de-obra, mas eu quero fazer e tentar pegar uma parte dessa grana e aprender que cada dia que passa eu fico mais fã desse sistema operacional.

    Só que econtrei várias dificuldades, a primeira que agora já venci graças aos amigos do fórum foi a de rotear a internet para rede interna, e agora estou tentando configurar um proxy com squid mas é tão difícil que estou quase acreditando que isso não funciona e que todos aqui falam de coisa que não existe mas eu sou insistente e vou continuar tentando.

    Vou tentar explicar como estou fazendo para que alguém possa me ajudar se for possível é claro.

    Bem, baixei o squid para compilar mas quando vai compilar ele passa uma menssagem que não pode criar os executáveis e que o compilador gcc não funcionou e eu lembro que na hora da instalação eu marquei todos os compiladores gcc, c todos que vi ali, detalhe não fiz a instalação full, mas tenho certeza que marquei todos os compiladores será que é um problema da minha mídia ou do meu computador? Ou seja não consigo compilar então pesquisei e achei um squid que não precisa compilar e executei um comando installpkg parece que instalou, mas eu reparei que só criou a pasta squid no /etc no /sbin não criou na pasta /log tb não criou, isso siginifica que não instalou direito? mas mesmo assim eu configurei o arquivo squid.conf executei squid start deu alguns erros no começo mas fui indo corrigindo a sintaxe do arquivo até que não deu mas erro nenhum, depois criei o cache tive criar manualmente a pasta do cache e dar permissão, depois disso tudo, quando configuro o browser no xp não navega de jeito nenhum, vcs acham que eu devo reinstalar o slackware ou tentar uma versão mais nova ou devo ainda insistir um pouco mais nessa instalção?
    Tem alguma maneira de ver se o squid está instalado no sistema mesmo, tipo no windows que tem aquele utilitário de adicionar e remover programas?

    muito obrigado para quem leu isso tudo.

  2. e ae kra blz?

    seguinte, pra ver se seu squid esta realmente instalado faça assim


    Código :
    squid -v

    se ele estiver instalado ele retorna algo parecido com isto

    Código :
    Squid Cache: Version 2.5.STABLE12
    configure options:  --enable-default-err-language=Portuguese --enable-arp-acl --prefix=/etc/squid


    voce disse que teve que criar o diretorio de cache na mao neh? voce precisa apenas criar um diretorio onde sera criada a estrutura do cache, depois é so executar um squid -z que ele ira cria-la

    se possivel posta ae seu squid.conf pra agente ver oq tem errado...

    blz?


    []'s



  3. Foi isso que eu fiz eu criei só diretório dei a permissão no diretório chmod 755 acho que foi isso executei o comando squid -z ele criou e ficou ok.

    Estou no trabalho agora e esse computador onde estou tentando criar esse proxy é na minha casa estou estudando em casa, chegando lá hoje a noite vou executar esse comando pra ver se o squid está instalado e vou te postar aqui o meu conf que retirei daqui do underlinux aí tu dá uma olhada pra mim.

    http_port 3128
    visible_hostname proxy.pvioflas.net
    cache_mem 64 MB
    maximum_object_size_in_memory 5 MB
    maximum_object_size 10 MB
    minimum_object_size 0 KB
    cache_swap_low 90
    cache_swap_high 95

    cache_dir ufs /var/spool/squid/cache1 1000 16 256

    cache_access_log /var/log/squid/access.log
    error_directory /usr/share/squid/errors/Portuguese
    refresh_pattern ^ftp: 15 20% 2280
    refresh_pattern ^gopher: 15 0% 2280
    refresh_pattern . 15 20% 2280


    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 901 # SWAT
    acl purge method PURGE
    acl CONNECT method CONNECT


    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports

    acl blockedsites url_regex -i "/etc/squid/bloqueados/block.txt"
    acl unblockedsites url_regex -i "/etc/squid/bloqueados/unblock.txt"
    http_access deny blockedsites !unblockedsites

    acl redelocal src 192.168.0.0/24
    http_access allow redelocal

    http_access allow localhost

    http_access deny all

    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    Valeu mesmo amigo






Tópicos Similares

  1. Eu sei o que fazer
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-01-2003, 13:18
  2. Respostas: 7
    Último Post: 17-01-2003, 08:14
  3. Dominio Virtual o que fazer?
    Por Anticristh no fórum Servidores de Rede
    Respostas: 2
    Último Post: 23-12-2002, 12:42
  4. acl no squid não está funcionando. O que fazer ?
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 20-12-2002, 16:01
  5. Modem só da ocupado ! O que fazer ??
    Por no fórum Servidores de Rede
    Respostas: 6
    Último Post: 18-11-2002, 23:21

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L