Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Dae galera, mais uma vez estou aqui para ver se alguem pode me dar uma maozinha....
    seguinte, criei um arquivo chamado "firewall", e dentro dele inclui regras com iptables, e coloquei esse arquivo no /etc/init.d, dando permissao de executavel.
    O problema eh que no boot ele nao estah sendo inicializavel, ou seja, somente depois de eu entrar com o usuario root e dar um /etc/init.d/.firewall, eh que as regras comecam a funcionar.
    Alguem pode me dar uma dica de como executar esse arquivo no boot, e nao ficar chamando toda hora que preciso reiniciar a maquina??
    Desde jah agradeco..
    flw....

  2. No slackware por exemplo, depois de criar seu script e coloca-lo em /etc/rc.d é necessario configurar o rc.local e adicionar uma linha que ira executar o script de firewall no boot.

    Nao sei que distro você usa, mas o esquema deve ser o mesmo.
    Da uma olhada nos arquivos desse diretorio.



  3. #3
    wrochal
    Caro,

    Qual distribuição você usa?

    Até,

  4. #4
    charadaa
    tente ao inves de usar caminhos relativos tipo iptables -t nat use por exemplo /sbin/iptables -t nat pois muitas vezes ele não carregou o patch e não consegue entender o caminho relativo, então coloque o absoluto

    Não sei se é isso, mas é uma probabilidade

    Abraços



  5. Amigos, to usando o MANDRIVA 2006.
    Soh pra ressaltar, criei o arquivo "firewall" no init.d, e o mesmo nao carrega no boot, entao, pra rodar esse arquivo, soh se eu estiver como root, e o que eu preciso eh carregar esse arquivo no boot com as regras do firewall.

    Valeu






Tópicos Similares

  1. Ossec não inicia no boot
    Por juliocm no fórum Segurança
    Respostas: 3
    Último Post: 23-01-2013, 10:39
  2. squid não inicia no boot
    Por jnveiga no fórum Sistemas Operacionais
    Respostas: 5
    Último Post: 08-03-2008, 09:43
  3. pppoe nao inicia no boot
    Por flon no fórum Redes
    Respostas: 5
    Último Post: 19-08-2005, 01:23
  4. Minhas Regras de FireWall nao funcionam
    Por elton no fórum Servidores de Rede
    Respostas: 5
    Último Post: 23-12-2004, 11:17
  5. script que nao inicia no boot
    Por demiurgo no fórum Servidores de Rede
    Respostas: 1
    Último Post: 17-03-2003, 17:02

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L