Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Rede lenta...squid?

    Pessoal, depois que a internet aqui no meu serviço passou a ser proxy (squid), coincidência ou não, a rede está lenta.
    Alguem sabe se o squid pode ter relação com a velocidade da intranet?

    Grata

  2. #2

    Padrão Rede lenta...squid?

    Pode ser que seja por causa do squid, depende como tá usando a política de cache, ou uma coincidência também pode haver alguma maquina na tua rede com worm, com isso deixando sua net lenta, alguma placa de rede danificada, tem muitos fatores que podem influenciar. Verifique as regras do teu firewall principalmente no que se refere a tabela filter forward. Veja o log de acesso do squid (tail -f /var/log/squid/access.log).



  3. #3
    charadaa
    Visitante

    Padrão Rede lenta...squid?

    se vc usa intranet escolha opção do seu navegador de internet para excluir que o endereço do seu servidor passe pelo proxy, faça passar direto

  4. #4

    Padrão Rede lenta...squid?

    independente disso, qualquer máquina está lentíssima. eu tirei o servidor de internet da rede e tudo voltou ao normal. tive que voltar com o speedy numa máquina windows e o servidor de internet com fibra ótica + CL10 + iptables + squid está parado. está impossível usar as estações com esse servidor ativo.

    já fuçei o squid.conf, mas nada. se alguém souber o que pode ser, qualquer auxílio é bem-vindo.



  5. #5

    Padrão Rede lenta...squid?

    Torne fazer suas regras de iptables e de suas configurações de squid.
    comece pelo basico e vai analisando a rede. Assim vai conseguir descobrir se a erro de configuração ou o que seja.
    Boa sorte.

  6. #6

    Padrão Rede lenta...squid?

    Poste aqui com está o teu firewall e o squid.conf.

    Essa lentidão se dá quando coloca o servidor no ar, ou depois de um certo tempo, ou em intervalos específicos, esporádicos ?



  7. #7

    Padrão Rede lenta...squid?

    Olá,
    verifique o dns interno/externo da sua rede.

  8. #8
    morenocm
    Visitante

    Padrão Rede lenta...squid?

    Olá!
    Primeiro você precisa especificar o que é a lentidao na sua rede! Acesso a internet ? Acesso ao BD ? Acesso a um compartilhamento de uma estação para outra ? Você verficou como esta a latencia em de sua rede ? Com um simples ping ou tracert você pode ver isto.Instale no teu ser o MTR é um tracert que de da um LOSS de pacotes.ajuda muito! E tira fora o CL, coloca Debian! Muito melhor,sem comparação!(na minha opiniao)
    O Squid e o Iptables com certeza nao "deixa a rede lenta" ele pode deixar o acesso a internet mais lento! Mas o acesso a rede interna jamais.
    Em um cliente,ele tinha uma placa de rede do servidor (que era de marca e novinho) com defeito que disparava muitos pacotes na rede ethernet gerando um trafego absurdo na rede interna,e naturalmente quando ele tirava fora o servidor novinho que recem tinha sido instalado funcionava!
    E o pobre linux era o culpado :-)
    Como eu descobri isto ?
    Um simples ping de uma estação para a outra,o tempo de resposta esta altíssimo,depois com um tcpdump no server vi que era ele mesmo que estava intupindo a rede!! Rde lenta é problema de rede,serviço lento é problema de aplicação ( iptables,squid).
    Lembra que o squid nao é um filtro! Ele "quebra" este galho,mas o show é deixar o squid como proxy/cache e o DansGuardian como Filtro! Você pode usar autenticação com NTLM normalmente(se você usar),mas vai ter que fazer um squid Back e Frontend com comunicação ICP para funcionar,é so rodar duas instancias no mesmo server Maior barbada!
    Se for Iptables o teu stress,quanto menos regras mais rapido! E utilize a tabela mangle para dar uma real melhora no desempenho com esta marcação de pacotes.
    Quaquer coisa estamos ai!
    Bom trabalho!



  9. #9

    Padrão Rede lenta...squid?

    Qualquer horário e qualquer coisa que for fazer na máquina, fica lento. Abrir uma janela qualquer demoooooora. A internet não está lenta, mas para abrir o navegador é uma eternidade.

    Tanto o iptables quanto o squid estavam o mais básico possível. O iptables eu bloqueei tudo depois liberei a porta de acesso.
    O squid estava apenas negar tudo, permitir a rede local e sem cache. E lento. Daí no squid.conf mexi na parte de cache e continuou na mesma.

    No ping, o tempo de resposta a esse servidor é metade do tempo do ping nas estações.

    Acho que independe da distro, seja debian ou conectiva. Isso não tem importância se a configuração está boa. E outra, o servidor de arquivos é conectiva, queríamos um padrão...nós adquirimos o produto com livros e etc. direto da conectiva, estamos acostumados com esta distro...não queria trocar, até pq o problema com certeza nem é esse....

    Alguém tem alguma sugestão do que deve estar errado?

  10. #10

    Padrão Rede lenta...squid?

    Eu não sei se estou certo, mas a ultima vez q vi algo desse tipo, foi quando a rede da empresa de uma amigo meu tinha sido toda infectada com o antigo vírus bugbear.......

    Creio q nao seje isso..

    Pelo q vc disse, creio q as regras do IPTABLES não vão influenciar em nada ( pelo menos acho isso ), e sim quando vc levana o seu Proxy.

    É o seguinte: vc poderia analisar os logs do squid, e postar aqui as suas acls...... para vermos em q poderemos lhe ajudar.

    Esse servidor ja estava sendo usado antes ?
    ou é a primeira vez q está mexendo nele?
    pois, dependendo, pode ser problemas de hardware também.



  11. #11
    felco
    Visitante

    Padrão Rede lenta...squid?

    Natasha tem Samba nesse CL10?

  12. #12

    Padrão Rede lenta...squid?

    A internet não está lenta, mas para abrir o navegador é uma eternidade.
    Então não tem nada a ver com as regras do iptables e o squid. Agora muito estranho tirar o servidor da rede e tudo volta ao normal, faça o seguinte atualize as maquinas e passe um anti-spware caso seja windows. Dê uma olhada na colisão de pacotes do teu servidor através do comando ifconfig.
    Mas para desencargo de consciência faça um teste e nos mande o resultado, é o seguinte crie apenas um nat no iptables, para compartilhar a internet.


    Código :
    iptables -F
    iptables -X
    iptables -Z
     
    iptables -P INPUT  ACCEPT
    iptables -P FORWARD ACCEPT
    iptables -P OUTPUT ACCEPT
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    Caso não seja proxy transparente, desmarque a opção de usar o proxy e faça o teste.
    Mas lembrando com mesmo disse que a internet não está lenta e sim o processo de carregar na memória o browser, verifique os processos em execução.
    Tira todas as maquinas da rede e depois vai colocando uma a uma, pode ser coincidência do servidor está ligado.

    Boa Sorte,



  13. #13

    Padrão Rede lenta...squid?

    Tudo fica lento demais quando essa máquina é servidor de internet.
    Se eu tirar o roteador da placa, mas permanecer a máquina na intranet, volta ao normal. Fica devagar quando está distribuindo a internet.

    Nessa máquina não roda samba. O samba está numa outra máquina, que é servidor de arquivos.

  14. #14
    felco
    Visitante

    Padrão Rede lenta...squid?

    Provavelmente alguma(s) workstation ta com spyware(malware) e quando voce deixa a conexao Internet funcionando eles comecam a usar muito a rede, pra chegar a esse ponto provavelmente deve ter HUB na sua rede em algum lugar ou muitas maquinas estao contaminadas, oque voce pode fazer e definir um ruleset pro firewall mais restritivo, bloqueando tudo e liberando so oque eh necessario, mas isso eh so uma solucao paliativa, e se voce nao tiver pratica no iptables voce vai demorar mais tempo criando ruleset doque limpando o spywares das maquinas, que é absolutamente necessario.

    O mais provavel e que seja spyware, mas pode ser que algum servico estaja sendo "abusado" no proprio firewall, por exemplo, um servidor de smtp, ou ate mesmo o proprio proxy.

    E interessante nesse caso, sempre usar um sniffer para pesquisar a rede e descobrir qual maquina ou oque esta usando os recursos da rede.
    Existem muitas opcoes de sniffer, voce pode utilizar o tcpdump no caso, por exemplo:
    # tcpdump -i eth1 -n host 192.168.0.254 and not port 22

    No caso eu abri uma sessao via ssh pro meu firewall, afim de sniffar, eu pedi para o tcpdump escutar na interface de rede interna, o proprio ip do firewall e para ele nao escutar nada que estiver usando a porta 22(isso porque eu estou usando uma sessao ssh e seria impossivel ver outra coisa, alem do ssh).

    E importante te nocao que em uma rede grande(muitos computadores, +100) voce precisa ser mais minucioso com o sniffer senao voce tera tantas informacoes na tela e nao aproveitara nada, rapidamente, so com uma analize demorada, nesse caso voce tem que verificar aonde esta esse possivel trafego, ignorar o ip do proxy no sniffer e uma boa, as portas que sao padroes de service Microsoft devem ser verificadas primeiro 137,138,139 e 445.

    Um estranho sinal seria voce ver pacotes tentando sair da rede interna usando sempre a mesma porta porem tentando usar um range de IPs, por exemplo, ficticio vo inventar :P:

    16:28:32.840777 IP 192.168.0.10.4088 > 200.124.231.123:445
    16:28:32.840866 IP 192.168.0.10.4088 > 200.124.232.123:445
    16:28:32.840956 IP 192.168.0.10.4088 > 200.124.233.123:445

    Isso, provavelmente, seria um spyware tentando se espalhar, se voce verificar algo parecido em grande quantidade, tenha certeza que sua rede tem spyware.
    Espero ajudar a voce e muitos, porque ja vi muitas duvidas de lentidao aqui no Forum.



  15. #15

    Padrão Rede lenta...squid?

    Natacha sou novo aqui mas vou tentar de ajudar. Vai por parte volte tudo para o que era inicialmente para todos trabalharem.

    Pegue este servidor se vc tiver tempo reinstale o SO vc usa Slackware? Se não, enta usar porque com a pouca experiência que tive ele funciona bem pra cacete comigo. Faça instalação full e tira o KDE pra não levantar modo gráfico, faça isso tudo em paralelo arrume se possível um hub ou switch para vc fazer essa operação depois disso na eth0 vc coloca o ip da sua rede pra teu linux funcionar na internet dns gateway e tudo mais e na outra interface coloque um ip na outra facha ex: 192.168.0.1 habilite dhcp nessa interface, habilite o nat, iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE pra rotear pra tua rede local que vc criou em paralelo e teste primeiro o compartilhamento da internet funcionou blz instala o squid funcionou blz depois fire.

    espero ter ajudado

  16. #16
    rabbarros
    Visitante

    Padrão squid

    Natascha, troque a placa de rede eh ela que esta com problemas...



  17. #17

    Padrão Rede lenta...squid?

    Seguinte, talvez se pergunte, mas porque quando tiro o servidor de internet das estações (gateway), a rede volta a ficar estável pelo menos aparentemente se fosse spware na rede teria que continuar com o mesmo problema, em partes sim. Mas pode ser que o problema seja mesmo em seu servidor, mais especificamente na tua placa de rede, seu servidor deve ter duas placas de rede, acredito eu, uma ligada no modem e outra na rede. Faça o seguinte ligue o modem no hub, ou seja, tire ele do seu servidor, e aquela ligada na tua rede deixa como está, altere a rota default do servidor para o ip do modem. Nas estações volte o gateway para o servidor. Se tudo ficar estável tente fazer isso na placa de rede que estava ligada no modem, se o problema ocorrer, saberá que a placa tá com problema.

  18. #18

    Padrão Rede lenta...squid?

    Bem, spyware eu acredito que não seja, pois para não ficar sem internet instalei o speedy numa máquina windows, esta passou a distribuir a internet e as máquinas voltaram ao normal, sem lentidão.
    se eu ligar o roteador numa máquina windows, fica tudo ok. é só colocar na máquina que está com o CL10 que fica tudo devagar. esta máquina não tem modo gráfico, tem apenas o básico necessário. as suas configurações são medianas (HD 6GB, 128MB Ram, Proc. 1,1 Ghz)

    todas estações estão com antivírus atualizado e são windows.

    sim, há 2 placas de rede, uma para a rede local e a outra ligada no roteador.

    Vioflas, tudo o que vc sugeriu eu já fiz. A distro é conectiva, mas acho que trocá-la não resolveria o problema.


    Estou achando que é a placa de rede mesmo. Vou trocá-la e depois testar...



  19. #19
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.928
    Posts de Blog
    1

    Padrão Rede lenta...squid?

    ja aconteceu comigo isto era placa de rede

  20. #20
    felco
    Visitante

    Padrão Rede lenta...squid?

    antes de fazer isso coloca a maquina na rede eh faz um drop eh ve se a rede fica normal...

    # iptables -t nat -F
    # iptables -t nat -X
    # iptables -F
    # iptables -X
    # iptables -P INPUT DROP
    # iptables -P FORWARD DROP
    # iptables -P OUTPUT DROP