+ Responder ao Tópico



  1. Estou usando o OpenVPN conforme o artigo no
    VivaoLinux(http://www.vivaolinux.com.br/artigos...hp?codigo=2602),mas estou precisando que os dois workgroups e seus micros aparecam no Ambiente de Rede do windows.
    Pelo ping consigo acessar o servidor do outro lado bem como as maquinas atraves deste servidor. Alem disto consigo acessar os compartilhamentos remotos usando o endereço ip.
    Atraves de algumas pesquisas descobri que para as redes se enxergarem é preciso usar o SAmba como servidor WINS.
    O que coloquei para tentar este objetivo é:
    - no samba da matriz(rede 192.168.0.0/24)
    wins support = yes
    hosts allow = 192.168.0. 192.168.1. 127.
    remote browse sync = 192.168.1.255
    obs.: as estacoes estao com wins apontando para 192.168.0.1
    - no samba da filial(rede 192.168.1.0/24)
    wins support = no
    wins server = 192.168.0.1
    hosts allow = 192.168.0. 192.168.1. 127.
    remote browse sync = 192.168.0.255
    obs.: as estacoes estao com wins apontando para 192.168.1.1
    Qualquer ajuda sera bem vinda.
    Obrigado.

    Laercio

  2. Estou colocando abaixo os arquivos completos para ver se alguem me ajuda.

    - smb.conf da matriz
    [global]
    workgroup = WORKGROUP
    netbios name = SERVIDOR01
    netbios aliases = SERVIDOR01
    interfaces = 192.168.0.0/255.255.255.0
    time server = yes
    hosts allow = 192.168.0.1/24 192.168.1.1/24 127.0.0.1/24
    server string = SERVIDOR LINUX
    wins support = yes
    name resolve order = lmhosts host wins bcast
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 0
    panic action = /usr/share/samba/panic-action %d
    passdb backend = tdbsam guest
    obey pam restrictions = yes
    invalid users = root
    unix password sync = yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *Entre\sa\snova\ssenha\sLinux:* %n\n *Redigite\sa\snova\ssenha:* %n\n .
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    add user script = useradd -g usuarios -d /home/%U -s /bin/sh -c %U %U
    delete user script = userdel %U
    logon script = /home/netlogon/logon.bat
    logon path =
    domain logons = Yes
    os level = 64
    preferred master = True
    domain master = True
    admin users = +usuarios
    remote browse sync = 192.168.1.255
    [ipc$]
    hosts allow = 192.168.0.1/24 127.0.0.1/24 192.168.1.1/24

    - smb.conf da filial
    [global]
    workgroup = GRUPO
    netbios name = MICRO01
    netbios aliases = MICRO01
    interfaces = 192.168.1.0/255.255.255.0
    time server = yes
    server string = Samba %v
    hosts allow = 192.168.0. 192.168.1. 192.168.2. 127.
    wins server = 192.168.0.1
    dns proxy = no
    name resolve order = lmhosts host wins bcast
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 0
    panic action = /usr/share/samba/panic-action %d
    passdb backend = tdbsam guest
    obey pam restrictions = yes
    invalid users = root
    unix password sync = yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *Entre\sa\snova\ssenha\sLinux:* %n\n *Redigite\sa\snova\ssenha:* %n\n .
    preserve case = No
    short preserve case = No
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    add user script = useradd -g usuarios -d /home/%U -s /bin/sh -c %U %U
    delete user script = userdel %U
    logon script = logon.bat
    logon path =
    domain logons = Yes
    os level = 64
    preferred master = True
    domain master = True
    admin users = +usuarios
    debug level = 10
    remote browse sync = 192.168.0.255
    [ipc$]
    hosts allow = 192.168.0.1/24 127.0.0.1/24 192.168.1.1/24



  3. O 1.1 não está como servidor wins, está funcionando como cliente do 192.168.0.1!
    Normalmente eu deixo apenas um servidore WINS e funciona legal!
    Tenta colocar nas estações das duas redes o WINS apontando pro 192.168.0.1 ...

    Valeu

  4. #4
    EvertonCastro
    Não sei se é o caso, mas o meu host allow é separado por vírgulas, tipo 192.168.0., 192.168.1., 192.168.3., etc...



  5. Além de tudo isso que já foi pistado, uma dúvida: O servidor que mantém as VPNs tem firewall ativo (em cada ponta)?? Se sim, libere as portas 137:139 bem como a 445. Use o tcpdump para um análise mais completa.

    Att

    mtec :wink:






Tópicos Similares

  1. Respostas: 4
    Último Post: 30-11-2012, 20:56
  2. Clientes se Enchergando Pela Rede
    Por Mr_Dom no fórum Redes
    Respostas: 1
    Último Post: 30-08-2005, 09:09
  3. redes se enxergam
    Por pensador-ce no fórum Servidores de Rede
    Respostas: 7
    Último Post: 24-03-2004, 20:52
  4. fazer 2 redes se comunicarem
    Por Neckratal no fórum Servidores de Rede
    Respostas: 3
    Último Post: 06-02-2004, 12:54
  5. Roteamento pela VPN
    Por 4ndr3 no fórum Servidores de Rede
    Respostas: 7
    Último Post: 18-02-2003, 07:27

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L