+ Responder ao Tópico



  1. Pessoal,

    Estou tentando configurar o Samba para usar a base Ldap. To apanhando para configurar o Ldap. A princio está no ar, mas nào estou conseguindo logar via PHPOpenLdap.
    O q mais me entriga, é q consigo locag via linha de comando.

    EX:
    ldapadd -D "cn=Manager,dc=dominio,dc=local" -x -W
    digito a senha e OK.
    No log do Ldap aparece tudo OK.

    Se usar o mesmo usuário para logar no phpopenldap, aparece o seguinte no log:
    daemon: conn=22 fd=7 connection from IP=127.0.0.1:33204 (IP=0.0.0.0:389) accepted.
    slapd[22516]: conn=22 op=0 BIND dn="" method=128
    slapd[22516]: conn=22 op=0 RESULT tag=97 err=0 text=
    slapd[22516]: conn=22 op=1 SRCH base="dc=dominio,dc=local" scope=2 filter="(uid=cn=Manager,dc=dominio,dc=local)"
    slapd[22516]: conn=22 op=1 SEARCH RESULT tag=101 err=0 text=
    slapd[22516]: conn=22 op=2 UNBIND
    slapd[22516]: conn=-1 fd=7 closed


    segue as configurações do meu config.php do phpopendldap:



    $i++;
    $ldapservers->SetValue($i,'server','name','dominio LDAP Server');
    $ldapservers->SetValue($i,'server','host','127.0.0.1');
    $ldapservers->SetValue($i,'server','port','389');
    $ldapservers->SetValue($i,'server','base',array('dc=dominio,dc=local'));
    $ldapservers->SetValue($i,'server','auth_type','cookie');
    $ldapservers->SetValue($i,'login','dn','');
    $ldapservers->SetValue($i,'login','pass','');
    //$ldapservers->SetValue($i,'server','tls',false);
    $ldapservers->SetValue($i,'server','low_bandwidth',false);
    $ldapservers->SetValue($i,'appearance','password_hash','ssha');
    $ldapservers->SetValue($i,'login','attr','uid');
    $ldapservers->SetValue($i,'login','string','');
    $ldapservers->SetValue($i,'login','class','');
    $ldapservers->SetValue($i,'server','read_only',false);
    $ldapservers->SetValue($i,'appearance','show_create',true);
    $ldapservers->SetValue($i,'auto_number','enable',true);
    $ldapservers->SetValue($i,'auto_number','mechanism','search');
    $ldapservers->SetValue($i,'auto_number','search_base','');
    $ldapservers->SetValue($i,'auto_number','min','1000');
    $ldapservers->SetValue($i,'auto_number','dn','');
    $ldapservers->SetValue($i,'auto_number','pass','');
    $ldapservers->SetValue($i,'login','anon_bind',true);
    $ldapservers->SetValue($i,'custom','pages_prefix','custom_');
    $ldapservers->SetValue($i,'unique_attrs','dn','');
    $ldapservers->SetValue($i,'unique_attrs','pass','');


    Alguém tem alguma idéia?


    Obrigado!

    Valois

  2. Esqueci de comentar:
    Se eu logar anonimo no phpopenldap, ele acessa a base sem problemas. (somente como leitura)


    Valew!






Tópicos Similares

  1. Autenticando squid no LDAP (com samba ja autenticando)
    Por LeoJfa no fórum Servidores de Rede
    Respostas: 0
    Último Post: 11-12-2006, 10:27
  2. MOVIDO: Servidor LDAP com Ubuntu
    Por Fernando no fórum UnderLinux
    Respostas: 0
    Último Post: 12-09-2006, 21:47
  3. Servidor LDAP com Ubuntu
    Por celsobtu no fórum Servidores de Rede
    Respostas: 0
    Último Post: 11-09-2006, 15:57
  4. ldap com jabber
    Por geeko no fórum Servidores de Rede
    Respostas: 0
    Último Post: 07-03-2006, 10:42
  5. Posfix + ldap, com relayhost
    Por Peter_li no fórum Servidores de Rede
    Respostas: 8
    Último Post: 15-12-2004, 08:44

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L