Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Proxy no Mikrotik!!!

    Pessoal,

    Já faz algum tempo que venho tentando fazer um LoadBalance entre 2 links ou mais usando Linux, nas mais variadas distros, mas sem sucesso...

    Hoje resolvi tentar usar o Mikrotik para tal fim e, com pouco mais de duas horas e leitura da documentação, consegui implementar um LoadBalance bastante funcional e, pelo menos até aqui, estável...

    Estou usando um CF-IDE com cartão flash de 64 Mb para o sistema, e um HD IDE de 80 Gb na IDE Secundária, como Master, para fazer o cache do proxy, mas não consegui muito progresso, pois não consigo fazer o bichinho funcionar... Ele simplesmente não responde a nenhuma requisição... Alguém pode me dar uma dica do que está faltando???

    Outra pergunta: é possível usar proxy na mesma máquina com Mikrotik que está fazendo esse LoadBalance???

    A propósito, ainda não coloquei nenhuma licença nele... Tem alguém que vende essas licenças no Brasil, ou só posso comprar no site dos gringos???

    Desde já, obrigado.

  2. #2

    Padrão Proxy no Mikrotik!!!

    Tenho esta versao crackeada, mas nao testada, amanha vou começar a testar, podemos trocar uma idea neste topico. :?

    URL RETIRADA



  3. #3

    Padrão Controle

    Citação Postado originalmente por magnusrk8
    Tenho esta versao crackeada, mas nao testada, amanha vou começar a testar, podemos trocar uma idea neste topico. :?

    URL RETIRADA
    tipow qdo faço o controle de banda no mikrotik ele tb controla a banda dos arquivos que ja estao no cache como deixar o cache sem limite de banda??

  4. #4
    caquino
    Visitante

    Padrão Proxy no Mikrotik!!!

    Infelizmente isso não é possivel, pois não tem como ele diferenciar o que já estava no cache ou não. Fora que um arquivo qdo é acessado pela primeira vez ele vai pro cache e depois é enviado para o cliente.

    O que daria na mesma que nao ter controle de banda para web.



  5. #5

    Padrão Proxy no Mikrotik!!!

    mais de qualquer geito... eh mto bom fazer o pxy-cache... pois ele ira salvar mto de sua banda mesmo usando o controle de banda pois a requisiçao vai vim de seu AP e nao do LINK ...
    tenho uma duvida aqui ... pra por

    uso pppoe nos meus clientes ....
    dai como eu ponho para eles acessarem o proxy do mtk ?
    eu sei que eh pelo dstnat tem que por tudo que vem da 80
    redirecionar para 3128 ... alguem ai podia dar o comando completo ...
    se eu achar o comando antes eu posto aqui pra galera flws...

  6. #6

    Padrão Re: Proxy no Mikrotik!!!

    Citação Postado originalmente por _AGM_
    Pessoal,

    Já faz algum tempo que venho tentando fazer um LoadBalance entre 2 links ou mais usando Linux, nas mais variadas distros, mas sem sucesso...

    Hoje resolvi tentar usar o Mikrotik para tal fim e, com pouco mais de duas horas e leitura da documentação, consegui implementar um LoadBalance bastante funcional e, pelo menos até aqui, estável...

    Estou usando um CF-IDE com cartão flash de 64 Mb para o sistema, e um HD IDE de 80 Gb na IDE Secundária, como Master, para fazer o cache do proxy, mas não consegui muito progresso, pois não consigo fazer o bichinho funcionar... Ele simplesmente não responde a nenhuma requisição... Alguém pode me dar uma dica do que está faltando???

    Outra pergunta: é possível usar proxy na mesma máquina com Mikrotik que está fazendo esse LoadBalance???

    A propósito, ainda não coloquei nenhuma licença nele... Tem alguém que vende essas licenças no Brasil, ou só posso comprar no site dos gringos???

    Desde já, obrigado.
    Ola _AGM_ eu achoq ja falamos por msn, deixa eu te explicar, existe N formas de fazer o loadbalec, tem algumas formas de fazer com mangle outra de so definir dois gw no router, essas duas forma n deixa vc acessar sua maquina de fora e n funciona o cache proxy, isso amigo 'e experiencia tanto pratica quanto de forum da propria MT, entao se estiver fazendo dessa forma ele n vai funcionar mesmo, pq daquela forma ele se perde e n funga.
    abracos.



  7. #7

    Padrão Re: Controle

    Citação Postado originalmente por douglassantos
    Citação Postado originalmente por magnusrk8
    Tenho esta versao crackeada, mas nao testada, amanha vou começar a testar, podemos trocar uma idea neste topico. :?

    URL RETIRADA
    tipow qdo faço o controle de banda no mikrotik ele tb controla a banda dos arquivos que ja estao no cache como deixar o cache sem limite de banda??
    Ola amigo douglassantos, tem como fazer sim o controle de banda fora do cache sim, mas te um detalhe, usa muito processamento da maquina pq vc tera q marcar todos os pacotes dos ranges dos ips no mangle e definr as velocidades no queue tree.... funcionar funciona, mas imagina vc colocando clientes em redes separadas ? ai tu tera q marcar pacote por pacte de cada IP no mangle e depois definir eles no queue tree, se fosse somente um range inteiro como por exemplo 192.168.0.0/16 ai sim funciona legal pq vc tera somente uma regra no mangle.
    Se n entendeu posta ai a duvida. :good:

  8. #8
    caquino
    Visitante

    Padrão Proxy no Mikrotik!!!

    Bom eu gostaria de saber então como ele iria fazer marca diferente nos pacotes de sites já cacheados e dos não cacheados.



  9. #9

    Padrão Proxy no Mikrotik!!!

    Citação Postado originalmente por caquino
    Bom eu gostaria de saber então como ele iria fazer marca diferente nos pacotes de sites já cacheados e dos não cacheados.
    No queue tree ele so limita o controle de out do server n o de entrada, rapaz vou dar uma olhada aonde eu li isso e posto aqui ok, la esta explicando certinho como que funcionar, n me lembro se era no forum ou no howto

  10. #10
    caquino
    Visitante

    Padrão Proxy no Mikrotik!!!

    Tiago eu acho que você não entendeu direito a pergunta dele.

    Ele quer que sites que ainda não estejam cacheados no proxy venham na limitação de banda do cliente. Os que já estão cacheados ele quer que venha sem limite de banda, não existe como fazer a distinção do que esta ou não cacheado pelo proxy na marcação dos pacotes. Se você deixa o cache inteiro, ou seja todos pacotes que entram e saem do proxy, sem limite de banda o cara não vai ter NUNCA limitação na velocidade de navegação.



  11. #11

    Padrão Proxy no Mikrotik!!!

    Em respota ao post:

    Aumentando a velocidade de acesso ao cache do squid

    https://under-linux.org/modules.php?...37903&start=60

    nosso amigo Nataniel respondeu:

    "4) Se o CBQ está instalado na mesma máquina que o SQUID, sim ele irá bloquear o tráfego de saida do squid. Se o CBQ está instalado no provedor e o SQUID está em um servidor bridge no meio do caminho então o Squid não terá bloqueio."


    Portela

  12. #12

    Padrão Proxy no Mikrotik!!!

    Citação Postado originalmente por caquino
    Tiago eu acho que você não entendeu direito a pergunta dele.

    Ele quer que sites que ainda não estejam cacheados no proxy venham na limitação de banda do cliente. Os que já estão cacheados ele quer que venha sem limite de banda, não existe como fazer a distinção do que esta ou não cacheado pelo proxy na marcação dos pacotes. Se você deixa o cache inteiro, ou seja todos pacotes que entram e saem do proxy, sem limite de banda o cara não vai ter NUNCA limitação na velocidade de navegação.
    Bom dia caquino, achei a materia que disse a vc que ja tinha lido. de uma olhada nela e me diz as suas conclusoes.

    Código :
    Example of using global-in and global-out queues
    Let us consider a situation when you are using a Web-Proxy on your MikroTik router and you want to use bandwidth limitation to/from Internet and allow the maximum speed available if the clients use proxy-data (or do uploads to the router). In this situation you can use global-in and global-out virtual interfaces. Remember that data from Web-Proxy is sent to clients from Local Process. See this diagram for a better understanding of packet flow through the router.
     
    Assume that you already have configured your web-proxy:
     
    [[email protected]] ip web-proxy> print
                    enabled: yes
                src-address: 10.5.8.104
                       port: 8080
                   hostname: proxy
          transparent-proxy: no
               parent-proxy: 0.0.0.0:0
        cache-administrator: webmaster
            max-object-size: 4096 kB
                cache-drive: system
             max-cache-size: none
                     status: running
         reserved-for-cache: 100 MB
    Add a mangle rule for marking all packets coming from interface Public:
     
    /ip firewall mangle add in-interface=Public mark-flow=all-down action=accept
    Add a mangle rule for marking all packets coming from interface Local:
     
    /ip firewall mangle add in-interface=Local mark-flow=all-up action=accept
    Add a queue tree rule that will limit all traffic coming from interface Public (flow=all-down) to 512kbps:
     
    /queue tree add parent=global-in max-limit=524288 flow=all-down
    Add a queue tree rule that will limit all traffic coming from interface Local (flow=all-up) to 256kbps:
     
    /queue tree add parent=global-out max-limit=262144 flow=all-up
    Now the client downloads from the router (proxy) will be unlimited, but downloads from the Internet will be limited to 512K! The same goes for uploads - no limitation if you are uploading to router, but limit all uploads to Internet to 256K.

    Qualquer reposta sera muito bem vinda.
    Grato.



  13. #13
    caquino
    Visitante

    Padrão Proxy no Mikrotik!!!

    Você continuou sem entender o problema, com esta solução ele limita pra rede externa e deixa a interna sem limite. com o download pra fora a 256k TODOS os clientes dele iriam ficar com 256k de download http, a não ser que esteja no cache.

    Não vai ser NADA confortal ter 256k para TODO mundo navegando principalmente se uns 4 ou 5 tiverem acessando coisas fora do cache (o que não é incomum)


    ou seja se ja tiver no proxy vai vir rapido, se não vao usar uma banda "compartilhada"
    E tem outro porem se ele não limitar a banda externa compartilhada assim, todos vao poder usar o link inteiro fazendo download http pois tudo parte como requisição do ip do proxy.

  14. #14

    Padrão Proxy no Mikrotik!!!

    Ae galera to vendo que o topico andou mtoo ...
    eh eu tenho uma duvida que eu axo que se encaicha ai ...
    eh essa:

    eu tenho uma rede normal com os clientes por pppoe...
    dai eu quero por um servidor ftp na "rede" ....
    mais nao quero que a banda dele seja limitada para acessar o tal ftp....
    alguma dica ai ?

    =]



  15. #15

    Padrão Proxy no Mikrotik!!!

    Citação Postado originalmente por Drks
    Ae galera to vendo que o topico andou mtoo ...
    eh eu tenho uma duvida que eu axo que se encaicha ai ...
    eh essa:

    eu tenho uma rede normal com os clientes por pppoe...
    dai eu quero por um servidor ftp na "rede" ....
    mais nao quero que a banda dele seja limitada para acessar o tal ftp....
    alguma dica ai ?

    =]
    mas vc quer q seus clientes n tenha banda limitada ao acessar o ftp ou o server mt vai estar mandano net para esse ftp e tu quer e ele n limite a banda da net do ftp?

  16. #16

    Padrão Proxy no Mikrotik!!!

    Alguém tem um procedimento básico para colocar o proxy para funcionar ?

    Valeu,

    Samuel.



  17. #17

    Padrão Re: Proxy no Mikrotik!!!

    Foi mal, o meu proxy não estava funcionando. Por isso não consegui ativá-lo. Tive que remover o pacote e instalar novamente para ele constar na lista de opções dentro do menu IP.

    Agora alguém tem regras básicas de segurança prontas para facilitar a instalação do firewall ?

    Valeu.

  18. #18

    Padrão Re: Proxy no Mikrotik!!!

    Vlw Matiassss
    eh assim ...
    eu queria fazer com que o cliente possa acessar o ftp sem controle de banda .... mais ja a web com o controle ...
    tem como ?

    vlw galera



  19. #19

    Padrão Re: Proxy no Mikrotik!!!

    esse ftp q vc diz 'e dentro do mt ou 'e uma maquina que fica atraz do mt ?

  20. #20

    Padrão Re: Controle

    Citação Postado originalmente por tiagomatias
    Citação Postado originalmente por douglassantos
    Citação Postado originalmente por magnusrk8
    Tenho esta versao crackeada, mas nao testada, amanha vou começar a testar, podemos trocar uma idea neste topico. :?

    URL RETIRADA
    tipow qdo faço o controle de banda no mikrotik ele tb controla a banda dos arquivos que ja estao no cache como deixar o cache sem limite de banda??
    Ola amigo douglassantos, tem como fazer sim o controle de banda fora do cache sim, mas te um detalhe, usa muito processamento da maquina pq vc tera q marcar todos os pacotes dos ranges dos ips no mangle e definr as velocidades no queue tree.... funcionar funciona, mas imagina vc colocando clientes em redes separadas ? ai tu tera q marcar pacote por pacte de cada IP no mangle e depois definir eles no queue tree, se fosse somente um range inteiro como por exemplo 192.168.0.0/16 ai sim funciona legal pq vc tera somente uma regra no mangle.
    Se n entendeu posta ai a duvida. :good:
    Tipow assim ai vai uma outra duvida se eu colocar por exlemplo um amd k6 com 128 para controlar a banda e um p4 2.4 bla bla bla para controlar o proxy, essa maquina que vai controlar banda vai redirecionar o trafego de http para o server melhorzinho..
    serah q vai ficar muito lenta essa maquina mais ruinzinha soh controlando banda??? ah isso eh para uns 100 users...