+ Responder ao Tópico



  1. #1
    Lion_Black
    Visitante

    Padrão Meus servidores nao usam a SWAP (É Normal?)

    Todos os servidores linux que eu instalo .. nenhum deles usa a memoria swap ... tanto faz se for conectiva, debian ou slack.

    Olhem a saida do comando free -m

    [email protected]:~# free -m
    total used free shared buffers cached
    Mem: 218 195 23 0 21 31
    -/+ buffers/cache: 142 75
    Swap: 956 2 954
    [email protected]:~#

    Ta falando que so tem 23 mb livre de RAN e so ta usando 2 de SWAP .
    Outro dia so tinha 3 MB de RAN livre e nao tava usando nenhum pra swap .

    Esse server tem 256 mb de ran .. sendo que 128 sao para uso no squid.

    No /etc/fstab a swap esta assim:

    /dev/hda2 swap swap defaults 0 0


    É normal isso?

  2. #2

    Padrão Re: Meus servidores nao usam a SWAP (É Normal?)


    Taí cara, nunca fiz esse teste. E não entendi como isso funciona. Pelo jeito a tua rede parece estar funcionando normal. Que digam os usuários Underlinux que conhecem sobre isso ......... Mas prá mim é um fato novo.
    Inté mais amigo .......... :|



  3. #3
    Lion_Black
    Visitante

    Padrão Re: Meus servidores nao usam a SWAP (É Normal?)

    No seu servidor ....... como funciona a swap?

    ela anda normal .... a memoria pode tar acabando que a swap ja ta usando .. ou nao?

    Eu so quero saber como funciona esse negocio de swap .. nunca vejo ela usando ... nem na hora que vou compilar o kernel ele nao usa swap ...

    fiquei so com 3 mb de ran e nao usou ....

  4. #4

    Padrão Re: Meus servidores nao usam a SWAP (É Normal?)

    swap eh uma "extensão" da memoria da maquina, qdo a ram se esgosta ele passa a utilizar o swap como se fosse mais memoria, porém como o acesso eh feito ao disco eh mais lento.
    Eh normal em desktops nao haver a necessidade de utilizar o swap



  5. #5
    Lion_Black
    Visitante

    Padrão Re: Meus servidores nao usam a SWAP (É Normal?)

    Mas o meu nao é desktop ... e minha ram praticamente se esgotou ... ficando com apenas 3 mb de ran livre ...

    e a swap em nada foi usada