+ Responder ao Tópico



  1. #1

    Padrão problemas em conectar no linux com o cisco 2500

    Saldações pessoal,
    to com um problema aqui, que e o seguinte o cisco conecta e navega blz no windows mas nao conecta no linux
    o lnik e da telemar e a conf co routewr e

    seriaal0 200.195.xxx.xxx masc 255.255.255.252

    e a ethernet0 200.149.xx.xx masc 255.255.255.248

    route 0.0.0.0 0.0.0.0 200.195.0.xxx

    podem me ajudar???

  2. #2

    Padrão Re: problemas em conectar no linux com o cisco 2500

    Seguinte voce tem a faixa 200.149.xxx.xxx pra voce certo?? Nao pos esse ip como ip invalido. Fora isso posta a saida do running config e o estado das interfaces, alem disso no linux de um ping no roteador e um traceroute under-linux.org poste os resultados aqui tb.

    falows



  3. #3

    Padrão Re: problemas em conectar no linux com o cisco 2500

    ai o running-config


    Router#show running-config
    Building config

    Current configuration:
    !
    version 11.1
    no service pad
    service udp-small-servers
    service tcp-small-servers
    !
    hostname Router
    !
    !
    !
    interface Ethernet0
    ip address 200.149.10.xxx
    255.255.255.248
    !
    interface Serial0
    ip address 200.195.0.xxx
    255.255.255.252
    encapsulation ppp
    bandwidth 256
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface Serial2
    no ip address
    shutdown
    !
    interface Serial3
    no ip address
    shutdown
    !
    no ip classless
    ip route 0.0.0.0 0.0.0.0 200.195.0.xxx
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    end

    agora as interfaces


    Router#show interfaces
    Ethernet0 is up, line protocol is up
    Hardware is Lance, address is 0000.0c75.d1ba (bia 0000.0c75.d1ba)
    Internet address is 200.149.10.xxx/29
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
    Encapsulation ARPA, loopback not set, keepalive set (10 sec)
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:44, output 00:00:00, output hang never
    Last clearing of "show interface" counters never
    Queueing strategy: fifo
    Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 1 packets/sec
    18742 packets input, 4051541 bytes, 0 no buffer
    Received 727 broadcasts, 0 runts, 0 giants
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    0 input packets with dribble condition detected
    36284 packets output, 16692903 bytes, 0 underruns
    765 output errors, 1 collisions, 3 interface resets
    0 babbles, 0 late collision, 5 deferred
    765 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    Serial0 is up, line protocol is up
    Hardware is HD64570
    Internet address is 200.195.0.xxx/30
    MTU 1500 bytes, BW 256 Kbit, DLY 20000 usec, rely 255/255, load 1/255
    Encapsulation PPP, loopback not set, keepalive set (10 sec)
    LCP Open
    Listen: cdp
    Open: ipcp
    Last input 00:00:00, output 00:00:00, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0 (size/max/drops); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/64/0 (size/threshold/drops)
    Conversations 0/12 (active/max active)
    Reserved Conversations 0/0 (allocated/max allocated)
    5 minute input rate 0 bits/sec, 1 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    430405 packets input, 37133372 bytes, 0 no buffer
    Received 276 broadcasts, 0 runts, 0 giants
    307 input errors, 305 CRC, 0 frame, 0 overrun, 0 ignored, 13 abort
    412992 packets output, 24543653 bytes, 0 underruns
    0 output errors, 0 collisions, 28 interface resets
    0 output buffer failures, 0 output buffers swapped out
    1 carrier transitions
    DCD=up DSR=up DTR=up RTS=up CTS=up


    agora vou pegar o trace



  4. #4

    Padrão Re: problemas em conectar no linux com o cisco 2500

    So uma coisa esse ip 200 da ethernet como ele chega na ethernet já que voce nao pos nenhuma entrada pra ele no roteador.

    falows



  5. #5

    Padrão Re: problemas em conectar no linux com o cisco 2500

    ai o ping e o trace

    #ping 200.149.10.xxx
    PING 200.149.10.XXX (200.149.10.XXX): 56 Data bytes
    64 dytes from 200.149.10.xxx: icmp_seq=0 ttl=255 time=992.4 ms
    64 dytes from 200.149.10.xxx: icmp_seq=0 ttl=255 time=1.8 ms
    64 dytes from 200.149.10.xxx: icmp_seq=0 ttl=255 time=1.8 ms
    64 dytes from 200.149.10.xxx: icmp_seq=0 ttl=255 time=1.8 ms
    64 dytes from 200.149.10.xxx: icmp_seq=0 ttl=255 time=1.9 ms

    [2]+ Stopped

    agora o trace

    #traceroute under-linux.org
    traceroute: unknown host under-linux.org

    ve se pode me ajudar


  6. #6

    Padrão Re: problemas em conectar no linux com o cisco 2500

    e ai rui deu uma olhada ? oque pode esta acomtecendo?



  7. #7

    Padrão Re: problemas em conectar no linux com o cisco 2500

    Cara ja olhou se o dns no seu linux ta ok??? olha o /etc/resolv.conf e ve se os servidores de dns la tao ok e pingando.

    falows

    PS: desculpa a demora mas nao tinah recebido mensagem de resposta do topico

  8. #8

    Padrão Re: problemas em conectar no linux com o cisco 2500

    tudo bem,

    os dns estão ok no etc/res...
    desconfio que seja no roteador o problema



  9. #9

    Padrão Re: problemas em conectar no linux com o cisco 2500

    Cara acho dificil ser o cisco, tenta dar um traceroute ou um ping nesse ip 200.255.5.4 se funcionar de certeza o problema eh de dns


    falows

  10. #10

    Padrão Re: problemas em conectar no linux com o cisco 2500

    habilite o "ip classless"

    e o ip routing esta ativo?

    da um "show protocols" para mim aí.

    considerando somente problemas no seu router nesse post, quanto ao problema ser no seu cliente tente fazer o traceroute em um ip qualquer na internet e mostre o resultado que ai da para dizer rapido onde é.



  11. #11

    Padrão Re: problemas em conectar no linux com o cisco 2500

    caro amigo o ip rout.. esta ativo
    como habilito este "ip classless" ???

    e no meu route



  12. #12

    Padrão Re: problemas em conectar no linux com o cisco 2500

    da os comandos q eu pedi para voce, mostra o seu show run tbm



  13. #13

    Padrão Re: problemas em conectar no linux com o cisco 2500

    Cara posta o traceroute pro ip que eu pedi pra voce.

    falows

  14. #14

    Padrão Re: problemas em conectar no linux com o cisco 2500

    bom, funciona assim pro ip classless... ativa assim oh:


    > enable
    # conf term
    (conf)# ip classless
    ^Z


    da um show ip route também para gente dar uma olhada.



  15. #15

    Padrão Re: problemas em conectar no linux com o cisco 2500

    e ae cara deu certo??

    falows

  16. #16

    Padrão Re: problemas em conectar no linux com o cisco 2500

    qe nada, ruy, o problema continua, funciona no rwindows mas nao funciona no linux



  17. #17

    Padrão Re: problemas em conectar no linux com o cisco 2500

    Que nada, ruy, continua com o mesmo problema funciona no rwindows mas nao funciona no linux

  18. #18
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.932
    Posts de Blog
    1

    Padrão Re: problemas em conectar no linux com o cisco 2500

    como que é no windows funciona

    então vamus la


    do linux pingue o seu roteador
    do linux ping 200.160.2.3
    do linux ping registro.br
    e deixe seu /etc/resolv.conf em 127.0.0.1 para que o linux resolva os nomes




  19. #19

    Padrão Re: problemas em conectar no linux com o cisco 2500

    Citação Postado originalmente por fasmaia
    Que nada, ruy, continua com o mesmo problema funciona no rwindows mas nao funciona no linux

    se funciona no Rwindows é lógico que tem que funcionar no linux ....

    faça um teste por eliminação ...

    no console do linux você pinga a lan do roteaor ...? a wan do roteador ...? a wan da operadora ...? um ip externo ...? se sim ....:

    você pinga um nome ...?

    se não ...reveja seu dns ...

    veja até em que nó vocÊ pinga ...pois só dai é que podemos ver qual a bromca ....

    só pra desencargo de conciência ...

    digita no linux ...

    rout -n
    e verifica se a rota default tá setada para o roteador ....


    valew