Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Pessoal quem poder me ajudar eu agradeço.
    Tenho o slack 10.1 com ssh, eu consigo me logar atravez do putty pela minha rede interna 10.89.1.x em eth0 mas eu quero me logar ao servidor aqui da minha casa, eu xamo o ip valido dasse mesmo servidor que é 201.xxx.xxx.xxx eu consigo pingar mas ele não abre a tela para colocar o login, aparece o seguinte connection refused.
    vou colocar o script do sshd_config para alguem me ajudar:
    #Port 22
    #Protocol 2,1
    #ListenAddress 0.0.0.0
    #ListenAddress ::

    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key

    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 768

    # Logging
    #obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    #LogLevel INFO

    # Authentication:

    #LoginGraceTime 2m
    #PermitRootLogin yes
    #StrictModes yes
    #MaxAuthTries 6

    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile .ssh/authorized_keys

    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes

    # To disable tunneled clear text passwords, change to no here!
    #PasswordAuthentication yes
    #PermitEmptyPasswords no

    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes

    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    #KerberosGetAFSToken no

    # GSSAPI options
    #GSSAPIAuthentication no
    #GSSAPICleanupCredentials yes

    # Set this to 'yes' to enable PAM authentication, account processing,
    # and session processing. If this is enabled, PAM authentication will
    # be allowed through the ChallengeResponseAuthentication mechanism.
    # Depending on your PAM configuration, this may bypass the setting of
    # PasswordAuthentication, PermitEmptyPasswords, and
    # "PermitRootLogin without-password". If you just want the PAM account and
    # session checks to run without PAM authentication, then enable this but set
    # ChallengeResponseAuthentication=no
    #UsePAM no

    #AllowTcpForwarding yes
    #GatewayPorts no
    #X11Forwarding no
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #TCPKeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression yes
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10
    # no default banner path
    #Banner /some/path

    # override default of no subsystems
    Subsystem sftp /usr/libexec/sftp-server


    se alguem poder me ajudar eu agradeço

  2. Que tipo de conexão voce usa?? se for adsl com modem router redirecionou a porta 22 pro seu servidor?? liberou no firewall a conexao??

    falows



  3. Bem, se vc esta usando algum tipo de conexão adsl com algum modem vc tem que criar uma regra nat apontando para a maquina que vai receber o acesso via ssh, abrindo a porta do mesmo que é 22 entende

    espero que isso ajude, caso não por favor desconcidere o post

  4. Ei pessoal na maquina servidor estou usando uma conexão radio de um provedor local que me da um ip real 201.xxx.xxx.xxx

    Situação quando eu estou na rede local 10.89.1.xxx e eu xamo pelo putty o ip real 201.xxx.xxx.xxx ele abre bunitinho mas quando eu estou em qualquer outro local ele não abre

    sera que pode ser alguma regra no provedor?

    ou é burrice minha?



  5. #5
    claudiovaqueiro
    Brother depois de verificar que tiver funcionando legal,da uma olhada na configuração com mais calma e faz algumas alterações de segurança,primeiramente tia da porta 22 e coloca numa porta la em cima queso vc saiba,por tantao que libere essa porta no firewall,não so isso ,mas outras alteraçoes que deixa teu ssh 99% mais seguro.
    valeuss






Tópicos Similares

  1. ssh não fechar por timeout.
    Por no fórum Servidores de Rede
    Respostas: 6
    Último Post: 11-08-2005, 22:13
  2. ssh nao funciona
    Por W@rl0ck no fórum Servidores de Rede
    Respostas: 6
    Último Post: 21-01-2005, 20:33
  3. ssh não conecta
    Por chicus no fórum Servidores de Rede
    Respostas: 1
    Último Post: 13-11-2004, 18:48
  4. Bloqueio SSH nao funciona! me ajudem!
    Por Felipe_ no fórum Servidores de Rede
    Respostas: 8
    Último Post: 29-08-2004, 10:39
  5. SSH Não levanta!
    Por PcGuy no fórum Servidores de Rede
    Respostas: 0
    Último Post: 02-09-2003, 16:12

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L