+ Responder ao Tópico



  1. #1
    sanguera
    Visitante

    Padrão erro no samba estranho

    galera tenho duas interfaces aqui,, eth0 10.1.1.100/24 e eth1 172.16.42.100/24 seguinte configurei o samba bem do modo simples apenas para compartilhar umas pastinhas tal,, eu rodo ele ele inicia normal mas acusa o seguinte erro no log
    Packet send failed to 172.16.42.255(138) ERRNO=Operation not permitted

    entao,, dai ele ate funcionou mas ta meio estranho, se alguem puder ajudar ai agradeço abraçaoooo.

  2. #2
    josneileal
    Visitante

    Padrão Re: erro no samba estranho

    Camarada...

    Antes de dar um "start" no smb, execute o comando "testparm".

    Ele verifica se esta tudo certo com a configuração do smb.conf.

    Falow......



  3. #3
    kr4mus
    Visitante

    Padrão Re: erro no samba estranho

    Bom dia!!

    Esse #testparm já me ajudou , tbm ate aconselho a rodá-lo por primeiro.
    Se não está tão familiarizado com o .conf do smd, uma alternativa rápida e fácil seria instalar o swat. É uma interface de administração do samba pelo browser.
    Espero ter ajudado!

    Marcus Burghardt
    www.sitedomarkito.com (em breve material linux)

  4. #4
    Cássio Jose
    Visitante

    Padrão Re: erro no samba estranho

    é isso ai mesmo kara tenta rodar o "testparm" antes, e se possivel posta também um exemplo do seu smb.conf.



  5. #5
    sanguera
    Visitante

    Padrão Re: erro no samba estranho

    pois é no testparm, da tudo ok ja revirei e desrevirei isso aqui,, mas to correndo atraz assim que tiver a solução posto aqui,, valeu ai pela ajuda.

  6. #6
    andfgon
    Visitante

    Padrão Re: erro no samba estranho

    dae .. seguinte, verifique se tem alguma regra
    de firewall bloqueando a saida de pacotes do
    samba com destino as portas 137, 138 e 139..

    pelo erro pode ser que esteja liberado a saida e/ou
    entrada do trafego para as portas 137:139 com
    protocolo tcp pelo fato de chegar a funcionar,
    e pode estar sendo bloqueado apenas o trafego
    udp para essas mesmas portas.

    tente usar as seguinte regra
    iptables -I INPUT -p udp --dport 137:139 -j ACCEPT
    iptables -I INPUT -p tcp -m multiport --dport 137,138,139,445 -j ACCEPT
    iptables -I OUTPUT -p udp --dport 137:139 -j ACCEPT
    iptables -I OUTPUT -p tcp -m multiport --dport 137,138,139,445 -j ACCEPT