+ Responder ao Tópico



  1. Ola pessoal
    Estou tentando configurar o squid no CL 10 aqui mas tá dificil!!!
    quando tento navegar aparece a seguinte msg!!!

    ERROR
    The requested URL could not be retrieved

    --------------------------------------------------------------------------------

    While trying to retrieve the URL: /

    The following error was encountered:

    Invalid URL
    Some aspect of the requested URL is incorrect. Possible problems:

    Missing or incorrect access protocol (should be `http://'' or similar)
    Missing hostname
    Illegal double-escape in the URL-Path
    Illegal character in hostname; underscores are not allowed
    Your cache administrator is thelast@xxxxx.com.br.


    aparece isso no /var/log/access.log

    [root@servidor squid]# tail -f /var/log/squid/access.log
    1139852005.037 0 192.168.5.0 TCP_DENIED/400 1465 GET /bandalarga/ - NONE/- text/html
    1139852683.881 9 192.168.5.0 TCP_DENIED/400 1443 GET / - NONE/- text/html
    1139852685.512 0 192.168.5.0 TCP_DENIED/400 1443 GET / - NONE/- text/html
    1139927317.066 0 192.168.5.91 TCP_DENIED/400 1439 GET / - NONE/- text/html
    1139927334.503 0 192.168.5.91 TCP_DENIED/400 1439 GET / - NONE/- text/html
    1139927342.863 0 192.168.5.91 TCP_DENIED/400 1439 GET / - NONE/- text/html
    1139927375.978 0 192.168.5.91 TCP_DENIED/400 1439 GET / - NONE/- text/html
    1139927377.672 0 192.168.5.91 TCP_DENIED/400 1439 GET / - NONE/- text/html
    1139927379.665 0 192.168.5.91 TCP_DENIED/400 1439 GET / - NONE/- text/html
    1139928489.430 0 192.168.5.91 TCP_DENIED/400 1463 GET / - NONE/- text/html


    aqui o squid.conf



    http_port 192.168.5.1:3128
    cache_mem 96 MB
    maximum_object_size 4096 KB
    cache_dir ufs /var/cache/squid 1024 16 256
    cache_access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.log
    cache_store_log none
    emulate_httpd_log off
    #client_netmask 255.255.255.0
    #Default:
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320
    #Defaults:
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 21 443 563 70 210 1025-65535
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT
    acl minharede src 192.168.5.0/255.255.255.0
    #Default configuration:
    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow minharede
    http_access deny all
    cache_mgr thelastr@xxxx.com.br
    cache_effective_user proxy
    cache_effective_group proxy
    visible_hostname servidor.xxxx.com.br


    o q está bloqueando a navegacao???


  2. ninguem sabe p q está acontecendo isso???

    Dá uma força ai pessoal



  3. #3
    lobo
    >>>>>>>>>>>http_access deny all<<<<<<<<<<<

    cara eu acho que essa regra aqui esta bloqueando tudo... vc deveria por ela como allow pra ver o que dar,, ou entao colocar ela como allow minharede. testa ai pra ver

  4. Problema resolvido!!!
    Apaguei tudo e configurei novamente, agora está funcionando

    mas valeu pela força!!!






Tópicos Similares

  1. Squid nao deixa preencher formularios
    Por renatoneiva no fórum Servidores de Rede
    Respostas: 3
    Último Post: 28-09-2011, 08:51
  2. Squid nao deixa!!
    Por francistomba no fórum Sistemas Operacionais
    Respostas: 3
    Último Post: 03-08-2009, 08:54
  3. Squid não deixa acessar java
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 16-08-2005, 10:44
  4. Windows não quer navegar pelo proxy Squid
    Por scarmagnani no fórum Servidores de Rede
    Respostas: 16
    Último Post: 05-05-2005, 19:23
  5. Respostas: 3
    Último Post: 25-11-2002, 18:22

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L