Galera essa aqui eh tensa e precisa de bastante atenção....

Galera eu uso o Freebsd e tenho instalado o postfix + Sasl + pam_mysql, tudo instalado via ports..
Agora entra oq eu acho muito estranho...

Quando eu configuro a conta no outlook express eu ñ consigo enviar e-mail nenhum...
PORÉM, quando eu marco a opção MEU SERVIDOR REQUER AUTENTICAÇÃO eu envio e-mail normalmente....
Oq ta estranho eh que: Se eu colocar qualquer coisa como login, o sasl procura dentro do MYSQL, conformo o log abaixo, faz a consulta e libera o acesso... estou encucado com isso...

PS> REPAREM QUE NO LOG O e-mail oi@ederson.ebr.com.br ñ exite na tabala do mysql no mailbox....


060216 20:09:52 50 Connect postfix@localhost on postfix
50 Init DB postfix
50 Query SELECT password FROM mailbox WHERE username='oi@ederson.ebr.com.br'
50 Quit
51 Connect postfix@localhost on postfix
51 Query SELECT goto FROM alias WHERE address='hpbr.adm.br'
52 Connect postfix@localhost on postfix
52 Query SELECT description FROM domain WHERE domain='hpbr.adm.br'
51 Query SELECT goto FROM alias WHERE address='ebrnet.com.br'
52 Query SELECT description FROM domain WHERE domain='ebrnet.com.br'
51 Query SELECT goto FROM alias WHERE address='juastori@ebrnet.com.br'
51 Query SELECT goto FROM alias WHERE address='@ebrnet.com.br'
51 Query SELECT goto FROM alias WHERE address='juastori@ebrnet.com.br'
51 Query SELECT goto FROM alias WHERE address='@ebrnet.com.br'
51 Query SELECT goto FROM alias WHERE address='ebrnet.com.br'
52 Query SELECT description FROM domain WHERE domain='ebrnet.com.br'