+ Responder ao Tópico



  1. #1

    Padrão erro ao montar cdrom

    e aee gurizada, blz....eu to tentando utilizar o cdrom, mas esta dando o seguinte erro:

    mount: wrong fs type, bad option, bad superblock on /dev/hdc,
    missing codepage or other error
    (could this be the IDE device where you in fact use
    ide-scsi so that sr0 or sda or so is needed?)
    In some cases useful info is found in syslog - try


    esse erro ja da logo q carrego o meu linux....o meu drive d cd eh o hdc...ja configurei o lilo com a linha append = "hdd=ide-scsi", e ja configurei o fstab tbm....sempre funcionou, mas dessa vez esta dando esse erro.....estou usando slackware 10.2 com kernel 2.4.......o meu drive d cd eh um combo no caso......o q eu devo fazer ?.....[]'s...dedao

  2. #2

    Padrão Re: erro ao montar cdrom

    Opa!


    - Se vc tá emulando SCSCI para o cdrom, então ele não fica mais em /dev/hdc, e sim em /dev/sr0 (ou /dev/scd0)
    - Já que vc está emulando SCSI pra um dispositivo IDE, esteja certo de que o módulo ide-scsi está carregado ("lsmod" pra listar, e "modprobe ide-scsi" pra carregar)

    Depois tente:

    Código :
    # mount -t iso9660 /dev/sr0 /mnt/cdrom
    ou
    Código :
    # mount -t iso9660 /dev/scd0 /mnt/cdrom

    Outra coisa, vc citou 'append = "hdd=ide-scsi"', não sei se foi erro de digitação, mas deve ser "hdc" no lugar de "hdd" pelo que vc citou antes.



    flw



  3. #3
    dedo
    Visitante

    Padrão Re: erro ao montar cdrom

    bah lidzky, vlw , o problema eu acho eh q tava faltando a linha /sbin/modprobe ide-scsi no rc.modules, e tbm eu tive q trocar o /dev/cdrom do fstab pra /dev/sr0, como vc falou.......heheheh....brigadao ae pela ajuda ...abraçao...fui



    /dev/hda1 swap swap defaults 0 0
    /dev/hda2 / reiserfs defaults 1 1
    /dev/hda5 /home reiserfs defaults 1 2
    /dev/sr0 /mnt/cdrom iso9660 auto,users,ro 1 0
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0



  4. #4

    Padrão Re: erro ao montar cdrom

    Não há necessidade de ativar emulação scsi.
    Muda no seu fstab a opção "auto" para "noauto" na linha referente ao seu drive de cd.

    [email protected]:~$ cat /etc/fstab
    /dev/hda3 swap swap defaults 0 0
    /dev/hda2 / reiserfs defaults 1 1
    /dev/hdb1 /mnt/hdb1 vfat auto,gid=users,umask=002 0 0
    /dev/cdrom /mnt/cdrom auto noauto,users,ro 0 0
    /dev/hdd /mnt/lg auto noauto,users,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0
    [email protected]:~$



  5. #5

    Padrão Re: erro ao montar cdrom

    Acho q no kernel 2.4 o gravador funciona melhor com emulação. Já no 2.6 eu uso sem emulação mesmo pq o suporte a gravadores IDE tá melhor.

    Citação Postado originalmente por Skorpyon
    Não há necessidade de ativar emulação scsi.
    Muda no seu fstab a opção "auto" para "noauto" na linha referente ao seu drive de cd.

    [email protected]:~$ cat /etc/fstab
    /dev/hda3 swap swap defaults 0 0
    /dev/hda2 / reiserfs defaults 1 1
    /dev/hdb1 /mnt/hdb1 vfat auto,gid=users,umask=002 0 0
    /dev/cdrom /mnt/cdrom auto noauto,users,ro 0 0
    /dev/hdd /mnt/lg auto noauto,users,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0
    [email protected]:~$

  6. #6
    ttjedi
    Visitante

    Padrão Re: erro ao montar cdrom

    tente apenas

    #mount /cdrom

    ve ai se funfa;;;; valew!!!



  7. #7

    Padrão Re: erro ao montar cdrom

    Citação Postado originalmente por ttjedi
    tente apenas

    #mount /cdrom

    ve ai se funfa;;;; valew!!!
    Para isso funcionar o fstab deve estar configurado, caso contrario ele retornara um erro.

  8. #8
    xwm
    Visitante

    Padrão Re: erro ao montar cdrom

    Olá Skorpyon eu digitei esse comando no terminal (cat /etc/fstab) que retornou

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/sda2 / reiserfs notail 0 1
    /dev/sda1 none swap sw 0 0
    /dev/hdb /media/cdrom0 udf,iso9660 user,noauto 0 0


    Estou tentando fazer com que funcione o xcdroast...ele pede para ativar a emulação SCSI no kernel.. :?

    Comecei a usar o Ubuntu 6.06 faz pouco tempo.... não entendo nada de linux :? :?....sou praticamente "loira" nesse assunto (sem ofensa) .... se você puder me ajudar.....

    Gracias.