+ Responder ao Tópico



  1. Pessoal, estou utilizando agora o Debian.

    Porem ao fazer.

    apt-get install PACOTE

    qualquer pacote que seja da esse erro abaixo.


    E: This installation run will require temporarily removing the essential package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad, but if you really want to do it, activate the APT::Force-LoopBreak option.
    E: Internal Error, Could not early remove e2fsprogs



    Como corrigir isso ?

    Toda vez que eu instalo ele da o mesmo problema.


  2. Respondendo a alguem que tenha o problema.
    At[e porque nao estao ajudando tambem.
    Fazendo buscas na net sobre o problema citado.
    o link onde encontrei uma documentacao explicando o mesmo.
    OBS: Depois que eu conseguir arrumar isso. Postarei os procedimentos completos.



    http://www.debian.org/releases/woody...rading.pt.html




    3.5.1 Possíveis Problemas Durante ou Após a Atualização

    Algumas vezes é necessário habilitar a opção APT::Force-LoopBreak no APT para poder remover temporariamente um pacote essencial devido a um loop de Conflitos/Pré-Dependências. O apt-get o alertará sobre isso e abortará a atualização. Você pode resolver isso especificando a opção -o APT::Force-LoopBreak=1 na linha de comando do apt-get.

    É possível que a estrutura de dependências de um sistema possa estar tão corrompida que a ponto de requerer intervenção manual. Geralmente isso significa usar o dselect ou


    dpkg --remove nome_do_pacote

    para eliminar alguns dos pacotes problemáticos, ou


    apt-get --fix-broken --show-upgraded install
    dpkg --configure --pending

    Em casos extremos você pode ter que forçar a reinstalação com um comando como


    dpkg --install /caminho/para/nome_do_pacote.deb

    Depois de consertar as coisas, você deve ser capaz de terminar a atualização repetindo os comandos de dist-upgrade previamente descritos.

    Durante a atualização, serão feitas perguntas para configurar ou reconfigurar vários pacotes. Quando perguntado se algum arquivo nos diretórios /etc/init.d ou /etc/terminfo, ou o arquivo /etc/manpath.config devem ser substituídos pela versão do desenvolvedor do pacote, geralmente é necessário responder `yes' (sim) para garantir a consistência do sistema. Você sempre poderá reverter para as versões antigas, já que serão guardadas com uma extensão .dpkg-old.

    Se você não souber bem o que fazer, escreva o nome do pacote ou arquivo, e resolva isso depois. Você pode procurar no arquivo typescript para rever a informação que estava na tela durante a atualização.



  3. BOM, com esse procedimento da certo fazer

    Supondo que voce queira instalar o amsn, ou sei la qual pacote a sua escolha.

    faca

    # apt-get update
    # apt-get install amsn -o APT::Force-LoopBreak=1

    Com isso ele ira instalar sem dar o problema do famoso

    e2fsprogs

    Fui !!!!!






Tópicos Similares

  1. Respostas: 5
    Último Post: 08-09-2006, 10:09
  2. apt-get nao installa
    Por cvr no fórum Sistemas Operacionais
    Respostas: 1
    Último Post: 10-06-2006, 08:43
  3. apt-get não funciona
    Por Osvaldo.affonso no fórum Sistemas Operacionais
    Respostas: 5
    Último Post: 22-04-2006, 10:36
  4. Apt-get nao desinstala pacote instalado
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 2
    Último Post: 30-08-2005, 10:49
  5. apt-get não passa pelo Squid
    Por rato16br no fórum Servidores de Rede
    Respostas: 2
    Último Post: 20-08-2004, 09:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L