+ Responder ao Tópico



  1. #1

    Padrão Firewall nao compartilha

    Olá amigos, estou com dificuldades em compartilhar minha conexao Adsl, vejam minha situação:

    Tenho um modem roteado funcionando como servidor DHCP, ligado a eth0, com os dns do VELOX já configurados nele. A eth0 recebe o um ip da faixa 10.0.0.0. Para a rede interna eu tenho a eth1 com a seguinte faixa de IP: 192.168.1.0 . No arquivo resolv.conf tenho o Ip do modem (10.1.1.1) . As rotas estao dispostas da seguinte forma

    rede netmask gw iface
    192.168.1.0 255.255.255.0 n tem eth1
    10.0.0.0 255.0.0.0 n tem eth0
    0.0.0.0 (default) 10.1.1.1

    certo ... O serivodr Funciona normalmente navega até, essas mesmas configurações funcionam em outra maquina como servidor, mas nesta nao, das estaçõs eu consigo pingar na eth1( rede interna) mas nao compartilha... Abaixo tenho as seguinte regras no script Firewall, em outra maquina até omitindo o paramentro "-s 192.168.1.0/24 " compartilha ....

    modprobe iptable_nat

    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -s 192.168.1.0/24 -o eth0 -j MASQUERADE

    configurei o dns nas estações tb , junto aos ips da faixa 192.168.1.0 e gw 192.168.1.1 . Espero Ajuda ...

    espero ajuda ...

  2. #2
    felco
    Visitante

    Padrão Re: Firewall nao compartilha

    Qual distribuição vc está usando?!



  3. #3

    Padrão Re: Firewall nao compartilha

    Slack, felco ...

  4. #4
    felco
    Visitante

    Padrão Re: Firewall nao compartilha

    Execute em sequencia para ver se funciona...

    iptables -F
    iptables -X
    iptables -P INPUT ACCEPT
    iptables -P FORWARD ACCEPT
    iptables -P OUTPUT ACCEPT
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    Se nao funcionar provavel que seja problema de hardware



  5. #5

    Padrão Re: Firewall nao compartilha

    ainda nao conseguih, nao obtive resultado com essas regras de firewall , alguem me ajujda por favor ?

  6. #6
    henrique_1502
    Visitante

    Padrão Re: Firewall nao compartilha

    aqui na empresa onde trabalho etava com o mesmo problema e resolvi dessa forma :


    ######DECLARA QUEM É INTERNO E EXTERNO ############################################
    EXTIF="eth0"
    INTIF="eth1"
    echo " Interface Externa: $EXTIF"
    echo " Interface Interna: $INTIF"
    ###########################################################################
    # #encaminhamento IP pois ele é desativado por padrão
    ###########################################################################
    echo " Habilitando o encaminhamento IP.."
    echo "1" > /proc/sys/net/ipv4/ip_forward
    echo " Habilitando IP dinâmico.."
    echo "1" > /proc/sys/net/ipv4/ip_dynaddr
    ###########################################
    # COMPARTILHA A NET############################################
    modprobe iptable_nat
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE





    Espero que tenha ajudado