+ Responder ao Tópico



  1. #1
    cfsl
    Ola pessoal... sou novo aki no fórum e tambem sou um pouco novato com linux... tenho uma máquina aki instalada o suse 9.3, tenho que montar um servidor simples de arquivos com ela, para isso preciso usar o SAMBA ja que toda a rede aki é com windows XP, ja peguei algumas apostilas de samba, li e tentei configurar o samba.conf aki, mas não estou conseguindo fazer tudo funcionar.

    Eu faço as configurações no arquivo testo depois usando o comando "testparm" a aparece tudo ok, vou em uma máquina com win xp que esta na rede, consigo ver o servidor samba no grupo em que coloquei, mas não consigo acessar a servidor de jeito nenhum, da akele erro dizendo que a máquina não esta acessivel.

    Eu axo que preciso configurar alguma coisa na máquina com win xp tambem pro compartilhamento funcionar mas não sei o que tenho que configurar, ja vi em algumas apostilas falando para configurar (botão direito em cima do meu computador e escolher opções de rede) mas isso não tem no win xp axo que isso é do windows 2000....
    O teste que estou querendo fazer de começo, é compartilhar um arquivo com o samba e acessar esse arquivo com uma máquina com o win xp, pra depois se der certo compartilhar para toda a rede. Aqui vai como esta configurado o meu arquivo samba.conf caso alguem entenda e queira dar uma analisada pra ve se existe algo errado :

    Samba config file created using SWAT
    # from 127.0.0.1 (127.0.0.1)
    # Date: 2006/03/10 15:47:14

    # Global parameters
    [global]
    comment = Servidor Samba
    workgroup = CENTREG
    security = user
    os level = 100
    announce as = NT Server
    domain logons - no
    logon script = %U.bat
    domain master = no
    local master - no
    prefered master - yes
    guest acount = nobody
    wins support = yes
    keep alive = 20
    debug level = 3
    null passwords = yes
    hosts allow = ip da máquina que tera acesso ao servidor
    map to guest = Bad User
    username map = /etc/samba/smbusers
    printcap cache time = 750
    printcap name = cups
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    logon path = \\%L\profiles\.msprofile
    logon drive = P:
    logon home = \\%L\%U\.9xprofile
    printer admin = @ntadmin, root, administrator
    cups options = raw
    include = /etc/samba/dhcp.conf

    [homes]
    comment = Home Directories
    valid users = %S
    read only = No
    inherit acls = Yes
    browseable = yes
    writeable - yes

    [users]
    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/

    [groups]
    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes

    [printers]
    comment = All Printers
    path = /var/tmp
    create mask = 0600
    printable = Yes
    browseable = No

    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin, root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

    [netlogon]
    comment = Compartilhamento de Scripts
    path= etc/scripts
    public - no
    browseable - yes
    writeable - no

    [CENTREG]
    comment = Grupo CENTREG
    path = /home
    public - yes
    browseable - yes
    writeable - yes
    write list - @CENTREG
    read list - @CENTREG
    hosts allow = ip da maquina que tera acesso a pasta “/home”

    Essa configuração, é a configuração que ja estava no arquivo samba.conf quando eu abri ele pela primeira vez, e mais algumas coisas que eu adicionei olhando pela apostila que tenho aqui, por isso deve ter coisas a mais nessa configuração que fiz.

    Se alguem puder me ajudar dando uns toques do que esta errado e do que esta certo, e o que falta para a máquina com win reconhecer o servidor eu agradeço muito ....

    valeu...

    até +

  2. #2
    wellington2
    So uma pergunta vc criou o usuario samba pra accessar este server?Vc tem que adicionar um usuario e depois criar uma senha samba para esse usuario..
    Ex. adduser joão
    smbpasswd joão
    ai o linux pede para vc digitar a senha duas vezes pronto vc adicionou o usuario.agora la no smb.conf vc adiciona tambem esse usuario...



  3. #3
    cfsl
    Ola Wellington... então eu criei os usuário no Samba, usando o Swat e depois criei no linux mesmo... criei usuários e tambem um grupo chamado CENTREG que é o nome do grupo onde estão as maquinas com win xp na tede.... mas na hora que vou acessar o servidor samba com uma máquina win xp ele diz que o Ser_Samba (o nome do servidor) não esta acessivel e não abre akela tela pedindo loguin e senha.

    Não sei se tem alguma coisa a ver tambem, mas a rede aki na empresa ela não tem nenhum dominio, existe apenas o grupo de trabalho CENTREG.

    Se vc puder me ajudar eu agradeço, pq realmente não sei o que acontece.

    value


  4. Olá amigo. Eu tenho algumas estações XP na nossa rede e sempre que configuro uma estação xp para conectar no nosso servidor Samba, que está no Slackware em um servidor e no Conectiva 8 no outro servidor, eu faço o seguinte no xp. Clico em iniciar, configurações, ferramentas administrativas, diretivas locais e opções de segurança. Nesse item eu procuro um tópico que fala sobre senha criptografada para servidores SMB de outro fabricante. Coloco ela como ativada. Ela vem por padrão como desativada. Outra coisa : no SuSE , se não me engano tem um parâmetro do smb.conf que eu vi também no slackware, que fala de passdb backend. Acho que é isso. Veja em man smb.conf. Esse parâmetro especifica onde está o path para o arquivo smbpasswd. Eu penei para descobrir isso. Mas depois, ficou legal. Descobri vendo o comando man smb.conf. Tem muitas dicas legais no man.
    Espero ter ajudado em alguma coisa ... Um grande abraço .... :-)



  5. Cara uma coisa que pode ser tb é....

    O windows pode não estar encontrando seu servidor por nome,,,, apenas com ip....para funcionar com nome vc tem q adicionar uma linha no seu windows;

    arquivo estadentro da pasta system32/drivers/etc/hosts

    adcione a linha

    "nome do server" "ip"

    salve e saia.....

    talvez tenha que reniciar o PC... depois vá até o executar e digite \\nome do server

    Se a config do samba tivé certa vai funçona



    falows aew






Tópicos Similares

  1. Respostas: 2
    Último Post: 26-03-2015, 14:55
  2. Windows XP não entra no Dominio Samba
    Por lucastavarestga no fórum Servidores de Rede
    Respostas: 0
    Último Post: 16-04-2006, 02:25
  3. Windows 2003 não conecta no compartilhamento Samba
    Por Ricardo Silva no fórum Servidores de Rede
    Respostas: 2
    Último Post: 15-07-2005, 10:13
  4. XP nao apaga arquivos no samba-2.0.3
    Por wsavi no fórum Servidores de Rede
    Respostas: 9
    Último Post: 23-02-2005, 13:42
  5. Help Help Licq não conecta no servidor
    Por Itise no fórum Servidores de Rede
    Respostas: 1
    Último Post: 30-01-2003, 11:03

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L