+ Responder ao Tópico



  1. #1
    rafaeldw
    fala galera, blz?
    em uma das maquinas do meu serviço instalamos o FreeBSD 6, e iremos usar o apache 2.0.54 + php 4.3.2 + gd 2.0.33, depois de ralar pra instala o apache (precisavamos de tds os modulos, no linux era --enable-module=so, no bsd eh --enable-so, e sofremos pra isso ¬¬) instalamos o gd com os pacotes q precisava, depois , no php precisamos de uma serie de opcoes :

    /configure --prefix=/usr/local/www-2.0.52/php --with-config-file-path=/usr/local/www-2.0.52/php/lib --with-gd --enable-gd-native-ttf --with-png-dir --with-zlib-dir --with-zlib --with-ttf --with-jpeg-dir= --with-freetype-dir --with-xpm-dir --enable-track-vars --enable-calendar --with-apxs2=/usr/local/www-2.0.52/bin/apxs

    mas durante o configure o php acusa um erro no freetype, sendo q o freetype ja esta instalado no lugar onde ele acusa o erro.. o unico problema eh q nao tenho como copiar o erro q da la aki, pq la ta sem rede...
    c precisa vo tenta depois da um jeito de copia..

    mas por enquanto, alguem sabe como converter isso? alguem ja enfrento isso?

    vlw

  2. Faz assim

    Atualiza o ports assim:
    portsnap fetch
    portsnap extract
    portsnap update

    Instalando apache20
    cd /usr/ports/www/apache20
    mcedit MakeFile

    Procure a linha onde começa:
    CONFIGURE_ARGS= --prefix=

    Coloque sua opções salve e saia, depois :
    make install clean


    Instalando php4
    cd /usr/ports/lang/php4
    make configure # habilite as opções que precisa OK - Começa instalar automatico

    Se nao começar instalr automatico faça:
    make install clean

    Instalando extencao php4 no apache
    cd /usr/ports/lang/php4-extencions
    make install clean

    Só nao encontrei o gd...

    Flw

    Instalando apache2



  3. #3
    etherlink
    Quando vc vai instalar o php ele ja ti dar lista do que precisa ser baixado pelo ports..sem precisar compilar tudo na mao...
    cd /usr/ports/lgan/php4

  4. cd /usr/ports/www/apache20
    make install clean
    cd /usr/ports/lang/php4
    make install clean
    cd /usr/ports/lang/php4-extensions
    make install clean

    Mais facil que isso, impossivel.






Tópicos Similares

  1. problemas pra instalar a v3.2x
    Por Gosulator no fórum Redes
    Respostas: 1
    Último Post: 26-04-2009, 18:39
  2. problemas pra instalar o samba no linux LE 2.0
    Por stormpbi no fórum Servidores de Rede
    Respostas: 1
    Último Post: 05-01-2009, 11:23
  3. problemas pra instalar o bash 3.0 OPenBSD
    Por fjunior no fórum Sistemas Operacionais
    Respostas: 2
    Último Post: 20-08-2005, 08:32
  4. Respostas: 0
    Último Post: 13-08-2004, 14:03
  5. problemas para instalar o apache !!!!!!
    Por noir no fórum Servidores de Rede
    Respostas: 18
    Último Post: 20-07-2004, 15:41

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L