+ Responder ao Tópico



  1. Olá galera!

    Alguem ai já usou o pam_winbind.so pra autenticar usuários do FTP ?? Aqui eu não estou conseguindo, consigo usar o pam_winbind pra autenticação do courier-imap e postfix, inclusive logando via webmail. Mas eu preciso do ftp ŕa atiavr o Vacation no squirrelmail.

    Acho q estou configurando errado o serviço em /etc/pam.d/ftp

    ele está assim:
    Código :
    #/etc/pam.d/ftp
    auth required pam_winbind.so
    account required pam_winbind.so

    Deixei ele assim pois é essa a configuração que eu utilizo para o smtp e imap e funciona!

    Só que quando tento logar o usuário tenho isso no meu syslog:

    Mar 20 09:26:16 zen-dsk10 proftpd: PAM _pam_load_conf_file: unable to open /etc/pam.d/pam_winbind.so
    Mar 20 09:26:16 zen-dsk10 proftpd: PAM unable to dlopen(<*unknown module path*>)
    Mar 20 09:26:16 zen-dsk10 proftpd: PAM [dlerror: <*unknown module path*>: cannot open shared object file: No such file or directory]
    Mar 20 09:26:16 zen-dsk10 proftpd: PAM adding faulty module: <*unknown module path*>
    Mar 20 09:26:16 zen-dsk10 proftpd: PAM _pam_load_conf_file: unable to open /etc/pam.d/pam_winbind.so
    e no log do proftp eu tenho isso:
    Mar 20 09:29:21 zen-dsk10 proftpd[20849] zen-dsk10.zenisys.local (zen-dsk10.zenisys.local[192.168.0.30]): FTP session opened.
    Mar 20 09:29:27 zen-dsk10 proftpd[20849] zen-dsk10.zenisys.local (zen-dsk10.zenisys.local[192.168.0.30]): no such user 'diegoadm'
    Mar 20 09:29:27 zen-dsk10 proftpd[20849] zen-dsk10.zenisys.local (zen-dsk10.zenisys.local[192.168.0.30]): USER diegoadm: no such user found from zen-dsk10.zenisys.local [192.168.0.30] to 192.168.0.30:21

    Mas os usuários locais ele autentica normalmente !

    Se alguem tiver alguma ideia ou já fez isso

  2. Após muito apanhar e ler, descobri que apenas o pam não é suficiente pra autenticar o usuário.... então meu pam_winbind não vai dar certo =/

    aqui esta o link:
    http://www.castaglia.org/proftpd/doc...ntication.html






Tópicos Similares

  1. Usando squid com sarg
    Por luizflavio no fórum Servidores de Rede
    Respostas: 2
    Último Post: 07-07-2005, 11:13
  2. problema para conectar usando adsl com modem DLink500Grouter
    Por Luquinhass no fórum Servidores de Rede
    Respostas: 11
    Último Post: 15-09-2004, 12:45
  3. Erro com libXft.so.2 no debian
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 0
    Último Post: 02-03-2004, 22:22
  4. Autenticacao usando VirtualHost com ProxyPass
    Por clever no fórum Servidores de Rede
    Respostas: 0
    Último Post: 19-12-2002, 12:54
  5. Curriculum.com.br só aceita IE
    Por 1c3m4n no fórum Servidores de Rede
    Respostas: 20
    Último Post: 05-12-2002, 23:45

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L