+ Responder ao Tópico



  1. #1

    Padrão OpenVPN - Não consigo pingar na rede interna!

    Instalei dois servidores OpenVPN (Matriz e Filial) e estão funcionando certinho. O problema e que não consigo pingar de um lado do túnel para o outro (Matriz – 192.168.0.0/24 e Filial – 192.168.1.0/24), isso de ambos os lados. Agora se eu estiver no servidor da Filial consigo pingar nas pontas do túnel (Matriz-10.0.0.1 / Filial – 10.0.0.2) e também na rede interna da Matriz. Já se eu estiver em uma estação da rede interna (Filial – 192.168.1.0/24) não consigo pingar além da ponta do túnel da filial (10.0.0.2). O que será que pode está errado ou faltando na configuração de ambos.
    Os teste que realizei, foram sem FIREWALL e a única rota que eu criei no servidor da Filial foi esta: route add -net 192.168.1.0/24 gw 10.0.0.1.

    Obrigado e espero qualquer tipo de orientação.

  2. #2

    Padrão Re: OpenVPN - Não consigo pingar na rede interna!

    Descomentou a diretiva client-to-client ?



  3. #3
    slackrio
    Visitante

    Padrão Re: OpenVPN - Não consigo pingar na rede interna!

    Posta os confs das duas pontas para darmos uma olhada pra poder ajudar melhor

  4. #4

    Padrão Re: OpenVPN - Não consigo pingar na rede interna!

    Citação Postado originalmente por Duca
    Descomentou a diretiva client-to-client ?
    Não! Mas redefini as rotas e agora está dando certo.

    Esta diretiva que você mencionou é realmente necessaria?

    Outra coisa: Como é que eu faço para ter acesso aos recursos compartilhados da Rede - A (Matriz), onde lá existe um domínio local (SAMBA-PDC) e a estação está na Rede - B e já está autenticada nessa rede (SAMBA-PDC) localmente?

    Muito obrigado e espero que você possa me ajudar novamente.



  5. #5

    Padrão Re: OpenVPN - Não consigo pingar na rede interna!

    Citação Postado originalmente por slackrio
    Posta os confs das duas pontas para darmos uma olhada pra poder ajudar melhor
    slackrio,

    redefini as rotas e agora está dando certo.

    Outra coisa: Como é que eu faço para ter acesso aos recursos compartilhados da Rede - A (Matriz), onde lá existe um domínio local (SAMBA-PDC) e a estação está na Rede - B e já está autenticada nessa rede (SAMBA-PDC) localmente?

    Obrigado e espero qualquer ajudar.

  6. #6
    slackrio
    Visitante

    Padrão Re: OpenVPN - Não consigo pingar na rede interna!

    Eu tenho o openvpn aqui tb rodando blz os meus usuarios logan logan no servidor vpn normalmente com o samba configurado .. ou seja eu ja tinha o samba rodando e meses depois que fui instalar vpn aqui e uso o samba do jeito que ta ... vc ja tem os usuarios cadastrador no samba ? (smbpasswd -a usuario)
    quando vc abre roda o openvpn ele cria um tunel somente isso e passa a fazer parte da rede normalmente e com isso acessando os serviços normais.. bom comigo ta rodando blz

    a conf do meu samba ta assim nos compartilhamentos:

    #======================= Shares ===========================================
    [homes]
    comment = Rede Linux
    public = no
    browseable = no
    writeable = yes
    write list = Linux

    #[public]
    #comment = Diretorio publico
    #path = /home/publico
    #public = yes
    ##read only = yes
    #writeable = yes
    #write list = @users
    #create mask = 755

    depois criado os usarios no samba.

    ##########################################################################

    cara ja que vc acertou na rota .. me passa como ta a sua rota que eu tb to com uma difilcudade de acertar uma aqui
    ta desta forma a conf:

    matriz :
    ip local:192.168.0.1/24
    ip vpn : 10.10.0.1

    filial:
    iplocal: 192.168.0.1/24
    ip vpn : 10.10.0.2

    quebra esta pra min!!

    valew



  7. #7

    Padrão Re: OpenVPN - Não consigo pingar na rede interna!

    Citação Postado originalmente por slackrio
    Eu tenho o openvpn aqui tb rodando blz os meus usuarios logan logan no servidor vpn normalmente com o samba configurado .. ou seja eu ja tinha o samba rodando e meses depois que fui instalar vpn aqui e uso o samba do jeito que ta ... vc ja tem os usuarios cadastrador no samba ? (smbpasswd -a usuario)
    quando vc abre roda o openvpn ele cria um tunel somente isso e passa a fazer parte da rede normalmente e com isso acessando os serviços normais.. bom comigo ta rodando blz

    a conf do meu samba ta assim nos compartilhamentos:

    #======================= Shares ===========================================
    [homes]
    comment = Rede Linux
    public = no
    browseable = no
    writeable = yes
    write list = Linux

    #[public]
    #comment = Diretorio publico
    #path = /home/publico
    #public = yes
    ##read only = yes
    #writeable = yes
    #write list = @users
    #create mask = 755

    depois criado os usarios no samba.

    ##########################################################################

    cara ja que vc acertou na rota .. me passa como ta a sua rota que eu tb to com uma difilcudade de acertar uma aqui
    ta desta forma a conf:

    matriz :
    ip local:192.168.0.1/24
    ip vpn : 10.10.0.1

    filial:
    iplocal: 192.168.0.1/24
    ip vpn : 10.10.0.2

    quebra esta pra min!!

    valew
    slackrio,

    você usa o seu SAMBA como controlador de domínio (PDC)? Pois como eu tenho PDC em ambos os lados acho que o usuário só pode ser autenticado em apenas um dele. Ou eu estou errado?
    outra o OpenVPN está todo certinho. O que tá faltando é localizar as estações de ambas as redes pela NetBIOS (nome) e que as mesmas fiquem visiveis no "ambiente de rede" do windows. Já defini em ambas as rede um servidor WINS, mas não resolvou. Você sabe como posso resolver isso?

    Sobre as rotas: Acho que você deve diferenciar o endereçamento da Matriz e da Filial. Tipo Matriz 192.168.0.1 e Filial 192.168.1.1, sendo assim fica mais facil de aplicar as rotas conforme abaixo:

    Na Matriz faça: route add -net 192.168.1.0/24 gw 10.10.0.2

    Na Filial faça: route add -net 192.168.0.0/24 gw 10.10.0.1

    Depois teste pingar nas pontas do túnel e além das pontas. É só.

    Espero ter te ajuda, mais uma vez obrigado e aguardo um novo contato seu.


  8. #8
    slackrio
    Visitante

    Padrão Re: OpenVPN - Não consigo pingar na rede interna!

    valew pelas as rotas irei ver aqui como fica

    sobre o samba e o seguinte, o servidor que tenho rodando openvpn se conecta ao um outro sendo matriz e filial blz, cada um deles tem o samba PDC rodando pra ass suas respesctivas redes locais .. entao o que acontece e que quando o tunel se forma conectando os 2 servidores cada um pedira a a autenticacao para entrar nos seus propios diretorios ou seja compartilhamento ..
    quando o matriz aqui tenta entrar na maquina filial que esta em outro bairro da cidade ele pede o usuario e senha para ter acesso ao compartilhamento, e quando a filial acessa a ,matriz acontece a mesma coisa .. a conclusao que chego entao e que o samba vc pode deixar como esta para a sua rede pq a vpn ira trabalhar em cima das permissoes de acesso que vc deixou na conf do samba.

    Sobre em ver a maquinas visiveis em ambiente de rede vc tem ativa wins no samba como ja feito !
    o que vc pode fazer e colocar no windows
    1 no icone de ambiente de rede do windows na area de tranbalho vai com o botao direto e escolhe procurar maquina na rede ai vc coloca o ip e coloca pra procurar ... ira pedir a autenticacao para poder ver os arquivos .
    pode ate mapear a unidade depois..
    irei ver aqui mais detalhes e informo aqui ok



  9. #9

    Padrão Re: OpenVPN - Não consigo pingar na rede interna!

    Citação Postado originalmente por slackrio
    valew pelas as rotas irei ver aqui como fica

    sobre o samba e o seguinte, o servidor que tenho rodando openvpn se conecta ao um outro sendo matriz e filial blz, cada um deles tem o samba PDC rodando pra ass suas respesctivas redes locais .. entao o que acontece e que quando o tunel se forma conectando os 2 servidores cada um pedira a a autenticacao para entrar nos seus propios diretorios ou seja compartilhamento ..
    quando o matriz aqui tenta entrar na maquina filial que esta em outro bairro da cidade ele pede o usuario e senha para ter acesso ao compartilhamento, e quando a filial acessa a ,matriz acontece a mesma coisa .. a conclusao que chego entao e que o samba vc pode deixar como esta para a sua rede pq a vpn ira trabalhar em cima das permissoes de acesso que vc deixou na conf do samba.

    Sobre em ver a maquinas visiveis em ambiente de rede vc tem ativa wins no samba como ja feito !
    o que vc pode fazer e colocar no windows
    1 no icone de ambiente de rede do windows na area de tranbalho vai com o botao direto e escolhe procurar maquina na rede ai vc coloca o ip e coloca pra procurar ... ira pedir a autenticacao para poder ver os arquivos .
    pode ate mapear a unidade depois..
    irei ver aqui mais detalhes e informo aqui ok
    Beleza!

    Mas tudo isso que você mencionou é exatamente o que estou fazendo. Procuro as máquina pelo IP e não pelo NOME e as encontro (em ambas as redes). Consigo mapear também e etc. Configurei servidores WINS (em ambas as redes) e especifiquei o mesmos nas estações windows, mas o que me deixa mais confuso é o fato de todas as estações (ambas as redes) não aparecerem no "ambiente de rede".

    Obrigado pelo "toque" e vamos nos falando para ver se a gente resolve isso.

  10. #10

    Padrão Re: OpenVPN - Não consigo pingar na rede interna!

    Na Matriz faça: route add -net 192.168.1.0/24 gw 10.10.0.2

    Na Filial faça: route add -net 192.168.0.0/24 gw 10.10.0.1

    Depois teste pingar nas pontas do túnel e além das pontas. É só.
    O problema ai é o seguinte: mesmo com a vpn inativa, as maquinas da rede matriz acessam a filial so por causa da rota.
    Estou com o mesmo problema aqui e nao consigo resolver: autentica, estabelece o tunel e a rede1 nao pinga a rede2. :?
    Nao sei o que fazer!



  11. #11

    Padrão Re: OpenVPN - Não consigo pingar na rede interna!

    Opa, desculpem a demora.
    A diretica client-to-client permite que os clientes possam se enxergar, por padrão eles só enxergam o servidor.

    roggy, voce poderia postar seu conf, para darmos uma olhada.

    Ab, Duca. :-)

  12. #12

    Padrão Re: OpenVPN - Não consigo pingar na rede interna!

    Citação Postado originalmente por Duca
    Opa, desculpem a demora.
    A diretica client-to-client permite que os clientes possam se enxergar, por padrão eles só enxergam o servidor.

    roggy, voce poderia postar seu conf, para darmos uma olhada.

    Ab, Duca. :-)
    Olá Duca,

    tentei colocar a diretiva "client-to-client", só que quando vou levantar o serviço (OpenVPN) dá um erro justamente desta diretiva. É como se ela na fosse reconhecida. E agora o que posso fazer?

    Obrigado e aguardo qualquer ajuda.