+ Responder ao Tópico



  1. #1
    fabum
    Boa tarde pessoal.

    Estou com o seguinte problema:
    S.O.: Debian Sarge com kernel 2.6.16
    Na hora de carregar as interfaces de rede:
    Configurei o arquivo /etc/network/interfaces da seguinte forma:

    Rede interna
    auto eth1
    iface eth1 inet static
    adress 192.168.2.1
    netmask 255.255.255.0
    broadcast 192.168.0.255
    network 192.168.2.0

    Rede externa
    auto eth0
    iface eth0 inet static
    adress
    netmask
    broadcast
    network
    gatway
    Acima eu coloco os endereços da minha conexão com a internet

    Quando eu subo a interface de rede ele retorna as seguintes mensagens:

    Don´t seem to be have all the variables for eth1/inet.
    Failed to bring up eth1.
    Don´t seem to be have all the variables for eth0/inet.
    Failed to bring up eth0.
    done

    Daí eu configuro elas pelo ifconfig e funciona tudo perfeitamente. O inconveniente é que eu tenho que configurar tudo dinovo toda vez que reinicio a máquina.
    Eu observei tb que quando eu configuro no arquivo interfaces para pegar ip por dhcp funciona bem.

    Por que será que quando eu coloco static não sobe sozinho?

    Desde já agradeço a colaboração de todos.

    Tenham um excelente dia.

  2. cara, tipo como vc quer que a máquina configure o ip se voce não diz pra ela de onde tirar esta informação? voce não disse pra eth0 qual é o adress dela, a não ser que voce espere que ela se lembre do ultimo ip ou saiba que tem um servidor DHCP na rede (ela não vai procurar afinal de contas voce não mandou) não vai funcionar mesmo.



  3. #3
    fabum
    Se vc prestar atenção abaixo das configs da eth0 eu indiquei em negrito que eu coloco minhas configurações aki.
    São os meus ips reais. Por cautela preferi não divulgá-los publicamente.






Tópicos Similares

  1. Respostas: 9
    Último Post: 01-03-2010, 12:20
  2. Respostas: 1
    Último Post: 09-06-2009, 12:00
  3. Problemas em Configuração Rede
    Por fcavalera no fórum Sistemas Operacionais
    Respostas: 2
    Último Post: 06-09-2008, 12:54
  4. Problemas em Interface de Rede
    Por flaviobatistela no fórum Servidores de Rede
    Respostas: 4
    Último Post: 29-10-2005, 17:32
  5. diagnosticar problemas em uma placa de rede...
    Por sarna no fórum Servidores de Rede
    Respostas: 0
    Último Post: 22-09-2005, 10:19

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L