+ Responder ao Tópico



  1. #1
    NeedHelp
    Visitante

    Padrão Nvidia - FX 5200 - Trava Após startx

    Já rodei muitos lugares procurando está solução.

    1º Rodando Slackware 10.2 (supondo que tenha acabado de ser instalado)
    2º Utilizando o bare.i
    3º Utilizando FX 5200 128MB
    4º Baixei e instalei o driver da NVIDIA (sh NVDIA... o mais novo) em modo texto (assim que inicializa o sistema) a instalação ocorreu tudo certo
    5º Olhei no xorg.conf e está aparentemente correto (em relação ao Load GLcore e Load dri que devem ser comentados, no caso eles nem estão lá e o driver está como nvidia)


    Agora o problema, quando eu dou startx a tela fica preta(cinza) e a única solução é o botão reset.

    O que eu preciso colar aqui pra me ajudarem a resolver, ou isso basta. :mrgreen:

  2. #2
    antonioclj
    Visitante

    Padrão Re: Nvidia - FX 5200 - Trava Após startx

    Boa noite. Aqui em casa tenho uma GF 6600 256 MB e instalei o drive da nvidia sem nenhum problema. Fiz da mesma forma que você o fez. Então vou dar um chute. Dê uma olhada na bios e veja se tem alguma opção como designar irq para VGA. Aqui está habilitada. Veja se não é o seu caso. Boa sorte.

    Antonio Carlos Lemos Júnior



  3. #3

    Padrão Re: Nvidia - FX 5200 - Trava Após startx

    veja se a frequencia/resolucao do monitor nao estao ferradas, olhe no log do X oq acontece (ctrl+alt+backspace mata o x), se nao der certo volte o driver de nvidia para nv (generico) e tente achar oq tem de errado na conf... as vezes é algo no X e nao no driver..
    veja a minha conf:
    Código :
    Section "Module"
      Load    "dbe"  # Double buffer extension
      SubSection "extmod"
       Option  "omit xfree86-dga"  # don't initialise the DGA extension
      EndSubSection
      Load    "type1"
      Load    "freetype"
      Load    "glx"
    EndSection
    Section "Files"
      RgbPath   "/usr/X11R6/lib/X11/rgb"
      FontPath  "/usr/share/fonts/misc/"
      FontPath  "/usr/share/fonts/Type1/"
      FontPath  "/usr/share/fonts/75dpi/"
      FontPath  "/usr/share/fonts/100dpi/"
    EndSection
    Section "ServerFlags"
    EndSection
    Section "InputDevice"
      Identifier "Keyboard1"
      Driver   "kbd"
      Option "AutoRepeat" "500 30"
      Option "XkbRules"  "xorg"
      Option "XkbModel"  "abnt2"
      Option "XkbLayout" "br"
    EndSection
    Section "InputDevice"
      Identifier "Mouse1"
      Driver   "mouse"
      Option "Protocol"  "IMPS/2"
      Option "Device"   "/dev/psaux"
      Option "ZaxisMapping" "4 5"
    EndSection
    Section "Monitor"
        Identifier  "My Monitor"
        VendorName  "SAM"
        ModelName  "1057"
        HorizSync  30.0 - 70.0
        VertRefresh 50.0 - 160.0
        Option   "DPMS"
    EndSection
    Section "Device"
      Identifier "Standard VGA"
      VendorName "Unknown"
      BoardName  "Unknown"
      Driver   "vga"
    EndSection
    Section "Device"
      Identifier "** NVIDIA (generic)          [nv]"
      Driver   "nvidia"
      Option "UseEDID" "FALSE"
      Option "NvAGP" "1"
      Option     "RenderAccel"      "true"
      Option "AllowGLXWithComposite" "true"
      # Insert Clocks lines here if appropriate
    EndSection
    Section "Screen"
      Identifier "Screen 1"
      Device   "** NVIDIA (generic)          [nv]"
      Monitor   "My Monitor"
      DefaultDepth 24
      Subsection "Display"
        Depth    8
        Modes    "1600x1200" "1400x1050" "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort  0 0
      EndSubsection
      Subsection "Display"
        Depth    16
        Modes    "1600x1200" "1400x1050" "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort  0 0
      EndSubsection
      Subsection "Display"
        Depth    24
        Modes    "1600x1200" "1400x1050" "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort  0 0
      EndSubsection
    EndSection
    Section "ServerLayout"
      Identifier "Simple Layout"
      Screen "Screen 1"
      InputDevice "Mouse1" "CorePointer"
      InputDevice "Keyboard1" "CoreKeyboard"
    EndSection
    Section "Extensions"
        Option "Composite" "Enable"
    EndSection