+ Responder ao Tópico



  1. #1
    slacklex


    Olá pessoal boa tarde!! Estou configurando aqui o HTB para que faça controle de banda somente em uma maquina da rede, essa maquina conforme podem ver é a 192.168.0.2. O servidor de conexão internet está configurado com o IPTABLES e Squid e este estão funcionando conforme o planejado.

    No entanto conforme podem ver coloquei abaixo uma regra para limitar a banda para o ip 192.168.0.2 em 60 kbps, mas não está funcionando pois vejam que quando baixo alguma coisa nessa maquina sempre baixa com velocidade alta tipo 40 50 KBytes/s, sendo que deveria baixar em algo tipo 6 KBytes/s.. Tenho uma conexao ADSL em modo bridge de 600k.

    O que está errado nesse script ai? Se alguem aí ja sabe HTB e puder me ajudar agradeço muito! Obrigado.

    #!/bin/bash

    tc qdisc del dev ppp0 root
    tc qdisc add dev ppp0 root handle 1: htb default 12

    tc class add dev ppp0 parent 1: classid 1:1 htb rate 600kbps

    # REgra q limita banda em 60kbps
    tc class add dev ppp0 parent 1:1 classid 1:10 htb rate 60kbps

    tc filter add dev ppp0 protocol ip parent 1:1 prio 1 u32 match ip src 192.168.0.2 flowid 1:10

  2. olha,
    baseado no seu script que vc colocou aqui, vc terá de fazer muito mais coisas

    1 - seu objetivo é controlar somente Download ou também Upload ?
    em caso afirmativo vc deve criar regras para a sua outra interface de saída, e procure marcar os pacotes e fazer os filtros pelos pacotes marcados, pq em caso de nat ele nào irá controlar o upload pq como a banda é controlada na saída o ip já será outro

    agora se seu objetivo é controlar apenas o download veja qual é a interface que sai para o ip 192.168.0.2 e lembre-se que a banda é controlada saída... e veja a questão de src e dst ou seja'se é source ou destination

    creio que com isso já conseguira resolver seu problema



  3. #3
    slacklex
    Olá, o objetivo é somente controle de download mesmo. O servidor tem 2 placas de rede a eth1 está o link adsl que é conectado via pppoe-start e a eth0 é a que tem ip 192.168.0.1 que liga com o outro pc que é o que tem o ip 192.168.0.2. Bom, mudei no script a opção src para dst, no entanto fui testar na maquina cliente um download qualquer de um site de downloads e continua baixando com velocidade máxima.... O que pode estar errado entaum? No servidor uso o kernle 2.6.13 e além do script htb está rodando o Squid Proxy e o Iptables como firewall.... Obrigado






Tópicos Similares

  1. autenticação squid nao esta funcionando
    Por muganga no fórum Servidores de Rede
    Respostas: 6
    Último Post: 18-02-2004, 12:50
  2. Meu SMTP do Qmail não esta funcionando Rede Externa!!!!
    Por maiconovic no fórum Servidores de Rede
    Respostas: 3
    Último Post: 18-10-2003, 09:08
  3. Respostas: 10
    Último Post: 11-06-2003, 07:20
  4. DNS Nao esta funcionando
    Por earaujos no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-02-2003, 14:40
  5. acl no squid não está funcionando. O que fazer ?
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 20-12-2002, 16:01

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L