Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    eduardoalbano
    Oi Pessoal,

    Estou com um problema no meu squid, quando tento startar ele aparece a seguinte mensagem:

    /etc/init.d/squid: line 129: log_daemon_msg: command not found
    * Creating squid spool directory structure
    2006/05/03 09:02:53| Creating Swap Directories
    ...done.


    Ja tentei usar o apt-get para atualiza-lo e nao adianta nada.. continua o mesmo erro. Estava funcionando normalmente e "do nada" parou. Alguem tem uma luz???


    Abraços,

    Eduardo.

  2. Amigo, faça

    squid -z

    ele vai criar o swap.
    Talvez seu problema seja permissão das pastas.

    http://www.vivaolinux.com.br/artigos...hp?codigo=2020

    Veja as permissões aqui e faça o squid -z


    FUI !!!



  3. #3
    eduardoalbano
    Amigo,

    Foi otima sua ajuda. Só que continua com o mesmo problema.

    Olha o que aparece no cache.log:

    2006/05/03 11:38:48| Starting Squid Cache version 2.5.STABLE13 for i386-debian-linux-gnu...
    2006/05/03 11:38:48| Process ID 15940
    2006/05/03 11:38:48| With 1024 file descriptors available
    2006/05/03 11:38:48| DNS Socket created at 0.0.0.0, port 32794, FD 6
    2006/05/03 11:38:48| Adding nameserver 10.17.1.34 from /etc/resol2006/05/03 11:38:48| commBind: Cannot bind socket FD 9 to *:3128: (98) Address already in use
    FATAL: Cannot open HTTP Port
    Squid Cache (Version 2.5.STABLE13): Terminated abnormally.
    CPU Usage: 0.028 seconds = 0.018 user + 0.010 sys
    Maximum Resident Size: 0 KB
    Page faults with physical i/o: 0
    Memory usage for squid via mallinfo():
    total space in arena: 2624 KB
    Ordinary blocks: 2495 KB 2 blks
    Small blocks: 0 KB 1 blks
    Holding blocks: 204 KB 1 blks
    Free Small blocks: 0 KB
    Free Ordinary blocks: 128 KB
    Total in use: 2699 KB 103%
    Total free: 128 KB 5%

    Agradeço mais uma vez a ajuda,


    Eduardo.


  4. Tem certeza que não tem outro Squid rodando na máquina? Talvez um processo bobo que não morreu... um firewall que esteja bloqueando a porta 3128?


    Abraços!



  5. #5
    eduardoalbano

    Esta tudo liberado. Tenho certeza que nao tem outro processo qdo dou stop e start no serviço olha o que acontece:

    fwmportos:~# /etc/init.d/squid stop
    /etc/init.d/squid: line 137: log_daemon_msg: command not found
    ...done.
    fwmportos:~# /etc/init.d/squid start
    /etc/init.d/squid: line 129: log_daemon_msg: command not found
    * Creating squid spool directory structure
    2006/05/03 12:34:58| Creating Swap Directories
    ...done.


    Olha o que ja fiz:

    chmod 777 /var/spool/squid
    chmod 777 /var/cache/squid
    squid -z


    To começando a ficar louco.
    Antes disso fiz backup de todos meus arquivos de instalação e reinstalei tudo. Ele chegou a startar e o serviço terminou inesperavelmente. E voltou a dar a msm mensagem de erro.

    sera que tem algum arquivo de eu tenha que zerar ou limpar que eu esteja esquecendo?

    []´s

    Eduardo.






Tópicos Similares

  1. Squid não inicia
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-10-2004, 17:14
  2. Compilação Squid - Não inicia !!!
    Por Beto no fórum Servidores de Rede
    Respostas: 6
    Último Post: 01-06-2004, 20:35
  3. Squid não inicia
    Por guardian_metal no fórum Servidores de Rede
    Respostas: 17
    Último Post: 29-09-2003, 16:11
  4. Squid não inicia
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 11-06-2003, 14:02
  5. Squid não inicia
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 11-06-2003, 12:27

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L