+ Responder ao Tópico



  1. #1
    slacklex
    Olá pessoal, atualmente uso o squid em modo transparente, só que agora estou tentando colocar em modo autenticado via ncsa_auth mas quando vou abrir o browser no cliente não pede senha nenhuma... Fiz o s seguintes passos:

    Criei o arquivo abaixo
    touch /etc/squid/passwd

    Adicionei o seguinte usuario abaixo
    htpasswd /etc/squid/passwd alex

    Coloquei o seguinte no meu squid.conf:

    auth_param basic program /usr/libexec/ncsa_auth /etc/squid/
    auth_param basic children 5
    auth_param basic realm Digite seu Login


    e no final do arquivo comentei as seguintes opções:

    #httpd_accel_host virtual
    #httpd_accel_port 80
    #httpd_accel_with_proxy on
    #httpd_accel_uses_host_header on

    No entanto quando vou acessar o browser no cliente não pede nenhuma senha.. o que mais tá faltando fazer pra dar certo??

  2. Vc ja definiu no browser, como endereço de servidor de proxy, o ip da maq q o squid esta rodando?



  3. #3
    slacklex
    sim ja defini

  4. Fiz o teste no squid c/ autenticação uma vez, como sou iniciante naum posso ajudar mto, porém vou deixar a copia do meu squid.conf p/ tentar te ajudar.

    http_port 3128
    cache_dir null /var/spool/squid #No meu caso eu não faço cache, só controle de acessos
    cache_mem 64 mb #Como é um teste deixei c/ pouca memória
    cache_swap_low 90
    cache_swap_high 95
    maximum_object_size 4096 kb
    client_netmask 255.255.255.0
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY

    cache_access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.log
    cache_store_log /var/log/squid/cache.log

    auth_param basic program /usr/local/squid/libexec/ncsa_auth /etc/squid/usuarios
    auth_param basic children 5
    auth_param basic credentialsttl 2 hours

    acl manager proto cache_object

    acl all src 0/0
    acl localhost src 127.0.0.1
    acl lan src 192.168.12.0/24

    acl bloquear_spy url_regex -i "/etc/squid/spywares"
    acl liberar_palavras url_regex -i "/etc/squid/palavras"
    #acl download urlpath_regex -i "/etc/squid/extensoes"
    acl autentica proxy_auth REQUIRED
    acl manha time MTWHF 11:45-12:10
    acl tarde time MTWHF 17:00-18:10
    acl sabado time A 11:00-13:10

    http_access allow localhost
    http_access deny bloquear_spy
    #http_access deny download
    http_access allow liberar_palavras
    http_access allow manha lan
    http_access allow tarde lan
    http_access allow sabado lan
    http_access allow lan autentica
    http_access deny all

    icp_access allow all
    miss_access allow all
    cache_effective_user squid
    cache_effective_group squid

    httpd_accel_host virtual
    httpd_accel_port 80
    #httpd_accel_single_host off
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    Espero ter ajudado.



  5. #5
    slacklex
    Já descobri o problema, bem simples: tinha esquecido de indicar ao ncsa_auth qual o arquivo de autenticações hauhahauauh alinha correta esta abaixo:

    auth_param basic program /usr/libexec/ncsa_auth /etc/squid/passwd


    :mrgreen:






Tópicos Similares

  1. Respostas: 10
    Último Post: 05-06-2009, 14:42
  2. autenticação squid nao esta funcionando
    Por muganga no fórum Servidores de Rede
    Respostas: 6
    Último Post: 18-02-2004, 12:50
  3. Meu SMTP do Qmail não esta funcionando Rede Externa!!!!
    Por maiconovic no fórum Servidores de Rede
    Respostas: 3
    Último Post: 18-10-2003, 09:08
  4. Respostas: 10
    Último Post: 11-06-2003, 07:20
  5. acl no squid não está funcionando. O que fazer ?
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 20-12-2002, 16:01

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L