+ Responder ao Tópico



  1. #1

    Padrão Problema com o CUPS.

    Bom dia pessoal.
    Estou tendo problema para adicionar uma nova fila de impressão no CUPS. Eu verifiquei o arquivo /etc/cups/printers.conf e lá mostra a nova fila, porém quando eu tento imprimir alguma coisa nela (seja via lpr ou via samba) simplesmente não sai nada... como se essa fila de impressão não existisse.

    As filas já existentes estão funcionando normalmente... o problema está sendo quando eu adiciono uma nova fila.

    Alguém saberia me ajudar?

  2. #2

    Padrão Re: Problema com o CUPS.

    Citação Postado originalmente por andunno
    Bom dia pessoal.
    Estou tendo problema para adicionar uma nova fila de impressão no CUPS. Eu verifiquei o arquivo /etc/cups/printers.conf e lá mostra a nova fila, porém quando eu tento imprimir alguma coisa nela (seja via lpr ou via samba) simplesmente não sai nada... como se essa fila de impressão não existisse.

    As filas já existentes estão funcionando normalmente... o problema está sendo quando eu adiciono uma nova fila.

    Alguém saberia me ajudar?
    Qual a sua distribuição e a versão do seu CUPS?



  3. #3

    Padrão Re: Problema com o CUPS.

    Estou utilizando RedHat ES 3.0 com cups-1.1.17-13.3.6.
    Ao longo do dia eu fiz alguns testes e percebi o seguinte... quando eu crio uma nova fila de impressão, ela funciona via lpr, porém não via samba. Quando eu tento utilizar essa fila de impressão através de uma estação Windows, aparece as seguintes mensagens em /var/log/cups/error_log.

    D [08/May/2006:16:23:06 -0300] AcceptClient() 6 from localhost:631.
    D [08/May/2006:16:23:06 -0300] ReadClient() 6 POST /printers/cpd_dj03 HTTP/1.1
    D [08/May/2006:16:23:06 -0300] print_job: auto-typing file...
    D [08/May/2006:16:23:06 -0300] print_job: request file type is application/octet -stream.
    D [08/May/2006:16:23:06 -0300] check_quotas: requesting-user-name = 'andre'
    D [08/May/2006:16:23:06 -0300] print_job: requesting-user-name = 'andre'
    D [08/May/2006:16:23:06 -0300] Adding default job-sheets values "none,none"...
    I [08/May/2006:16:23:06 -0300] Job 2395 queued on 'cpd_dj03' by 'andre'.
    D [08/May/2006:16:23:06 -0300] Job 2395 hold_until = 0
    D [08/May/2006:16:23:06 -0300] StartJob(2395, 0x8123e00)
    D [08/May/2006:16:23:06 -0300] StartJob() id = 2395, file = 0/1
    E [08/May/2006:16:23:06 -0300] Unable to convert file 0 to printable format for job 2395!
    I [08/May/2006:16:23:06 -0300] Hint: Do you have ESP Ghostscript installed?
    D [08/May/2006:16:23:06 -0300] CancelJob: id = 2395
    D [08/May/2006:16:23:06 -0300] ProcessIPPRequest: 6 status_code=0
    D [08/May/2006:16:23:06 -0300] CloseClient() 6
    D [08/May/2006:16:23:10 -0300] ReadClient() 4 POST / HTTP/1.1
    D [08/May/2006:16:23:10 -0300] ProcessIPPRequest: 4 status_code=1
    E [08/May/2006:16:23:10 -0300] [Job 857] Unable to connect to SAMBA host, will retry in 60 seconds...ERROR: Connection failed with error NT_STATUS_BAD_NETWORK_NAME