+ Responder ao Tópico



  1. #1
    PRISCILASCHU
    Visitante

    Padrão Velox mudou...me ajudem por favor

    Por favor me ajudem, o Velox mudou a forma de autenticação, tenho um servidor Linux Red Hat 9 que fazia a autenticação e o roteamento mas agora que a forma mudou o servidor não está mais fazendo a autenticação.

    Eu usava um script de autenticação do Fabio Vilan da página www.isec.com.br/velox

    Alguém tem um script novo?

    Muito obrigada,
    Priscila

  2. #2

    Padrão Re: Velox mudou...me ajudem por favor

    #!/bin/sh
    ADSL_START= #aqui vc coloca o caminho que é executado o adsl-start #

    # Quem sou eu ?..
    MEUNOME="`basename $0`"

    # Para testar se a interface pppoe já está ativa
    IFCONFIG="/sbin/ifconfig"
    PPPOE_INTRF="ppp0"

    {


    # Testa se é necessário disparar a conexão pppoe
    if ( ! ($IFCONFIG $PPPOE_INTRF > /dev/null 2>&1) ); then

    # A interface não existe, vamos tentar criar
    if [ -x "$ADSL_START" ]; then

    echo "Ligando a conexao PPPOE..."

    $ADSL_START # Cria a conexao ppp0 (suponho que vc já configurou a
    # conexão com adsl-setup)
    fi
    fi

    }

    echo "$MEUNOME: Já autenticado. Saindo..."
    exit 0





    Salve esse script em um arquivo, e coloque pra rodar no cron,
    obs: esse script só faz a conexão, as atualizações da velox vc tem que mudar quando executar o adsl-setup.



  3. #3
    toniati
    Visitante

    Padrão Re: Velox mudou...me ajudem por favor

    Meu caro...até onde sei....vc num precisa de script nenhum mais.....
    Agora...quando vc configurar o ADSL-SETUP....na hora do login coloca
    [email protected] e num precisa mais entrar no veloxzone

  4. #4

    Padrão Re: Velox mudou...me ajudem por favor

    Sim , mais esse script funciona da seguinte forma. fica verificando se há status de conexão posivitivo, caso contrário percebendo que não há conexão, ele start novamente a dsl.
    É uma forma de garantir a conexão sempre ativa.



  5. #5

    Padrão Re: Velox mudou...me ajudem por favor

    Citação Postado originalmente por rodriguesoline
    #!/bin/sh
    ADSL_START= #aqui vc coloca o caminho que é executado o adsl-start #

    # Quem sou eu ?..
    MEUNOME="`basename $0`"

    # Para testar se a interface pppoe já está ativa
    IFCONFIG="/sbin/ifconfig"
    PPPOE_INTRF="ppp0"

    {


    # Testa se é necessário disparar a conexão pppoe
    if ( ! ($IFCONFIG $PPPOE_INTRF > /dev/null 2>&1) ); then

    # A interface não existe, vamos tentar criar
    if [ -x "$ADSL_START" ]; then

    echo "Ligando a conexao PPPOE..."

    $ADSL_START # Cria a conexao ppp0 (suponho que vc já configurou a
    # conexão com adsl-setup)
    fi
    fi

    }

    echo "$MEUNOME: Já autenticado. Saindo..."
    exit 0
    fi
    fi
    Meu caro Rodrigues,

    Desculpe se estou enganado (comecei a estudar shell script agora), mas, esses dois "fi's" do final, estão fechando quais "if's"?

    Obrigado.

  6. #6

    Padrão Re: Velox mudou...me ajudem por favor

    Citação Postado originalmente por Lipse
    Citação Postado originalmente por rodriguesoline
    #!/bin/sh
    ADSL_START= #aqui vc coloca o caminho que é executado o adsl-start #

    # Quem sou eu ?..
    MEUNOME="`basename $0`"

    # Para testar se a interface pppoe já está ativa
    IFCONFIG="/sbin/ifconfig"
    PPPOE_INTRF="ppp0"

    {


    # Testa se é necessário disparar a conexão pppoe
    if ( ! ($IFCONFIG $PPPOE_INTRF > /dev/null 2>&1) ); then

    # A interface não existe, vamos tentar criar
    if [ -x "$ADSL_START" ]; then

    echo "Ligando a conexao PPPOE..."

    $ADSL_START # Cria a conexao ppp0 (suponho que vc já configurou a
    # conexão com adsl-setup)
    fi
    fi

    }

    echo "$MEUNOME: Já autenticado. Saindo..."
    exit 0
    Meu caro Rodrigues,

    Desculpe se estou enganado (comecei a estudar shell script agora), mas, esses dois "fi's" do final, estão fechando quais "if's"?

    Obrigado.
    Foi um erro ao copiar e colar, ignore pois não precisava.