Galerinha, já baixei o script rc.bandlimit e o CBQ. Mais não estou conseguindo configurar o CBQ para controlar a banda da rede interna da empresa que trabalho. Na hora que mando cbq compile ele passa e aparece uma messagem:

###########################################################

[email protected]:/# cbq compile
/sbin/tc qdisc del dev eth0 root
/sbin/tc qdisc add dev eth0 root handle 1 cbq bandwidth 10Mbit avpkt 1000 cell 8
/sbin/tc class change dev eth0 root cbq weight 1Mbit allot 1514

**CBQ: class ID of cbq-0001.bruno_in512k must be in range <0002-FFFF>!
/sbin/tc qdisc del dev lo root
/sbin/tc qdisc del dev eth0 root
/sbin/tc qdisc del dev eth1 root
/sbin/tc qdisc del dev ppp0 root
[email protected]:/#

###########################################################

Na pasta interfaces eu crie a interface eth0 que é a placa de rede usada para jogar todo o trafego da internet para rede interna da empresa. a interface ppp0 é criada automaticamente quando me conecto pelo servidor slacware 10.2 da empresa e a eth1 é usanda junto com a ppp0 do velox porque nessa placa de rede é onde está ligado o cabo de rede entre pc e modem. na hora que rodo o rc.bandlimit aparece a messagem:

[email protected]:/# /etc/rc.d//rc.bandlimit
CBQ: "allot" is required to set WRR parameters.
RTNETLINK answers: Invalid argument
CBQ: "allot" is required to set WRR parameters.
RTNETLINK answers: Invalid argument
CBQ: "allot" is required to set WRR parameters.
RTNETLINK answers: Invalid argument
CBQ: "allot" is required to set WRR parameters.
RTNETLINK answers: Invalid argument
CBQ: "allot" is required to set WRR parameters.
RTNETLINK answers: Invalid argument
CBQ: "allot" is required to set WRR parameters.
RTNETLINK answers: Invalid argument
CBQ: "allot" is required to set WRR parameters.
RTNETLINK answers: Invalid argument
CBQ: "allot" is required to set WRR parameters.
RTNETLINK answers: Invalid argument
CBQ: "allot" is required to set WRR parameters.
[email protected]:/#

Não sei o que está errado, alguém poderia me ajudar........