Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá pessoal,

    Estou compilando o apache-2.2.2, só que está me gerando o seguinte erro:

    ./configure --prefix=/usr/local/apache-2.2.2 --sysconfdir=/etc/apache --enable-so --enable-ssl --enable-php --enable-mysql

    Até ai td certinho, .....

    ma quando do o camando make, gero o seguinte erro:

    pthread -DHAVE_CONFIG_H -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SO URCE -I/opt/httpd-2.2.2/srclib/apr-util/include -I/opt/httpd-2.2.2/srclib/apr- util/include/private -I/opt/httpd-2.2.2/srclib/apr/include -I/opt/httpd-2.2.2/ srclib/apr-util/xml/expat/lib -o buckets/apr_buckets_flush.lo -c buckets/apr_bu ckets_flush.c && touch buckets/apr_buckets_flush.lo
    /bin/sh /opt/httpd-2.2.2/srclib/apr/libtool --silent --mode=compile gcc -g -O2 - pthread -DHAVE_CONFIG_H -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SO URCE -I/opt/httpd-2.2.2/srclib/apr-util/include -I/opt/httpd-2.2.2/srclib/apr- util/include/private -I/opt/httpd-2.2.2/srclib/apr/include -I/opt/httpd-2.2.2/ srclib/apr-util/xml/expat/lib -o crypto/apr_sha1.lo -c crypto/apr_sha1.c && tou ch crypto/apr_sha1.lo
    /bin/sh /opt/httpd-2.2.2/srclib/apr/libtool --silent --mode=compile gcc -g -O2 - pthread -DHAVE_CONFIG_H -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SO URCE -I/opt/httpd-2.2.2/srclib/apr-util/include -I/opt/httpd-2.2.2/srclib/apr- util/include/private -I/opt/httpd-2.2.2/srclib/apr/include -I/opt/httpd-2.2.2/ srclib/apr-util/xml/expat/lib -o crypto/apr_md4.lo -c crypto/apr_md4.c && touch crypto/apr_md4.lo
    crypto/apr_md4.c: In function `MD4Transform':
    crypto/apr_md4.c:363: internal compiler error: in refers_to_regno_for_reload_p, at reload.c:6199
    Please submit a full bug report,
    with preprocessed source if appropriate.
    See <URL:http://gcc.gnu.org/bugs.html> for instructions.
    make[3]: *** [crypto/apr_md4.lo] Error 1
    make[3]: Leaving directory `/opt/httpd-2.2.2/srclib/apr-util'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/opt/httpd-2.2.2/srclib/apr-util'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/opt/httpd-2.2.2/srclib'
    make: *** [all-recursive] Error 1


    Já reinstalei as (gcc -3 - gcc-g77 - gcc-g++) mas continua a mesma coisa.
    Alguem pode me ajudar?

  2. vixi parece que vc encontrou um bug msm, tenta atualizar teu gcc



  3. #3
    rafaeldw
    ja tentou com outra versão do apache? (só para testar..)

  4. Como que eu atualizo o gcc?


    Ja tentei outra versão do apache mas não deu, o problema é comm o gcc mesmo.


    Valeu



  5. Tenta da seguinte forma so pra testar

    ./configure --prefix=/usr/local/apache --enable-so --enable-ssl --enable-php --enable-mysql


    E posta o resultado !!!

    Abraçao






Tópicos Similares

  1. Erro ao compilar o links-2.1pre13
    Por Francisco14 no fórum Servidores de Rede
    Respostas: 4
    Último Post: 09-07-2004, 12:14
  2. Erro ao compilar mysql++
    Por NeoRamza no fórum Servidores de Rede
    Respostas: 2
    Último Post: 17-05-2004, 23:33
  3. Erro ao compilar o module-init-tool
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 2
    Último Post: 01-03-2004, 23:00
  4. erro ao compilar o samba
    Por APS no fórum Servidores de Rede
    Respostas: 0
    Último Post: 03-10-2003, 11:27
  5. Erro ao compilar o Kernel
    Por fsales no fórum Servidores de Rede
    Respostas: 1
    Último Post: 22-04-2003, 02:50

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L