+ Responder ao Tópico



  1. #1
    juniox
    Visitante

    Padrão Apache2 + Perl

    Ae, estou com um problema pra configurar o apache2 com o mod_perl2.
    Depois de seguir um tutorial, aconteceu o seguinte erro ao tentar reiniciar o apache2

    Syntax error on line 395 of /etc/apache2/apache2.conf:
    Cannot load /usr/lib/apache2/modules/mod_perl.so into server: /usr/lib/apache2/modules/mod_perl.so: undefined symbol: PL_ppaddr
    eis a linha 395
    rt:/home/juniox/mod_perl-2.0.2# cat -n /etc/apache2/apache2.conf | grep 395
    395 LoadModule perl_module /usr/lib/apache2/modules/mod_perl.so
    mas esse arquivo existe, está lá.

    alguma sugestão?

  2. #2
    juniox
    Visitante

    Padrão Re: Apache2 + Perl

    olá galera
    ninguém sabe mesmo?
    to precisando disso com uma certa urgência
    revirei o google, já achei algumas pessoas (do exterior) com o MESMO problema mas também sem respostas

    :-(



  3. #3
    kr4mus
    Visitante

    Padrão Re: Apache2 + Perl

    Bom dia!

    Estranho isso velho! Mas pelo que aparenta nos logs, o apache não está conseguindo carregar o módulo.
    De uma olhada nas permissões desse arquivo, e se for necessário, mude para o usuário do apache com o comando chown.

    Faça isso e teste novamente. Qualquer coisas poste aqui que tentarei ajudar.

    Valew,
    Marcus Burghardt

  4. #4
    juniox
    Visitante

    Padrão Re: Apache2 + Perl

    recomecei do zero...
    fui instalar o mod_perl2 aqui, dai na hora de rodar o "perl Makefile.PL" ele retorna:

    Please provide a full path to 'apxs' executable
    (press Enter if you don't have it installed): APERTEI ENTER não achei o /usr/bin/apxs ou algo parecido


    Please provide the location of the Apache directory: /etc/apache2
    [ error] Unable to open /etc/apache2/ap_release.h: Arquivo ou diretório não encontrado
    [ error] Unable to determine server version, aborting.
    [ error] Please specify MP_APXS or MP_AP_PREFIX.

    alguém sabe algo a respeito?



  5. #5
    juniox
    Visitante

    Padrão Re: Apache2 + Perl

    seguinte, o meu problema foi resolvido instalando o apache2-dev, porém agora tenho outro problema:

    fefnet139:~# apache2ctl start
    Syntax error on line 10 of /etc/apache2/sites-enabled/000-default:
    Invalid command 'Rewrite', perhaps mis-spelled or defined by a module not included in the server configuration
    a linha 10 é:
    Rewrite Engine On
    eu instalei o RT (request tracker) com mod_perl2 e apache2, e adicionei as seguintes linhas no /etc/apache2/sites-enabled/000-default

    <VirtualHost XXX.XXX.XXX.XXX>
    ServerName XXX.XXX.XXX.XXX
    DocumentRoot /opt/rt3/share/html
    AddDefaultCharset UTF-8

    ### estas 5 linhas somente para o Apache2+mod_perl2
    PerlSetVar MasonArgsMethod CGI
    PerlModule Apache2 Apache::compat
    Rewrite Engine On
    RewriteRule ^(.*)/$ $1/index.html
    RedirectMatch permanent (.*)/$ http://XXX.XXX.XXX.XXX$1/index.html
    ###

    PerlModule Apache:BI
    PerlRequire /opt/rt3/bin/webmux.pl

    <Location />
    SetHandler perl-script
    PerlHandler RT::Mason
    </Location>

    </VirtualHost>
    alguém sabe o que há de errado?

  6. #6

    Padrão Re: Apache2 + Perl

    O apache não parece ter sido compilado com mod_rewrite ou ele não ta carregado.
    Se vc tem certeza que compilou com mod_rewrite verifique se existem no arq de conf as linhas:

    LoadModule rewrite_module libexec/mod_rewrite.so
    AddModule mod_rewrite.c

    ou parecida.

    Falou